Cover art doesn't appear after iOS 8.4.1 upgrade

Discussion in 'iPod Touch' started by RVojvoda, Aug 26, 2015.

Europa
Best Answer Europa, Aug 27, 2015
In iTunes on your computer, press the music icon in the upper left, then My Music on the left side of the controls in the center, then select Songs in... Go to Full Post
  1. RVojvoda

    RVojvoda New Member

    Joined:
    May 10, 2010
    Likes Received:
    0
    OK. So I upgraded my software and now my cover art does not appear either on my ipod touch or on the display of my vehicle. Any suggestions?
     
  2. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    4,434
    I never heard of 8.4.2. Did you mean 8.4.1?
     
  3. RVojvoda

    RVojvoda New Member

    Joined:
    May 10, 2010
    Likes Received:
    0
    Sorry, fat fingers. It was 8.4.1
     
  4. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,435
    This is a bug with Apple Music. Are you using Apple Music? If not, toggle off iCloud Music Library in the music settings on your phone. If this doesn't fix it, I'll post some additional things to try.
     
  5. RVojvoda

    RVojvoda New Member

    Joined:
    May 10, 2010
    Likes Received:
    0
    I don't have an iPhone but rather an touch. I checked music under settings and there is no iCloud switch. But I did switch off iCloud under the iCloud setting but to no avail. More suggestions would be appreciated. Thanks.
     
  6. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,435
    No, that's the wrong place. You don't want to turn off iCloud. You just need to turn off the iCloud Music Library.

    1. Do you have this toggle?:
    Settings > Music > Library > iCloud Music Library > Off

    2. Are you using Apple Music?
     
  7. RVojvoda

    RVojvoda New Member

    Joined:
    May 10, 2010
    Likes Received:
    0
    I do not have that setting available to me. I turned off apple music and it didn't make a difference.
     
  8. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,435
    In iTunes on your computer, press the music icon in the upper left, then My Music on the left side of the controls in the center, then select Songs in the upper right. Check the boxes for Show Artwork and Always Show and sync your iPod.

    Screen Shot 2015-08-27 at 2.29.23 AM.png
    If the album art still doesn't show up after that, unsync all of your music through iTunes and then resync it.
     
    Best Answer
  9. RVojvoda

    RVojvoda New Member

    Joined:
    May 10, 2010
    Likes Received:
    0
    Tried your suggestion and have cover art in iTunes but still no on the iPod touch.
     
    #9 RVojvoda, Aug 27, 2015
    Last edited by a moderator: Aug 27, 2015
  10. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,435
    Did you unsync all of your music from the iPod and then sync it back on?
     
  11. RVojvoda

    RVojvoda New Member

    Joined:
    May 10, 2010
    Likes Received:
    0
    Tried hard reset and resend. No good. Did a total reset and a resend. Success!!! Thanks to everyone for the help.
     

Share This Page