Cover art doesn't appear after iOS 8.4.1 upgrade

RVojvoda

New Member
May 10, 2010
13
0
1
On the border
#1
OK. So I upgraded my software and now my cover art does not appear either on my ipod touch or on the display of my vehicle. Any suggestions?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#4
This is a bug with Apple Music. Are you using Apple Music? If not, toggle off iCloud Music Library in the music settings on your phone. If this doesn't fix it, I'll post some additional things to try.
 

RVojvoda

New Member
May 10, 2010
13
0
1
On the border
#5
I don't have an iPhone but rather an touch. I checked music under settings and there is no iCloud switch. But I did switch off iCloud under the iCloud setting but to no avail. More suggestions would be appreciated. Thanks.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#6
No, that's the wrong place. You don't want to turn off iCloud. You just need to turn off the iCloud Music Library.

1. Do you have this toggle?:
Settings > Music > Library > iCloud Music Library > Off

2. Are you using Apple Music?
 

RVojvoda

New Member
May 10, 2010
13
0
1
On the border
#7
I do not have that setting available to me. I turned off apple music and it didn't make a difference.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#8
In iTunes on your computer, press the music icon in the upper left, then My Music on the left side of the controls in the center, then select Songs in the upper right. Check the boxes for Show Artwork and Always Show and sync your iPod.

Screen Shot 2015-08-27 at 2.29.23 AM.png

If the album art still doesn't show up after that, unsync all of your music through iTunes and then resync it.
 

RVojvoda

New Member
May 10, 2010
13
0
1
On the border
#9
Tried your suggestion and have cover art in iTunes but still no on the iPod touch.
 
Last edited by a moderator:

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#10
Tried your suggestion and have cover art in iTunes but still no on the it ouch.
Did you unsync all of your music from the iPod and then sync it back on?
 

RVojvoda

New Member
May 10, 2010
13
0
1
On the border
#11
Tried hard reset and resend. No good. Did a total reset and a resend. Success!!! Thanks to everyone for the help.