Customizing text alert

Rgn

Contributor
Bronze
Apr 29, 2013
113
36
28
#1
Hello, I can see the text tone I selected on sounds menu and when I push it will play. But for receiving texts it doesn't play the alert I selected,. I get the sound when the text is filled out and delivered. is there anyway to fix that?
 
Last edited:

Rafagon

Genius
Gold
Dec 7, 2011
7,566
1,254
113
45
Miami, Florida
#2
Hello, I can see the text tone I selected on sounds menu and when I push it will play. But for receiving texts it doesn't play the alert I selected,. I get the sound when the text is filled out and delivered. is there anyway to fix that?
So, to see if I understood correctly, the custom sound you chose for incoming texts doesn't play when you receive a text, but rather, when you send a text (you wrote "when the text is filled out and delivered")? That is quite odd. iOS allows you to customize the sound you hear when you receive a text, but when you send a text, it is always the same sound: "WooooOOOP!" (which plays immediately after the text is sent).

Here's an thread on the Apple Suppport Communities that states that the outgoing message tone is unconfigurable. The most you can do is silence it. So I'm clueless as to how your phone is making the sound when sending an outgoing text. (Again, assuming I understood your post correctly.)
 

Rgn

Contributor
Bronze
Apr 29, 2013
113
36
28
#3
Oh no I didn't explain correctly the whoop there are too kinds in a conversation. sending and receiving. those are the only sounds I'm getting I understand I can not change the sending. I was trying to see if I could get the sound I selected on the menu to play when I receive a text.
 

Rafagon

Genius
Gold
Dec 7, 2011
7,566
1,254
113
45
Miami, Florida
#4
Oh no I didn't explain correctly the whoop there are too kinds in a conversation. sending and receiving. those are the only sounds I'm getting I understand I can not change the sending. I was trying to see if I could get the sound I selected on the menu to play when I receive a text.
Okay, so you have picked a text tone, for example:

photo.PNG (thumbnail, click to expand)

And when you go to your Contacts, pick any contact, tap on Edit, and scroll down to where it says "Text Tone", is it set to "Default"?

And still, you're not hearing the text tone you select?

ADDENDUM: If you are still in the same conversation screen that is currently taking place when a new text message comes in (from that same person), then yes, there is only one sound it will play... the "receive" version of the "WOOOOooooop" that you hear when you send a message. You only hear the custom text tone if you're not still in the same conversation with the person you're already texting, or if you're doing something else on your phone (checking your mail, for example). For example, text yourself at your own phone number, and don't navigate away from that screen. You will hear the same "WOOOOOoooooop" because you're already in that conversation, and NOT the custom text tone you selected.
 
Last edited:
C

Charlotte Bolton

Guest
#5
I wish I could apply this to group chats
 

Rgn

Contributor
Bronze
Apr 29, 2013
113
36
28
#6
@ Rafagon I actually had to allow notifications for it to play my text tone. I did understand and knew about leaving the conversation is when you get the custom ringtone. I wasn't getting the text tone when I was out of the conversation. And for a minute there I thought I would have to check texts the way I check my email (what's on here today).
I usually don't have notification on but with the new updates I felt the need to check all the settings for apps and notifications. I have the sound notification on and the badges, alerts display on lock screen off. When I got the text tone receiving text alert I was saying yay it works lol.
 
Last edited: