Cydia Errors - Failed to Fetch & Some index files failed to download...

Discussion in 'Cydia Apps' started by tvbykr, Apr 19, 2013.

  1. tvbykr

    tvbykr New Member

    Joined:
    Apr 19, 2013
    Likes Received:
    0
    Hello all,

    I have been facing the below error (check inserted image) for quiet a few days. Due to this i am unable to install any apps!
    "I have tried deleting all the files under /private/var/lib/apt/lists apart from empty partial folder, but not worked."

    Well I guess I have a clue for this errors...The errors which I get belong to repositories like Bigboss, Saurik, Repo666 & Modmyi BUT NOT FOR ZODTTD, though I have five respositories added(check images). When I have tried to know the reason, I found that there was a package file for ZODTTD(8.8MB, check image). The similar package files are not available for rest of the 4 error giving repositories.

    Well the question is, are the errors thrown is because of the missing package files? If so, could anyone provide me the missing packages from your iPhone, so that i can place them & try if works!,
    photo 1.PNG photo 2.PNG photo 3.PNG
    I would be glad if someone could help me in fix this. Thanks.

    For your info I have iFile and MobileTerminal which could be helpful in troubleshooting.
     
  2. iphonewarrior

    iphonewarrior Moderator
    Moderator

    Joined:
    Apr 11, 2008
    Likes Received:
    701
    Can you install iCleaner? It may be a useful tool to clear those errors in Cydia.

    If you can't install it via Cydia you can SSH the .deb file onto your device ((if you have OpenSSH installed) or use iFile's webserver utility) and use the AutoInstall facility. iCleaner is a great app!
     
  3. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,520
    Try this. You can use iFile, DiskAid, SSH, iFun-Box, or any other app that gives you root privileges.

    1. Go to /private/etc/apt/sources.list.d and delete "cydia.list."
    2. Go to /var/lib/apt/lists and delete everything except the "lock" file and the "partial" folder.
    3. Go to /var/lib/apt/list/partial and delete all the files in that folder.
    4. Go to /var/lib/cydia and delete "metadata.plist."
    5. Restart Cydia. You will see the same screen you see the first time you open it after jailbreaking. It will regenerate you sources, ask what type of user you are and it should fix the "Failed to fetch" errors.
     
Similar Threads
  1. kian
    Replies:
    13
    Views:
    4,459
  2. Goodlife08
    Replies:
    4
    Views:
    2,609
Loading...

Share This Page