Cydia is Dead

Oct 14, 2008
15
0
1
#1
While downloading a theme called Illumine from Cydia, it went to the reboot screen while going through the process.
It took a bit to reboot, but afterward... Cydia now doesn't work.

It starts to come up but then just crashes back to the Springboard.

Someone PLEASE tell me there's a way to remedy this... without having to re-jailbreak, and reinstall ALL of my stuff back onto my phone...!

(Possibly somehow downloading Cydia onto my PC and SSH'ing it oto my phone someway...? I dunno.)

Also there have been updates on Cydia that I have been downloading & installing for Mobile Substrate.
I have NO clue what this is, and am not really sure if it's supposed to be on my new 3.0 firmwarte or not, but have been updating it because it comes up in Cydia as something that needs and update. Am I right in updaing this?

Thanks!
 
Jul 18, 2009
26
0
0
34
Morganton, NC
www.myspace.com
#2
I have also been updating that Substrate thing. But like you, I don't know if it's supposed to be there.

As far as Cydia crashing, I had that problem before I unlocked the phone because without the SIM working I couldn't browse on our wireless network. This was AFTER the jailbreak, so maybe try to unlock it again?

I don't know, I'm a complete amateur at this, I just got my phone yesterday, but I'm exploring all the wonderful options available to jailbroken phones. Just trying to help out :)
 

Skimball

Member
Bronze
Sep 7, 2008
83
0
6
KC
#3
My Cydia has also stopped functioning. I used it yesterday and did the mobile substrate upgrade and today it crashes back to springboard. I also reran the jailbreak today but Cydia still does not function.
 

partizan

Member
Bronze
Feb 25, 2008
302
3
18
Milton, Ontario
#4
Mine works fine. MobileSubstrate is used for running Winterboard among other things, so if you want to change the look of your iPhone then you must have the Substrate. Also, it's required by Backgrounder. Hope this helps.
 

efuseakay

Contributor
Silver
Nov 11, 2008
864
99
28
#5
Yup... DOA here too. Crashes straight to springboard after a few seconds.

And I've noticed my springboard has been crashing while plugged into the computer... this all happened with the recent updates of Mobile Substrate.
 

kakofonix

Member
Silver
Oct 2, 2007
596
0
16
#6
I'm having the same issue with Cydia. Wonder if this a user-specific problem. I'm not too bummed though as I have Icy.
 

carrera.owner

New Member
Bronze
Aug 31, 2008
164
0
0
Long Island, NY
#7
I've read that SBSettings did cause cydia crashings.....perhaps that is the culprit? I'm not using SB yet as I don't think it's ready for primetime, imo anyway
 

crystus

Member
Bronze
Jul 5, 2009
258
1
18
Deltona, FL
#8
Same thing happened to me yesterday. I tried re jailbreaking it and it didn't fix it. So I just restored to stock and rejailbroke.
 

efuseakay

Contributor
Silver
Nov 11, 2008
864
99
28
#9
Delete everything from /var/lib/apt/lists except the "partial" folder. Cydia is working again after doing this. :)
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#10
Delete everything from /var/lib/apt/lists except the "partial" folder. Cydia is working again after doing this. :)
Does this actually work though?


I'm surprised nothings' been released- to let people know that there are issues.
 

bredfan

New Member
Bronze
Dec 15, 2007
41
0
0
#12

efuseakay

Contributor
Silver
Nov 11, 2008
864
99
28
#13
Does this actually work though?


I'm surprised nothings' been released- to let people know that there are issues.
Worked for me... had to re-install the "all sources" thing though. That was a bit tricky, but I eventually lucked out and got everything working.