DMG Pwnage folder has no IPSW files

Jan 16, 2009
3,230
13
38
59
Mississippi
#1
I am having the hardest time with 1 problem that no one seems to be able to answer.

I followed the link for 3GS - Windows 3.0 to iClarified
I created pwnage folder
I downloaded the redsnow 0.8 link
I downloaded the http://appldnld.apple.com.edgesuite...090617.LlI87/iPhone2,1_3.0_7A341_Restore.ipsw
I extract redsnow into the folder
I Connect my iPhone to the computer and launch iTunes
I select my iPhone
I press and hold "shift" whild pressing restore
I browse to the pwnage folder but there are no ipsw files

The files are .DMG not .IPSW
I tried this on my Vista and XP machine to no avail. Surely someone has an answer for this. I tried google for a DMG extractor and there are plenty, I tried several of them to no avail.

This is supposed to be simple.
Thanks
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#2
Download PowerISO, there is a trial version, and use it to extract the ipsw from the DMG file.

The link you posted is to an ipsw file, not a DMG....did you use safari to download the file?
 
Jan 16, 2009
3,230
13
38
59
Mississippi
#6
Hey Shutter I've redownloaded again, actually 8-10 times on 3 different PCs and every time the files have dmg extensions. I downloaded that PowerISO program but it doesn't list ispw as an extension so it extracted to a daa extension. I could have chosen iso or some other extension.:(
 

bls8195

Member
Bronze
Apr 23, 2008
222
0
16
Texas City, TX
#7
Yeah I am still having issue's as well, I downloaded it about 10 times, and still no luck.
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#8
Have a look here for the proper file and copy it to where you need it.

If you ever restored to 3.0 on vista it will be there.
C:\Users\[username]\AppData\Roaming\Apple Computer\iTunes\iPhone Software Updates
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#9
I just downloaded the file with firefox and it downloads as an ipsw file.
 
Jan 16, 2009
3,230
13
38
59
Mississippi
#11
I am JB! But now I hooked it back up to iTunes and it is stuck on the screen where I have to choose to set up as a new device or restore from backup. What do I do?

Come on and bail me out 1 more time Shutter!
 
Jan 16, 2009
3,230
13
38
59
Mississippi
#16
I'm fixing to restore as new.

Bummer! I have no clue. I'm fixing to have to restore mine and I'm sure I'll have to JB it again. I think after that I should be ok. I guess after it adds the firmware you have to restore as new before running the redsnow program. Make sure you are running redsnow 0.8 and not an older version.
Good luck!
 
Jan 16, 2009
3,230
13
38
59
Mississippi
#17
I didn't "restore as new" I "set up as new" and it didn't hurt a thing! So now I'm putting my music, apps, data, ect. back on.

Could I have restored from a backup or would that have un JBed my phone? That would sure be easier!