Do not disturb

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,580
113
Utah
#61
I'm not sure why email notifications are going through and calls if I toggle DND on through Control Center. Are there additional settings I should check? It's a mystery since my understanding of DND is that it should stop any sort of alerts our calls.
It should silence them all. Just make sure you see the moon icon in the status bar and no schedule is set unless you want it to stop at a certain time.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#62
@silvermoon - please can you screenshot your Do Not Disturb settings screen please and post it.

Here is mine (below). I use DND every single day, it works as it should. I do wish there was more control however it is what it is. Looking at my settings either during a scheduled DND period my phone will not ring unless it's from a contact listed in my favourites OR any contact ringing me twice within three minutes (you can turn this off).

At the bottom it says 'SILENCE' if you have this selected to ALWAYS your phone will NOT make a sound even if it's unlocked, unless you have a favourite calling. If you have this setting selected to Only while iPhone is locked... it will ring, make sounds when you receive a notification etc. Visual notification is the Moon on the status bar.

I'm not sure if you've disabled something or got it set to Only while iPhone is unlocked.

image.jpg
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#64
The settings are almost the same other than you accept calls from contacts that you have in favorites. I didn't have any problem with DND while I was at work. For now, I'm just going to stop using Siri to turn on DND and use the Control Center to toggle it on/off.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,580
113
Utah
#65
The settings are almost the same other than you accept calls from contacts that you have in favorites. I didn't have any problem with DND while I was at work. For now, I'm just going to stop using Siri to turn on DND and use the Control Center to toggle it on/off.
I think Siri is the problem here. I recall you having the same problem with an alarm a time or two when it was (supposedly) set by Siri. I'm not sure if you're checking to make sure it really set it or it's saying it's doing it but isn't. Either way, I'll think you'll be fine if you take Siri out of the equation.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#66
I've just tested this with Siri disabling/enabling Do Not Disturb. I tried with and without a favourite contact calling me and tested notifications. DND blocked everything - I'm completely at a loss as to why it's not working properly for you.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#67
I've just tested this with Siri disabling/enabling Do Not Disturb. I tried with and without a favourite contact calling me and tested notifications. DND blocked everything - I'm completely at a loss as to why it's not working properly for you.
Siri is useful in other ways. Just like last night, I asked Siri for a time check when I was in the shower our to use as a timer. I don't have the greatest luck with Siri for DND.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#68
It's working perfectly for me and I've tried it on a 4s as well and it's working as expected on that.

When you ask Siri to enable DND is the position of the toggle in the correct space i.e Green (like below)?

image.jpg
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#69
IMG_0368.PNG

I really need some help to figure out what might be the problem with my DND settings. So I was in class today and my phone went off again. I've checked to make sure that DND was on and the half moon icon was showing at the top in the notification bar. I silenced the call again, not sure what else to do. The pretty embarrassing part was that the instructor said that I now have to buy her two lattes. I like using DND when it works but if I have to, there is the mute switch but I'm hoping that I can just get DND to work properly.

I have never had so many problems with DND. If it helps, the way I'm turning on/off DND is through the Control Center.
 
Last edited:

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#70
Either it was a repeated call within three minutes of the original call or your DND is broken. Two options, first one restore and setup as new. Secondly, use the mute button.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#71
Either it was a repeated call within three minutes of the original call or your DND is broken. Two options, first one restore and setup as new. Secondly, use the mute button.
I looked at the phone log and the call only appears once. The person calling was not in my contacts and responding to my craigslist ad.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#72
I looked at the phone log and the call only appears once. The person calling was not in my contacts and responding to my craigslist ad.
With the settings pictured below i've just enabled DND manually on my phone then rang myself from another phone and the first call was rejected and I heard my own voicemail. I then rang myself straight back and it instantly rang as expected within the three minutes.
image.jpg
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#73
I've just tested it again with repeated calls disabled and rang myself and hit my voicemail everytime...

The guy must have rang you twice.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#74
I've just tested it again with repeated calls disabled and rang myself and hit my voicemail everytime...

The guy must have rang you twice.
How do you block the call a second time? If I have DND on, I don't want the phone to ring. He did text me after he called.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#75
With the settings pictured below i've just enabled DND manually on my phone then rang myself from another phone and the first call was rejected and I heard my own voicemail. I then rang myself straight back and it instantly rang as expected within the three minutes.
View attachment 40000
I just answered my own question but noticed that I had repeated calls turned on. It is off now. That must be the default.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#76
How do you block the call a second time? If I have DND on, I don't want the phone to ring. He did text me after he called.

Turn off repeated calls. That's why it's gone off. I've tested DND every possible way with a manual turn on/off of DND and having Siri enable/disable it and it still works. I personally don't think there is anything wrong with your DND.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#77
Turn off repeated calls. That's why it's gone off. I've tested DND every possible way with a manual turn on/off of DND and having Siri enable/disable it and it still works. I personally don't think there is anything wrong with your DND.
You're right. It's not my DND settings. It's the user. I should know this more than ever being a software developer.