Don't Update to iOS 5.1 If You Want To Jailbreak Your 4S

bballrob

Genius
Gold
Oct 11, 2009
1,930
479
83
Alaska
OK, Got the iPad 2 all updated to 5.0.1. But in trying to update the iPhone 4S, twice I've gotten the following message: "The iPhone 'Rob's iPhone' could not be updated because the firmware file is not compatible."

Any idea what's going on?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,404
113
Utah
First make sure it's the 4S version. Then try these suggestions:

1. Do a hard reset on the phone and reboot the computer.
2. Temporarily disable your antivirus.
3. If the above suggestions don't work, just update to 5.0.1 on the phone rather than the computer. It's a faster process and doesn't require downloading the entire firmware file.
Settings > General > Software Update
 

bballrob

Genius
Gold
Oct 11, 2009
1,930
479
83
Alaska
I'm not sure what you meant by "make sure it's the 4S version. But for easiness, I just went with the third option. Now I just gotta wait for the windows jailbreak.