Driver Issues....

cjustice42

New Member
Jan 6, 2008
8
0
1
#1
Anytime I connect my phone to my pc, it tries to install the drivers automatically, but fails every time. Is there a way to manually install the drivers so iTunes recognizes my phone?
 

chrismmm

New Member
Silver
Dec 27, 2007
612
0
0
Gwinnett, Georgia
#3
what drivers does your pc try to load? I ask because i use xp and when i put my iPhone in the cradle, the pc recognizes it as a camera device and asks me if i want to import the pictures. The next time you see this message just select the "select auto play defaults in control panel" when the control panel comes up it will give a bunch of different options for cds, dvd, cameras, etc...for pictures, select "take no action" and this will not happen in the future. Hope this helps..
 

KNK

New Member
Jul 22, 2007
2,391
1
0
Stevenson Ranch
#5
I am on Vista. Thanks for any help you can provide.

Well you might try this:

1. Reinstall iTunes 7.5 as the "iTuneshelper.exe" .

2. Check device manager to see if it just shows as "iPhone" with an exclamation mark, so uninstall device.

3. Re boot the computer, open iTunes and then dock the phone and Vista should re-install a fresh driver.
 

cjustice42

New Member
Jan 6, 2008
8
0
1
#6
Well you might try this:

1. Reinstall iTunes 7.5 as the "iTuneshelper.exe" .

2. Check device manager to see if it just shows as "iPhone" with an exclamation mark, so uninstall device.

3. Re boot the computer, open iTunes and then dock the phone and Vista should re-install a fresh driver.
Thanks for the response KNK. I tried as you said, and it's still a no go. Windows tries to find the driver, and nothing is found.
 

cjustice42

New Member
Jan 6, 2008
8
0
1
#8
Are you connected to the internet. Have it search on the internet and it will find it, obviousily it is not on your hard drive.
Haha, yes, I am definitely connected to the net. I have no problems with my laptop, it's when I try to connect it to my desktop that it tries to install the drivers, and it doesn't find it, thereforee it isn't a known device in iTunes.
 

reaktor13

New Member
Aug 21, 2009
1
0
0
#9
Was having same problem

Cjustice,

I was having the same problem, and found the solution after googling around a bit. You have to copy the usbaapl.sys file from C:\Windows\system32\drivers to C:\Windows\inf. If that still doesn't work try the attached inf file.
 

Attachments