During an incoming call, "Decline" button only appears sometimes

Rafagon

Genius
Gold
Dec 7, 2011
7,566
1,254
113
45
Miami, Florida
#1
I'm not sure why I only get the "Decline" button for some calls, but not for others. Is there anything I can do to make this option always show up?

photo.PNG photo 2.PNG (thumbnails; click on each image to view larger)
 
Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#2
It happens to me also. Some calls I see the decline option or accept option. Others I can only slide to accept or I have to let it continue ringing and ignore it. I can't remember but does pressing lock button also ignore it?
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,849
999
113
66
Florence, AL
#3
[Raises Hand] I know this! Every morning my wife calls me at 5:30 am, and I always get the "Slide to Answer" option. If the phone is locked, you get the slide. If unlocked you get the accept/decline. Someone said if you swipe up on the slide to answer, it will show the option to decline. I have not tested that. Also they say 2 presses of the power/sleep button will send the call to VM. :)
 
Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#4
I never heard swiping up on slide to answer shows decline option. I'll test that the next time someone decides to call me.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,849
999
113
66
Florence, AL
#5
I never heard swiping up on slide to answer shows decline option. I'll test that the next time someone decides to call me.
Let me know. I have no clue. Just read it somewhere. It's apparently been a feature since iOS 6.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,849
999
113
66
Florence, AL
#7
I prank called myself and it didn't work, sliding up on the slide to answer. Nothing happened.
It must have changed in iOS 7. But pressing the top button twice probably declines the call and sends it to VM.
 
Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#8
It must have changed in iOS 7. But pressing the top button twice probably declines the call and sends it to VM.
Pressing the lock button? Yeah. That declined the call. It didn't send it to voicemail though. Unless it was just too late that I did it.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#9
I'm not sure why I only get the "Decline" button for some calls, but not for others. Is there anything I can do to make this option always show up?

View attachment 37579 View attachment 37580 (thumbnails; click on each image to view larger)
You're on the lock screen on the first screenshot and the home screen on your second. They have different options.
 
Dec 15, 2008
5,386
340
83
28
Pensacola, FL
#10
You're on the lock screen on the first screenshot and the home screen on your second. They have different options.
So when your iPhone is in lock mode the only way to decline a call is to use the lock button, correct?
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#11
So when your iPhone is in lock mode the only way to decline a call is to use the lock button, correct?
I decline a call from the lock screen by pressing the power button twice otherwise I use the slide to reject when the phone is unlocked.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,849
999
113
66
Florence, AL
#12
I decline a call from the lock screen by pressing the power button twice otherwise I use the slide to reject when the phone is unlocked.
When you twice press the power/sleep button, does it also send the call to voicemail? If not, that must have been a feature of iOS 6. One really has to take note of dates on "how to" articles.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#13
When you twice press the power/sleep button, does it also send the call to voicemail? If not, that must have been a feature of iOS 6. One really has to take note of dates on "how to" articles.
Yes, the person who is calling is sent straight to voicemail.