E-mail issue

bocanot

New Member
Jul 3, 2007
1
0
0
#21
smtp iPhone outgoing emails

The solution to this is rather simple. Namely: Do not put in a userid and password under smtp. Just your server name. Adding userid and password indicates authentucation which your service probably does not require.

Follow these steps:
(1) Add smtp server: i.e. smtp.server,com
(2) userid: leave blank. The word "Optional" should appear.
(3) password: leave blank. the word "Optional" should appear.
(4) send a test email. in some cases you may have to restart the iPhone.

Remember, both userid and password should remain blank, the word "Optional" should appear for both.

Good Luck!

------------------------------------------------------------------------

If anyone can receive email but can't send email and want a quick fix solution

under smtp use att's smtp...
cwmx.com:25

If you are outside their network and try to use them for outgoing mail, they kick it back. They suggest using port 587 rather than the default 25

cwmx.com is AT&T's smtp server -- it will work if you are using EDGE, because that is an AT&T service, but note that it will not work whenever the iPhone switches to wifi.
 

Hondamaker

Genius
Gold
May 14, 2007
9,946
671
113
57
Fairborn, Ohio
#22
The solution to this is rather simple. Namely: Do not put in a userid and password under smtp. Just your server name. Adding userid and password indicates authentucation which your service probably does not require.

Follow these steps:
(1) Add smtp server: i.e. smtp.server,com
(2) userid: leave blank. The word "Optional" should appear.
(3) password: leave blank. the word "Optional" should appear.
(4) send a test email. in some cases you may have to restart the iPhone.

Remember, both userid and password should remain blank, the word "Optional" should appear for both.

Good Luck!

------------------------------------------------------------------------
I've had those settings since day one and still no sending w/edge.
 

jeremyd

New Member
Jul 3, 2007
2
0
0
#23
email issue

When I try to download my email, if there is an attachment, it has it as a eml file. And I can't open it to get to the jpg file. Any comments?
 

gmcenroe

New Member
Jul 5, 2007
28
0
0
San Mateo, CA
#24
I had problems sending email with EDGE on comcast.

Now I have comcast email working without problem. Whether this is because comcast is working better or my iPhone is correctly configured I do not know. But here are my settings:

Incoming Mail Server
Host Name: mail.comcast.net
User Name: xxxxxxxx (fill in with yours)
Password: ********** (fill in with yours)

Outgoing Mail Server (SMTP)
Host Name: smtp.comcast.net
User Name: xxxxxxxxxx (fill this in with your username)
Password: ************* (fill this in with your password)


Under advanced Settings

Incoming Uses SSL: ON
Outgoing Uses SSL: OFF
Delete from server: Never

I hope this works for you. I was able to send a photo from my iPhone to my work email. Tried it twice and no problems.

Glenn
 

modernfx

New Member
Jul 6, 2007
5
0
0
#25
E-mail Problems and Solution

Hello everyone,

I was having the same problem as many of you, so, upon further experimenting with the mail settings this is what I've found out.
THIS IS FOR POP3 ACCOUNTS, but should work with your
ISP accounts as well. It's ALL about authentication.

Settings when you are on the EDGE or NOT ON YOUR HOME Wi-Fi network:

Incoming Mail Server
Host Name: mail.yourwebsite.com (this will vary depending on your host)
User Name: xxxxxxxx (fill in with yours)
Password: ******* (fill in with yours)

Outgoing Mail Server (SMTP)
Host Name: mail.yourwebsite.com (this will vary depending on your host)
User Name: xxxxxxx (fill this in with the same username)
Password: ****** (fill this in with the same password)

Under advanced Settings
Incoming Uses SSL: ON
Outgoing Uses SSL: ON (must be ON)
Delete from server: Never (keeps your email on the server)

*****************************************************
Just to calrify, you MUST put in your username and password in the outgoing sever AND SSL MUST be on. This is because almost ALL SMTP mail servers have some kind of security to limited unauthorized use to limit spamming. In some cases they do it by IP and since you are not in your home IP address the server rejects the e-mails. I have seen many people run into this. In other cases, some mail servers require a username and password. I have multiple mail servers and mine all work are working just fine this way. Essentially with the above settings this allows you to access the SMTP server from any IP. If you have an ISP e-mail account it very well might be limited by your actual IP address of your home network/home PC. You would need to find out what is the out going sever for your ISP. In my case I have optimum online for one of my accounts so I would use mail.optonline.net for out going host.
******************************************************


Settings when you are on ON YOUR HOME Wi-Fi network:
To send out e-mails while on your home network or Wi-Fi under Advance Settings turn Outgoing Uses SSL: OFF
This will now use your incoming settings which will then use your network/PC IP address for authentication.



*******************************************************
I have multiple e-mail accounts on multiple servers on diffrent hosting companies and all the e-mails work just fine. However, I have to make sure the host name for every account is set accordingly.

For example:
I use Host Gator for family accounts:
The mail host name for them is mail.mywebsite.com for both incoming and outgoing.

For businesss accounts on a dedicated server I use 1and1.com:
Their mail host names are pop.1and1.com AND smtp.1and1.com instead
of your website name as with host gator.
*****************************************************

I hope this helps some of you.
If you have any questions, you can drop me an e-mail.

Good Luck.
I LOVE THE iPhone!
 

the watcher

Member
Bronze
Jul 5, 2007
183
1
18
#26
Can someone tell me if there is a way to save images for my e-mail i can't seem to figure it out.
 

modernfx

New Member
Jul 6, 2007
5
0
0
#27
Can someone tell me if there is a way to save images for my e-mail i can't seem to figure it out.
The iPhone supports the following email attachment file formats:
.c, .cpp, .diff, .doc, .docx, .h, .hpp, .htm, .html, .m, .mm, .patch, .pdf, .txt, .xls, .xlsx


To save a file:
Tap the attachment. It downloads to iPhone and then opens.

So if someone sends you an image it most probably will be in a .jpg, .png or .gif format which iPhone does not supports as an E-mail attachment.
This is done for security / virus reasons as programs and viruses can be hidden and trigger inside image files.

You can still send images but they have to be included as part of the e-mail message.

Best,
J
 

tranewreck

New Member
Mar 21, 2007
15
0
0
#28
OK i had the same issue with my pop account, i could not send e-mail.. the fix? well, simple... on the outgoing side, under the "user name" put your entire email address. that fixed my issue. good luck.
 

kchester

New Member
Jan 23, 2007
6
0
0
#29
The first day I owned my iPhone I was able to send a test message no problem. I have not been able to send out an email since, I get the same error but don't know what to do about it. My ISP, Cox was of no help and neither is anything else I have read. I see there is a couple people with the same issue. I sure hope someone can figure it out. I get emails all day but can not reply.. soo frustrating.
 

kchester

New Member
Jan 23, 2007
6
0
0
#30
I was able to get mine to work on the edge network by changing the smtp to cwmx.com:25 It really sucks I have to change it to that for Edge and then back to my correct settings for Wifi.. I am on both networks throughout the day.. hopefully Apple or AT&T figure this out soon. Just glad to be able to email again.
 

deanp

New Member
Jul 11, 2007
1
0
0
#31
can't get email attachments

I can receive and send email without problem however any emails received that have an attachment, the attachment won't open. These emails say "This message has no content". I visited the Apple store today and they couldn't figure it out. Said it could be a comcast problem. They even tried sending me emails with attachments and got the same message.

Any ideas on how to get email attachments with using comcast server.
 

Martlet

New Member
Bronze
Jul 11, 2007
145
0
0
#32
I'm not sure this will fix all the email problems mentioned, but the most common problem is the 'rejected by the server' problem.


For your home wi-fi network, your mail settings work because you are "inside" your network providers "house". So if you're a Comcast subscriber, at home, you're connected to Comcast's network from the inside, and so can talk to their outgoing mail server which also is inside.

When you take the iPhone somewhere else, you're "outside". So your provider sees that someone from AT&T's network (when you're using the EDGE network) or some other network (if you found an open wi-fi access spot) is trying to shove their outgoing email in your providers server, and they don't allow that.

So you need to make sure you tell your service provider who you are, so they know that if you're in AT&T's EDGE network house, they'll still allow you to send mail through your provider's mail server.

The way you do this is by setting your outgoing mail server to use SSL authentication. You'll need to check with your provider to find out the mail server address, port, and the username and password to use secure SMTP outgoing email. That's 'simple mail transfer protocol', or if you're my buddy who likes meaningful sayings (he though HTTP meant 'head to this page'), call it 'sending mail to people' server. ;)

Once you have all that, I recommend you set up your home computer that way, SSL SMTP isn't bad even when you don't need it, so it's good for the home computer that works with or without it. Then sync the iPhone mail account(s) after you changed them to use SSL SMTP, and the settings should all transfer.

That way, when you're running around town using EDGE, it'll tell your outgoing mail server who you are, and that you have the right to shove your outgoing mail to their server.

If your provider doesn't have SSL SMTP, then you need to find a STMP server that does... gmail does, .Mac does, and I'm sure yahoo also does. Gmail isn't as good if you're not using a gmail return address though, since it will automatically change your return address to your gmail account no matter what you set it as. I'm not sure about the others.
 

gmcenroe

New Member
Jul 5, 2007
28
0
0
San Mateo, CA
#33
comcast attachment works for me

I had problems on first day setting up email for comcast using the imported mail server settings that iPhone imported from my computer, with message rejected. I found settings that work well for me now. You can search everything iPhone for settings I posted here earlier.

I tested sending attachments a word document that I generated on my work computer, emailed to my comast account and it was received on my iPhone with attachment intact and readable. I forwarded that message back to my work email address and it arrived without any problems including that readable attachement.

So I am not sure what is going on with some peoples comcast accounts. Maybe they have differant rules for differant customers or email servers?

Glenn
 

brinox

New Member
Bronze
Apr 30, 2007
195
0
0
#34
my email issue is that i receive every single email that i send on my desktop's normal browser in my iPhone's inbox... quite annoying!
 

ItoGator

New Member
Jul 3, 2007
15
0
0
#35
I have tried all of the options on this thread and still get the "rejected by server" when i try to send. This is very frustrating. I wonder if the support at bellsouth knows how to fix this? I will call them tonight and report what i find here.
 

ItoGator

New Member
Jul 3, 2007
15
0
0
#36
Ok, I did some searching and I believe I have the problem solved. I haven't tried it away from home, but I did it using the edge and it worked prefectly. I am no longer getting the "rejected by server" error when sending an email. All I did was change the outgoing server name from mail.bellsouth.net to cwmx.com. This worked. I found the info here:

http://www.wurd.com/cl_email_iphone-bs.php

If you try this, please post the results here.
 

photobyjj

New Member
Jul 13, 2007
7
0
0
#37
pay up...and your sent mail will go! i know 2 people same solve...apple lied on this one..free push or what ever they wanna call it... cash money pimps! makin' they dollas'
 
Jul 11, 2007
24
0
1
#38
I have been having this same email problem on and off for a couple of weeks. Even without changing settings, I have noticed that sometimes it works and others it doesn't. It just seems like a luck of the draw but I would rather have Vegas odds.

I updated my outgoing server to cwmx.com:25 and was just able to get a couple of emails out through edge just now. Thanks for that tip.
 
Jul 11, 2007
24
0
1
#39
Update...

I was able to get it working. Basically I updated the outgoing server port to '587' from the default of '25' and no more issues. This was a suggestion from Apple. It works in both wifi and edge. Your ISP will have to support port 587 for it to work, but that sounds like a secondary default so there is a good chance they will.

Your ISP may be different, but I do not have SSL selected but do have my username and password set on the outgoing server. That is set the same as my incoming.

HTH!
 

jryland

New Member
Jul 16, 2007
1
0
0
#40
Thanks. It worked for me.

Ok, I did some searching and I believe I have the problem solved. I haven't tried it away from home, but I did it using the edge and it worked prefectly. I am no longer getting the "rejected by server" error when sending an email. All I did was change the outgoing server name from mail.bellsouth.net to cwmx.com. This worked. I found the info here:

http://www.wurd.com/cl_email_iphone-bs.php

If you try this, please post the results here.

I followed the instructions at the URL you posted, and I am now able to email from my iPhone via Edge (I had only been able to send outgoing mail when connected to wi-fi network with excellent reception). Thanks!