E-mail issue

Jackson

New Member
Aug 6, 2007
2
0
0
#41
Still not working

I'm not sure this will fix all the email problems mentioned, but the most common problem is the 'rejected by the server' problem.


For your home wi-fi network, your mail settings work because you are "inside" your network providers "house". So if you're a Comcast subscriber, at home, you're connected to Comcast's network from the inside, and so can talk to their outgoing mail server which also is inside.

When you take the iPhone somewhere else, you're "outside". So your provider sees that someone from AT&T's network (when you're using the EDGE network) or some other network (if you found an open wi-fi access spot) is trying to shove their outgoing email in your providers server, and they don't allow that.

So you need to make sure you tell your service provider who you are, so they know that if you're in AT&T's EDGE network house, they'll still allow you to send mail through your provider's mail server.

The way you do this is by setting your outgoing mail server to use SSL authentication. You'll need to check with your provider to find out the mail server address, port, and the username and password to use secure SMTP outgoing email. That's 'simple mail transfer protocol', or if you're my buddy who likes meaningful sayings (he though HTTP meant 'head to this page'), call it 'sending mail to people' server. ;)

Once you have all that, I recommend you set up your home computer that way, SSL SMTP isn't bad even when you don't need it, so it's good for the home computer that works with or without it. Then sync the iPhone mail account(s) after you changed them to use SSL SMTP, and the settings should all transfer.

That way, when you're running around town using EDGE, it'll tell your outgoing mail server who you are, and that you have the right to shove your outgoing mail to their server.

If your provider doesn't have SSL SMTP, then you need to find a STMP server that does... gmail does, .Mac does, and I'm sure yahoo also does. Gmail isn't as good if you're not using a gmail return address though, since it will automatically change your return address to your gmail account no matter what you set it as. I'm not sure about the others.
Outgoing is mail.server.com with no user name and no password. Worked fine last Wednesday and Thursday. Then Friday, it quit sending e-mail to anyone ourside of our server name. Tried changing SSL outgoing to on instead of off, that didn't work. Tried the cwmx.com:587 and that didn't work for any outgoing e-mails. They are still sitting in the outbox saying "rejected by server." Any other ideas?
 
Aug 7, 2007
1
0
0
#42
Thanks!

Ok, I did some searching and I believe I have the problem solved. I haven't tried it away from home, but I did it using the edge and it worked prefectly. I am no longer getting the "rejected by server" error when sending an email. All I did was change the outgoing server name from mail.bellsouth.net to cwmx.com. This worked. I found the info here:

http://www.wurd.com/cl_email_iphone-bs.php

If you try this, please post the results here.

It totally worked for me. Hopefully this will do until Apple/AT&T officially address this. Thanks. I can't believe Apple or AT&T haven't posted anything on their websites about this incredibly common problem. I love their products, but Apple's tech support/customer service stinks. Thank goodness for this forum!
 

Jackson

New Member
Aug 6, 2007
2
0
0
#43
Finally found an answer. Changed outgoing mail to our in-house exchange server - mail.servername.com:26 - the :26 allowed the iPhone to bypass our firewall which was the issue. We also had to enter the user name and password in the Optional places under outgoing mail. Today it is working - and has worked for 24 hours. Will let you know if something happens to make it reject mail again.
 

JRfromTN

New Member
Aug 4, 2007
3
0
0
#44
i found this on a web site it seems to be working for me
JR


Ok, if you are on the edge network then everything should work just fine since they have their network pretty much wide open. If on the other hand you wish to hot-spot hop like most of us to get on faster networks, then watch out. If your ISP uses port 25 for its SMTP E-Mail server, expect to be blocked about two-thirds of the time. AT&T, BellSouth, MindSpring, CableOne, Charter, Comcast, ATTBI, Cox, EarthLink, Flashnet, MediaOne, MSN, NetZero, People PC, Sprynet, Sympatico.ca, Verio, and Verizon among many more block port 25. This of course is to help prevent SPAM(Junk Email) from traversing their networks. Unfortunately if your ISP uses port 25 for sending email, you are in a tough position. You will be able to read email but not send email. You could switch back and forth to and from the Edge network but that is kind of a hassle. There is a trick to work around this problem though – read below.

The trick! Sign up for a gmail account and have your email sent from it using Google’s SMTP servers. Google’s servers use ports which are not known to be blocked by any major ISP. You can keep your incoming email from your ISP. The only downside to this is that your username might change from something like smith@earthlink.net to smith@gmail.com or smith1523@gmail.com The upside will be that sending email will be possible regardless of the network you are connecting from!
 

BadSeed

New Member
Jul 30, 2007
1
0
0
#45
Ok, so I've read all of this.

Here are my symptoms.

At first, server error message appeared and I could not send or receive email.
Was working fine prior to update.

Now, it goes to the edge network, or wifi, and will not retrieve mail. But will send fine. No error message appear.

It just states that the last time I updated was 24 hours ago, even tho I have requested updates many times since then.

One of my favorite features is now dead....
 

sunshineprincess

New Member
Bronze
Aug 9, 2007
81
0
0
#46
i get the error

"cannot get mail" ...the user name or password for "mail.mac.com" is incorrect.

i'm trying to set up gmail. i just don't get it.
 

Willmca

New Member
Jul 14, 2007
2
0
0
#47
email problem with gmail

I had a hard time getting my work email to work. I.T. guys are clueless-finally forwarded it to gmail. Bam! In businesss, but I get the forward from gmail and it it gives me the forward message title and an icon(mime-attachment). Help! I get the subject but not the body of the email. Any suggestions. I check it in gmail on my pc and it is good but when iPhone checks email it gives me this on every fwd email from work. Any ideas?
 

iGusto

New Member
Jul 24, 2007
1
0
0
#48
email

hows it going everyone? im having a problem with my email accounts and was wondering if u guys could help me out. i have a yahoo and a .mac acct set up for my emails. anyway, my yahoo acct has been checking for new mail since yesterday morning and when i receive an email it wont alert me. i have to push the "load more messages" tab on the bottom of my screen. as for my .mac acct., that wont alert me either when i receive a new msg. i have to hit the check for new mail tab on the bottom as well. can anyone help me out with some info? thanks in advance.:)
 

TaySharpe

New Member
Mar 9, 2009
9
0
0
Canada
#49
I have the same issue, can't send on 3G (Rogers network in Toronto) but I can over wi-fi. I've tried deleting and setting up the Gmail mailbox again, but no luck.

Anyone help?
 

Riclov

New Member
May 18, 2009
1
0
0
#50
Only one email at a time shows up in INBOX

I recently switched ISPs and set up my iPhone 3G email according to their setup instructions. Everything works, sort of; I can send and receive to and from the new ISP, but it will only show the single most recent email in my INBOX. It says I have 40+ unread emails, but only one, the most recent, is visible. I tested it by sending three consecutive emails to that account from my work account, with subject lines test1, test2, and test3. Only test3 showed up.

I reset my phone, deleted the account and then added it again. Same issue.

Thoughts?:oops: