Email "Connecting" Problem Again!

nbdiver

Member
Bronze
Jul 7, 2008
246
0
16
Scottsdale, AZ
#1
Is anyone having the email "connecting" problem where your email just sits and tries to connect for countless minutes? It never shifts to "checking for mail"! I had this problem when I first got the phone but after a couple of updates, specifically 2.1 most of my problems went away including email problems. All of sudden its back and I now have to restart my phone most of the time to get my email. Very annoying.

Is anyone else having this same problem that also had it when the 3G first came out? Not sure what could cause this as I haven't really made any changes to the phone.

Thanks in advance for advice and help!
 

showguy

Member
Silver
Dec 2, 2007
769
15
18
Long Island, NY
#4
Word to the wise: When this happens shut your phone off and turn it on again. This always works for me. I am now in the habit of doing it every morning. Also if you are the type that switches between edge to 3g, do this method after you switch back to your normal network
 

nbdiver

Member
Bronze
Jul 7, 2008
246
0
16
Scottsdale, AZ
#5
Word to the wise: When this happens shut your phone off and turn it on again. This always works for me. I am now in the habit of doing it every morning. Also if you are the type that switches between edge to 3g, do this method after you switch back to your normal network
problem with this remedy is I check my email constantly throughout the day which means I have to restart my phone all the time. Not my idea of a fix. I guess it would work if I am only checking it a couple times a day.
 

showguy

Member
Silver
Dec 2, 2007
769
15
18
Long Island, NY
#8
problem with this remedy is I check my email constantly throughout the day which means I have to restart my phone all the time. Not my idea of a fix. I guess it would work if I am only checking it a couple times a day.
Sorry if I was not clear. Turn it off once a day and you will be fine. I do it every morning before the work day starts.
 

iErik

Zealot
Gold
Oct 27, 2007
1,221
72
48
Las Vegas, NV
#9
Instead of rebooting the phone I read somewhere a good work around for this is to just force quit the mail app by holding down the home button til it closes.
 

nbdiver

Member
Bronze
Jul 7, 2008
246
0
16
Scottsdale, AZ
#12
Sorry if I was not clear. Turn it off once a day and you will be fine. I do it every morning before the work day starts.
I understood. I turn it off several times a day as I check my email several times a day. Once in the morning doesn't cut it!

Don's suggestin has worked so far. Reset network settings has worked since yesterday.