Email not deleting from Outlook

dwp1975

Member
Bronze
Jul 4, 2007
561
2
18
43
Rockville, MD
#1
I upgraded to iTunes 7.6.1 and I added a second email account to my iPhone last night. All seemed fine, but this morning, I noticed that my 1st account no longer deletes emails that I delete off my iPhone off of my Outlook. It was working fine before both the iTunes upgrade and adding the 2nd email account. The 1st account is a IMAP account and the 2nd account is POP3. I do not see a option in the IMAP to see if it's set to delete from server too.
 

adseguy

New Member
Bronze
Jul 1, 2007
401
0
0
#3
No there is not really a convinient solution. That's why POP email sucks. Post Office Protocol only downloads the message off the server, but doesn't delete it. TRy to setup an IMAP account if possible or maybe your IT has web e-mail available.
 

dwp1975

Member
Bronze
Jul 4, 2007
561
2
18
43
Rockville, MD
#4
No there is not really a convinient solution. That's why POP email sucks. Post Office Protocol only downloads the message off the server, but doesn't delete it. TRy to setup an IMAP account if possible or maybe your IT has web e-mail available.
The account I am concerned about is my work email account and it is set up as IMAP, the POP one is just my personal iPhone email account that I used to get iPhone related emails. Wondering if it is worth it to take it back to the Apple store or if there is a setting I am missing to get it back to how it was. :)
 

x666x

New Member
Bronze
Jan 24, 2008
443
0
0
#5
I read through your posts and maybe I missed it, but have you tried removing your problematic email account and adding it again as a new one?

I have noticed some permissions problems with iTunes and it's backups. My friend's email wouldn't open, it would just show a white screen and close. He never jailbroke his phone or anything, but he did do a restore recently and some how, iTunes borked his permissions on his email account. 1.1.2 uses the account "root" and 1.1.3 uses "mobile" which has lead to some confusion within iTunes during it's backup/restores.

Your old email that worked may have once been backed up with one system user and then restored as another, and now you don't have the correct permissions to delete anything. In other words, you may be on as "mobile" trying to delete "root's" mail, and the OS won't let you because it doesn't belong to "mobile."

If you haven't tried it already, remove your email and then re add it. iTunes will create it with the proper identity. Failing that, I recommend doing a full Restore from iTunes which should sort it all out nicely.

I had to restore and backup my friend's iPhone twice to get his mail working again, and it's not limited to just people who mod their iPhones interestingly enough.
 

dwp1975

Member
Bronze
Jul 4, 2007
561
2
18
43
Rockville, MD
#6
I read through your posts and maybe I missed it, but have you tried removing your problematic email account and adding it again as a new one?

I have noticed some permissions problems with iTunes and it's backups. My friend's email wouldn't open, it would just show a white screen and close. He never jailbroke his phone or anything, but he did do a restore recently and some how, iTunes borked his permissions on his email account. 1.1.2 uses the account "root" and 1.1.3 uses "mobile" which has lead to some confusion within iTunes during it's backup/restores.

Your old email that worked may have once been backed up with one system user and then restored as another, and now you don't have the correct permissions to delete anything. In other words, you may be on as "mobile" trying to delete "root's" mail, and the OS won't let you because it doesn't belong to "mobile."

If you haven't tried it already, remove your email and then re add it. iTunes will create it with the proper identity. Failing that, I recommend doing a full Restore from iTunes which should sort it all out nicely.

I had to restore and backup my friend's iPhone twice to get his mail working again, and it's not limited to just people who mod their iPhones interestingly enough.
I am going to give this a try, I only deleted the new account and then added it back, but I will delete and add both accounts and try again. Should I sync with iTunes before or after I add the accounts back on?
 

x666x

New Member
Bronze
Jan 24, 2008
443
0
0
#7
I am going to give this a try, I only deleted the new account and then added it back, but I will delete and add both accounts and try again. Should I sync with iTunes before or after I add the accounts back on?
You can go ahead and sync, iTunes backs up every time you do.

I don't think iTunes will try to restore the mail account, just keep your contact info.
 

dwp1975

Member
Bronze
Jul 4, 2007
561
2
18
43
Rockville, MD
#8
removed the problematic account and added it back in, the problem still persists and now I don't have the ability to change the outgoing authentication to NTLM like I did before. Any other suggestions, should I delete both accounts and do a restore then add them back on? :mad:
 

dwp1975

Member
Bronze
Jul 4, 2007
561
2
18
43
Rockville, MD
#9
Still no luck, I did everything on my end that I cuold think of, I unchecked syncing with the account then removed it, added it back again and re-checked syncing and still it doesn not delete my emails off my server.
 

Nikki205

Member
Bronze
Oct 8, 2007
62
0
6
#10
Non Deleting eMail

I had this problem today for the first time. I have a Time Warner Road Runner account and when Apple told me that the emails were not being deleted from the server, I called Road Runner. I was informed that they were "upgrading " their system and "backed up" users emails so that nothing would be deleted when they made changes.
I was directed to go to the Road Runner mail account https://webmail.nyc.rr.com
There you may check to see which emails have been read and not and deleting those not needed will remove them from the server.

Also I should add that I went to Outlook Express and changed my setting to remove emails from server after 1 day (had it set for 5 days.).( Go to Outlook Express - select Tools-select Accounts- select Properties- select Advanced- select remove from server after 1 day- select Apply.)
So far so good. But tomorrow will be a better test.
By the way, they told that the upgrade was not completed so I'm expecting the worst.
Hope this helps
 

trflick

New Member
Oct 4, 2007
7
0
0
#11
Ok... this may deserve a new thread but it's related. Ever since the recent upgrade, my POP email account is randomly deleting emails from the server when I have clearly indicated "Never" on the setting. It is intermittent - no ryhme or reason. I have checked every single PC that pulls from this server and all have leave copy on server. I have also changed the password as a precauction. Am I sensing a bug in the iPhone email?