Email Trouble...

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Grappler

New Member
Jul 10, 2007
5
0
0
#1
When I go to send an email it says that the address is denied by the server. What can I do to fix this problem. Thanks.
 

ColsTiger

Zealot
Gold
Mar 8, 2007
5,856
2
38
Columbus, GA
#2
When I go to send an email it says that the address is denied by the server. What can I do to fix this problem. Thanks.
Welcome to EiP!

You get this problem when you us an ISP provided pop account and you're away from your home network. ISPs block outgoing emails from their server when you're not on the network to prevent spam.

You can try changing the settings on your outgoing server to port 587 instead of port 25, but it didn't help me at all. I finally had to configure a gmail account that would accept emails sent to my ISP provided email address and reply from that address as well.

You can also configure your outgoing server settings to cwmx.com instead of the normal smtp.myprovider.com settings. This will let you send outgoing email directly from your ISP provided email address when you're on the Cingular/ At&t EDGE network, but will prevent you from sending email when you're on WIFI anywhere. It's sort of clunky but it is a workaround.

There's quite a few posts on the Apple/iPhone/discussion forums. You can go to iPhone support at Apple.com to participate in those forums.
 

DRabbit

New Member
Bronze
Jul 2, 2007
383
0
0
#3
You can try changing the settings on your outgoing server to port 587 instead of port 25, but it didn't help me at all. I finally had to configure a gmail account that would accept emails sent to my ISP provided email address and reply from that address as well.
To try port 587 here's what you have to do...

Use your provider's outgoing mail server... whatever you have it set to now... and add :587 to the end. No spaces or anything. Example... mail.yourserver.com:587
put in your username and password, same as incoming.

See if that works. If not, you may have to set your outgoing to cwmx.com (no username or password) to send e-mail from the EDGE network (but not WiFi) or use an alternate .mac / google / yahoo address.
 

Grappler

New Member
Jul 10, 2007
5
0
0
#4
it still says it can't send (the connection to the server "snowmass.bvsd.org failed). I have the outgoing set to snowmass.bvsd.org:587 any more help would be great.