Error 1025 when downgrading from 1.1.2 to 1.1.1

spatznick

New Member
Sep 19, 2007
8
0
0
#1
I get Error 1025 when downgrading from 1.1.2 to 1.1.1
This is in iTunes, when I do system restore.

I just wanted to downgrade since I want to use the Jailbreakme.com to unlock it, which works with 1.1.1. Phone cames with 1.1.2...

There are probably too many options, but I my friend is leaving country in a few hours and needs to have the phone unlocked by then. Jailbreakme.com is quick, as long as I can get 1.1.1 to work. For now the phone in bricked, basically, in the recovery mode... BADDD

Any help is appreciated, asap.
 

spatznick

New Member
Sep 19, 2007
8
0
0
#3
If the phone came with 1.1.2 then you can't unlock it. It's not possible yet. You can jailbreak, but not unlock.

Thanks! I see now...
I thought that I can downgrade to 1.1.1 and then follow the instructions per this site: http://iPhone.unlock.no/

Unfortunately, the downgrade does not work...

But no matter if I want to unlock or now, the downgrade alone should work via iTunes no matter what. Is this correct?
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,385
1,089
113
DC
#4
no, you cannot downgrade using ONLY iTunes. The easiest way i found to downgrade is once you get that error message, close iTunes, and Run iBrickr. It will detect your iPhone is in restore mode, and will do its thing.