Exchange Email Setup Problems

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Jreed

New Member
Jun 30, 2007
2
0
0
#1
Now that my iPhone is syncing great with Outlook Calendars and Contacts, and my personal email is working great with Gmail, I decided to tackle my work email setup. My office uses Exchange and although I have repeatedly typed in my Exchange server info, I keep getting an error message that "Exchange Account Verification Failed". My IT guy says that IMAP is enabled so I don't think that's the issue but I don't have a clue how to fix this. Is there an online FAQ for Exchange setup issues or can someone who has this working offer any suggestions?

Many thanks!

Jim
 

raremage

New Member
Jul 10, 2007
3
0
0
#2
Just because IMAP is enabled on the server doesn't mean that it's available externally. Ports 143 (unsecured) or 993 (secured) are required in your company's firewall for this to work, properly mapped to the Exchange Server or an ISA server in the DMZ.
 

Jreed

New Member
Jun 30, 2007
2
0
0
#3
Just because IMAP is enabled on the server doesn't mean that it's available externally. Ports 143 (unsecured) or 993 (secured) are required in your company's firewall for this to work, properly mapped to the Exchange Server or an ISA server in the DMZ.
OK, I will ask my IT guy to open those ports but I think my problems start even before that because my attempt to set up this mail account fails right from the beginning BEFORE the Exchange account is even verified- in other words, I don't even get to the point where I get to receive even internal email..... Would the closed external ports cause the account verification to fail?

I will keep plugging away on this and thanks for the input and if you have any other ideas about what I should try I would be most appreciative.

Jim
 

kp98077

New Member
Jul 5, 2007
7
0
0
#4
i had same issue!

Now that my iPhone is syncing great with Outlook Calendars and Contacts, and my personal email is working great with Gmail, I decided to tackle my work email setup. My office uses Exchange and although I have repeatedly typed in my Exchange server info, I keep getting an error message that "Exchange Account Verification Failed". My IT guy says that IMAP is enabled so I don't think that's the issue but I don't have a clue how to fix this. Is there an online FAQ for Exchange setup issues or can someone who has this working offer any suggestions?

Many thanks!

Jim

****I had the same issue took my IT guy a week to figure out, but finally it did.. so now it works, good luck! Not sure what he did exactly but can find out if you need help.
 
Jul 11, 2007
1
0
0
#5
Before my iPhone, I had a Windows Mobile (6.0) Smartphone. Since my corporate IT shop only supports Blackberry, there were a couple of things I had to do to get my email (Exchange 2003) working on it. I got help from a guy who is far more techie than me for the smartphone, so here's my best stab at what was required, that I don't know how to do on the iPhone.

1. Enable SSL encryption.
2. Download and install a certificate from the exchange certificate server. I can download the certificate to my PC, but from that point I have no idea how (or if) I can put it on the iPhone.

It seems that the inability to connect to the exchange server is a security setting, that some IT folks might not be willing to change, so I needed a workaround, and it seems like #2 above was the critical item.

Feel free to correct me if I'm wrong, or lend assistance if you have any thoughts...
 

iamcpoo

New Member
Jul 17, 2007
1
0
0
#6
I had similar problems and it was driving me crazy. I set it up as 'IMAP'... and in the advanced section, set both SSL settings to 'OFF'. This worked for me and started syncing immediately.
 

kildjean

New Member
Jul 25, 2007
5
0
0
#7
****I had the same issue took my IT guy a week to figure out, but finally it did.. so now it works, good luck! Not sure what he did exactly but can find out if you need help.
Could you give your IT guy my email so he can explain me how he did it? I have imap enabled on my exchange server but it wont go... :( im stuck and ther eis not a lot of help on the web for it.

tell him he he can email me at kildjean@mac.com or gilbert.palau@usmax.com

thanks!

G.
 

kildjean

New Member
Jul 25, 2007
5
0
0
#9
we outsource our exchange server to another company... the exchange admin fixed my ports and made 143 and 993 open in the firewall. we run our voip phones through imap so these ports are open.

now...

my settings look like this:

incoming: mail.mycompany.com
username: hostingserver/username
password: password

is this the way it should go or is there another way?

Because the error I am getting is:

Cannot Get mail

The username or password for "mail.company.com" is incorrect. But I verified the password and everything is fine.

Please some insights as i have so many hairs on my head... :)

thanks!
 

Graphton

New Member
Jul 25, 2007
1
0
0
#10
Couldnt get exchange or Imap to work but found a work around

No matter what i tried i could not get the iPhone to sync with exchange, pop, or Imap. I punched holes in the firewall, white listed AT&T 's ip address block to no avail. Palm phones, Microsoft mobile phones all work but no luck with the iPhone.

Heres what i did...

I created the user a gmail account.

Went into active directory and created a new OU call mail forwarders
In the container I made a new contact http://www.msexchange.org/tutorials/MF015.html

Created the contact (named it user mail forwarder) with an SMTP address of the newly created gmail Account

Edited the users exchange account (exchange general tab) went to delivery options

chose forward mail to: found my newly created contact

checked the box to deliver to forwarding address and mail box

Entered the gmail account information in the iPhone

Logged into the gmail account and edited the mail settings and set the reply to address to correspond with the users work email

Done deal
 

kcarr91

New Member
Bronze
Apr 14, 2007
62
0
0
#11
i got and an iPhone and so did my dad he wanted his e mails to his phone so we got the it people to come set it up (this is with exchange)

it took 2 it people 5 hours to setup the iPhone

it keep saying mail.company/exchage is not available after 3 hours of that

then the imap was enable but it was not enable correctly

and so on and so on

once it was setup it worked great but it took a long ass time to setup

it is a real pain to setup exchange on the iPhone

and for my iPhone i just gave up on hotmail account and made a gmail account

did anyone else setup exchange? did u have these problems
 

kildjean

New Member
Jul 25, 2007
5
0
0
#12
Walkthrough on the iPhone/Exchange Issue

Guys;

Sorry it took me so long to post this. Ran into a million and one complications... but I think this is a simple yet viable workthrough...

First things first, and lets get this out of the way... Your exchange must have access to ports 193 (unsecured) and 993 (Secured). If your IT guy will start jumping like a pricky 15yr old skool girl, then you are screwed. Most IT People frown upon opening these two ports like they were their first love's legs. So if your IT is not happy about this he either has to find a way around it (I am sure there is) or you are screwed.

Secondly, IMAP must be enabled to be used amongst the user accounts. If not it won't work either.

Third, If your company is running on Exchange 2003, then you are going to use the IMAP setting on your iPhone. If you use the Exchange button tab, it wont work. The reason for this, is that even so Apple and MS are still in a petty squabble to see who has it larger. The Exchange Button Tab is for use exclusively for Exchange 2007.

Fourth, the exchange of information between the mail server and the iPhone is strictly "pull". This means that you can send/receive emails, but if you delete any, it will not be deleted on the exchange server. Also, you cannot synchronize calendar or contacts, through the "mail". You can do this by synchronizing your outlook with iTunes but not over the net. This will be able to happen if Apple releases their Active Sync thingy.

Fifth. Disclaimer, if you get hacked, shutdown or you loose your job, then I am terribly sorry. crap happens... but don't blame me. I am putting this up here because it took me two weeks of research and trial and error (and putting up with pricks that wanted to sell me their services when all they had to do was explain how they did it...). I don't think there is anything here that is cryptic but I am disclaiming my self so i don't get sued. ;)

The iPhone Configuration goes as following:

Personal Information
Name: John Dick
Email: jdick@yourcompany.com
Description: IMAP to Exchange

Incoming Mail Settings
Host name: mail.yourcompany.com
username*: jdick
password: mypassword

Outgoing Mail Settings
Host Name: mail.yourcompany.com
username*: jdick
password: mypassword

*note: some servers will use any of the following combinations: servername\jdick or jdick.yourcompany.com or any other mighty creative one. Just go for te name first and if it doesn't work then start trying other combinations.

Go into the Advanced Settings tab at the bottom. Assign the mailboxes to your iPhone (if you want), and depending on which way you want to go slide the SSL settings for incoming or outgoing.

With that close save your settings and you will be set.

Things to Remember:

Exchange 2003
  • use the IMAP Button on the iPhone
  • open ports 193 (unsecured) 993 (secured) on exchange
  • Pray your IT is not a Jdick

Exchange 2007
  • use the Exchange Button on the iPhone
  • open ports 193 (unsecured) 993 (secured) on exchange
  • Pray your IT is not a Jdick

This is how i got mine to work. I hope my guide helps others out there. Its not perfect but it works. At least it worked for me. If I find any updates I will post them here.

Any questions, just PM me or post em here, as I check this forums weekly.

Good Luck!

Kil'Djean
 
Aug 6, 2007
1
0
0
#13
This is so bloody frustrating...

Kil'Djean

Thanks you in advance for all the hard work you apparently have done to try and get this email thing working for all of us with the iPhone.

I just spent about an hour with my IT department trying to get things set up. I followed the instructions to the letter with a couple of exceptions (detailed below) and I am getting messages that the IMAP server is not responding...

So...here is what is 'slightly' different about my situation.

1. The IT department will NOT open port 143 but did open port 993
2. Tried connecting via SSL, but won't work.
3. Tried every combination of server\username
4. Verified password
5. Mail server is using OWA so the reference is: webmail.companyname.com -- does that make a difference?
6. I am using my wifi from home to connect to the network, as I live in an area where ATT services is very spotty. Does this make a difference?
7. Finally, my IT department is not 'up to speed' on IMAP. Are there any special setting that should be enabled?

Any suggestions from anyone would be great...massive frustration is prevailing here.

Brand new to the forum...been a lurker but never needed to post until now.

Cheers,

Man-in-Black






Guys;

Sorry it took me so long to post this. Ran into a million and one complications... but I think this is a simple yet viable workthrough...

First things first, and lets get this out of the way... Your exchange must have access to ports 193 (unsecured) and 993 (Secured). If your IT guy will start jumping like a pricky 15yr old skool girl, then you are screwed. Most IT People frown upon opening these two ports like they were their first love's legs. So if your IT is not happy about this he either has to find a way around it (I am sure there is) or you are screwed.

Secondly, IMAP must be enabled to be used amongst the user accounts. If not it won't work either.

Third, If your company is running on Exchange 2003, then you are going to use the IMAP setting on your iPhone. If you use the Exchange button tab, it wont work. The reason for this, is that even so Apple and MS are still in a petty squabble to see who has it larger. The Exchange Button Tab is for use exclusively for Exchange 2007.

Fourth, the exchange of information between the mail server and the iPhone is strictly "pull". This means that you can send/receive emails, but if you delete any, it will not be deleted on the exchange server. Also, you cannot synchronize calendar or contacts, through the "mail". You can do this by synchronizing your outlook with iTunes but not over the net. This will be able to happen if Apple releases their Active Sync thingy.

Fifth. Disclaimer, if you get hacked, shutdown or you loose your job, then I am terribly sorry. crap happens... but don't blame me. I am putting this up here because it took me two weeks of research and trial and error (and putting up with pricks that wanted to sell me their services when all they had to do was explain how they did it...). I don't think there is anything here that is cryptic but I am disclaiming my self so i don't get sued. ;)

The iPhone Configuration goes as following:

Personal Information
Name: John Dick
Email: jdick@yourcompany.com
Description: IMAP to Exchange

Incoming Mail Settings
Host name: mail.yourcompany.com
username*: jdick
password: mypassword

Outgoing Mail Settings
Host Name: mail.yourcompany.com
username*: jdick
password: mypassword

*note: some servers will use any of the following combinations: servername\jdick or jdick.yourcompany.com or any other mighty creative one. Just go for te name first and if it doesn't work then start trying other combinations.

Go into the Advanced Settings tab at the bottom. Assign the mailboxes to your iPhone (if you want), and depending on which way you want to go slide the SSL settings for incoming or outgoing.

With that close save your settings and you will be set.

Things to Remember:

Exchange 2003
  • use the IMAP Button on the iPhone
  • open ports 193 (unsecured) 993 (secured) on exchange
  • Pray your IT is not a Jdick
Exchange 2007
  • use the Exchange Button on the iPhone
  • open ports 193 (unsecured) 993 (secured) on exchange
  • Pray your IT is not a Jdick
This is how i got mine to work. I hope my guide helps others out there. Its not perfect but it works. At least it worked for me. If I find any updates I will post them here.

Any questions, just PM me or post em here, as I check this forums weekly.

Good Luck!

Kil'Djean
 
Aug 23, 2007
1
0
0
#14
Good thinking... but

This is a clever workaround, but hopefully there is, or will be, a more elegant solution for those of us that have more than a few accounts to deal with.

I'm dealing with an interesting issue. We have an Exchange server hosting two UPN's, "abc.com" and "xyz.com" . Here's a break down of what is happening:

abc.com - POP3 Outlook (success), POP3 iPhone (success)
xyz.com - POP3 Outlook (success), POP3 iPhone (failure)

All accounts are on the same Exchange server and are all configured the same way, which leads me to think there is something amiss going on in Exchange (regarding secondary UPNs), and it only affects the iPhone.
 
Sep 30, 2007
1
0
0
#15
Here's how to connect using IMAP4 / Exchange.

First, as stated before, port 993 MUST be open on the firewall. You don't need both 143 and 993 open. Pick one, and choose SSL on or off accordingly, (143 is non-SSL, 993 is SSL).

The exchange server must have the IMAP service running (right click my computer on the server, choose manage, go to services and applications, then services. Find the Microsoft Exchange IMAP service on the right, right click and go to properties, then set startup type to automatic. Make sure the service is currently started.

Now for the iPhone:
From the home button, go to settings, then Mail. Add a new account. . . the settings should look like:

Account : ON
Name : John Doe
address : johndoe@domain.com
description : John's e-mail account.

Incoming Mail Server:
Host Name : mail.domain.com (enter your e-mail domain here. This is NOT always the same as your OWA, it's whatever domain name points directly to your server. Hint: if you don't know it, check to see what the MX record is named with your domain registrar)
User Name : johndoe (or whatever username format you use, as mentioned in earlier post)
Password : password

Outgoing server:
Same as above typically. Sometimes you are required to use a different SMTP server. . . if this is the case, enter that information given to you by that ISP.

Under the advanced button:
Mailbox Behaviors and Deleted items - (all personal preference, none of these will prevent you from getting e-mail).
Settings: incoming must use SSL and outgoing must use SSL depends on which IMAP port you chose to open (see above).

Authentication : password. I had this set to md5 challenge / response and it automatically changed it, so you may not have to set this manually.
IMAP path prefix. I didn't change this, but if you change the IMAP path in Exchange, you must change it here.

NOTE: I did this setup with a server that was behind a Sonicwall once. I enabled the IMAP4 service on the firewall but wasn't getting mail. I went back and looked at the logs on the Sonicwall and found that it only opened 143. I had to go back in and manually add 993 and take out the 143.
 
Dec 27, 2007
1
0
0
#16
setup Exchange using POP3 & SMTP with SSL

I have just successfully setup my iPhone to use a POP3 account to receive and SMTP to send using SSL over my home Wireless network using Exchnage 2003 and a self issued SSL certificate using Windows 2003 server. I have a Windows 2003 / Exchange 2003 server because i do a lot of developement and testing at home for both work and because i like to keep current.

If you have an Exchange server in the office and a wireless network you can conenct your iPhone to then shoudl work for you provided your IT will allow you to use POP3 and configure it with an SSL certificate.

I am working on a document step by step on how to do this but before i upload just wnated to check if anyone was interested in knowing how to do this as the last post in the thread is September.

All i have to do remaining is to configure my iPhone to use 3G or Cloud network to use SSL POP3 / SMTP but since i have it working internally on my hom network this should just be a case of makign some firewall changes on my CISCO ADSL router to allow SSL inbound to my exchange server.

If anyone wants the guide e-mail me at matthew.dearden@networking-consultancy.com or repley to this post.

I couldn't get IMAP4 to work with SSL and when i did i couldn't display any of my mail messages.
 

jarambulo

New Member
Bronze
Dec 12, 2007
44
0
0
Atlantic City, NJ
#17
Here's how to connect using IMAP4 / Exchange.

First, as stated before, port 993 MUST be open on the firewall. You don't need both 143 and 993 open. Pick one, and choose SSL on or off accordingly, (143 is non-SSL, 993 is SSL).

The exchange server must have the IMAP service running (right click my computer on the server, choose manage, go to services and applications, then services. Find the Microsoft Exchange IMAP service on the right, right click and go to properties, then set startup type to automatic. Make sure the service is currently started.

Now for the iPhone:
From the home button, go to settings, then Mail. Add a new account. . . the settings should look like:

Account : ON
Name : John Doe
address : johndoe@domain.com
description : John's e-mail account.

Incoming Mail Server:
Host Name : mail.domain.com (enter your e-mail domain here. This is NOT always the same as your OWA, it's whatever domain name points directly to your server. Hint: if you don't know it, check to see what the MX record is named with your domain registrar)
User Name : johndoe (or whatever username format you use, as mentioned in earlier post)
Password : password

Outgoing server:
Same as above typically. Sometimes you are required to use a different SMTP server. . . if this is the case, enter that information given to you by that ISP.

Under the advanced button:
Mailbox Behaviors and Deleted items - (all personal preference, none of these will prevent you from getting e-mail).
Settings: incoming must use SSL and outgoing must use SSL depends on which IMAP port you chose to open (see above).

Authentication : password. I had this set to md5 challenge / response and it automatically changed it, so you may not have to set this manually.
IMAP path prefix. I didn't change this, but if you change the IMAP path in Exchange, you must change it here.

NOTE: I did this setup with a server that was behind a Sonicwall once. I enabled the IMAP4 service on the firewall but wasn't getting mail. I went back and looked at the logs on the Sonicwall and found that it only opened 143. I had to go back in and manually add 993 and take out the 143.

Does anyone know how to setup on Outlook? I need help
 
Jun 16, 2008
1
0
0
#18
Kil'Djean

Thanks you in advance for all the hard work you apparently have done to try and get this email thing working for all of us with the iPhone.

I just spent about an hour with my IT department trying to get things set up. I followed the instructions to the letter with a couple of exceptions (detailed below) and I am getting messages that the IMAP server is not responding...

So...here is what is 'slightly' different about my situation.

1. The IT department will NOT open port 143 but did open port 993
2. Tried connecting via SSL, but won't work.
3. Tried every combination of server\username
4. Verified password
5. Mail server is using OWA so the reference is: webmail.companyname.com -- does that make a difference?
6. I am using my wifi from home to connect to the network, as I live in an area where ATT services is very spotty. Does this make a difference?
7. Finally, my IT department is not 'up to speed' on IMAP. Are there any special setting that should be enabled?

Any suggestions from anyone would be great...massive frustration is prevailing here.

Brand new to the forum...been a lurker but never needed to post until now.

Cheers,

Man-in-Black
How do you add the Certificate to the iPhone.

Gerry
 

GuyFawkes

New Member
Bronze
Jul 4, 2007
46
0
0
#19
I had similar problems and it was driving me crazy. I set it up as 'IMAP'... and in the advanced section, set both SSL settings to 'OFF'. This worked for me and started syncing immediately.
I just updated my phone to the 2.0 firmware and was having a hard time trying to connect to Exchange with the new feature. This tip to turn off the SSL fixed my problem. Thanks for posting this!

Guy
 

flabyboy

New Member
Jun 25, 2008
769
0
0
Minnesota
#20
anybody here know how ATT becomes aware if you are using enterprise services or not. I just set my service up with my company, but only have the $30 data plan