External hard drives

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
May 1, 2011
7
0
1
#1
I just bought a Western Digital 1TB hard drive. I went to transfer all the files from my old hard drive to the new one on my MacBook Pro and it doesn't let me. What am I doing wrong.

Thanks
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,384
1,089
113
DC
#2
What happens when you try? Do you get an error message?

Typically when this happens, it means the drive you're trying to write to is formatted in NTFS (windows-friendly file system). Macs can read NTFS, but not write to it. So what you may need to do is format the drive as either FAT (will work with both Mac and Windows, but has some limitations), or, if you are only going to be using it on your mac in the future, format it as "Mac OS Extended (Journaled)".

If this is the problem and you need instructions on how to do it, just say so.
 
May 1, 2011
7
0
1
#3
I'm trying to format on my MacBook pro. I'm getting an error message that says, "cannot dismount volumes" volume busy and can't be dismounted. I would much rather format the hard drive so I can use it on Mac and PC. I don't see it as an option. What can I do? Thank you for responding.
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,384
1,089
113
DC
#4
regarding the "cannot dismount volumes" thing - have you tried restarting? Your computer may still be trying to use files on that drive for some reason, and restarting ought to take care of that.

To format it to be compatible with windows and Mac, open Disk Utility, select the hard drive in the left column, select the "Erase" tab, choose "MS-DOS (FAT)" next to "Format", then click "Erase". The biggest drawback with using FAT32 is that it cannot hold files larger than 4GB (usually videos). If that isn't an issue for you, it should otherwise work pretty well.

 

jerni

Member
Bronze
Oct 2, 2008
424
2
18
GA
www.instagram.com
#5
regarding the "cannot dismount volumes" thing - have you tried restarting? Your computer may still be trying to use files on that drive for some reason, and restarting ought to take care of that.

To format it to be compatible with windows and Mac, open Disk Utility, select the hard drive in the left column, select the "Erase" tab, choose "MS-DOS (FAT)" next to "Format", then click "Erase". The biggest drawback with using FAT32 is that it cannot hold files larger than 4GB (usually videos). If that isn't an issue for you, it should otherwise work pretty well.

Hey I'm needing to revive this topic. My hubby bought me a 2tb WD hard drive but it's the 'My passport for Mac' well what I use my hard drive for I need my PS3 to be able to read files on it. So I figure I need to reformat but in my options in the screen above MS-DOS (FAT) is not an option. Only the Mac OS options and ExFat.

How do I resolve this? How do I reformat this hard drive to be used on my PS3 and 360?
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,384
1,089
113
DC
#6
In my screenshot above, click on the "partition" tab at the top. In the drop-down menu at the left of that window, choose the partition scheme you want (sounds like you just want one, but you can pick whatever). Then the important part is to click the "options..." button underneath the partition layout. It's probably on "Apple Partition Map" now, which isn't compatible with FAT. Choose "GUID Partition Table", then "apply" and then you should be able to format to FAT like you want.
 

jerni

Member
Bronze
Oct 2, 2008
424
2
18
GA
www.instagram.com
#7
In my screenshot above, click on the "partition" tab at the top. In the drop-down menu at the left of that window, choose the partition scheme you want (sounds like you just want one, but you can pick whatever). Then the important part is to click the "options..." button underneath the partition layout. It's probably on "Apple Partition Map" now, which isn't compatible with FAT. Choose "GUID Partition Table", then "apply" and then you should be able to format to FAT like you want.
So I just exchanged the hard drive for one not formatted for Mac. My MacBook sees the drive but the drive says "read only". How do I fix that?
 

Lon

Evangelist
Gold
Jun 5, 2010
2,946
132
63
Alaska
#8
Go with exfat. It works on both Mac and PC. However, it doesn't work with some of the older operating systems.


Sent using iCafe app