Failed Calls & Searching for Service

Discussion in 'iPhone' started by Europa, Jan 1, 2012.

  1. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,471
    I've had a factory unlocked 4S (I'm using an AT&T SIM) for eight days and I've had a failed call and loss of service five times. Each time it has occurred while I was at home with five bars. The call drops and I see the failed call notification. Then about five seconds later the phone searches for service. After about ten seconds it locks on to AT&T and has five bars again. I reset the network settings and it didn't help. On one occasion my caller heard a loud, high-pitched screech just prior to the failed call. I set this phone up as a new device when I got it last week. I still need to try a restore to factory settings.

    I had failed calls on the iPhone 4, but they were no where near as frequent and the phone didn't search for a signal after the dropped call.

    Is anyone else here experiencing this problem? I'm thinking about exchanging the phone.
     
  2. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    4,443
    I was the caller. My ear is still in a cast. Exchange that damned thing. Thank you.
     
  3. Jmbaker429

    Jmbaker429 Evangelist
    Gold

    Joined:
    Jun 28, 2010
    Likes Received:
    146
    I have a 4s on AT&T and experience more dropped calls now than ever. Never this bad on past devices. I haven't had it search for service when there was service available. Sounds like you have done everything that you can do yourself from home. If it was me I would deffinately try to swap it out. I have not tried anything with mine just bc I think it's the service and not the phone, but not sure. I get dropped calls even with 5 bars. Also I have never had anyone complain of a noise when a call is dropped just dead air. Let us know what you decide. Hopefully they will just swap it out without too much of a hassle. I remember I used to have Nextel, and I left them bc when they merged with sprint I was dropping ever other call it seemed. I hope that it's just something AT&T can fix, and hopefully they fix it soon bc it's very inconvenient especially using the phone for work.
     
  4. Leo

    Leo Zealot
    Silver

    Joined:
    Nov 9, 2008
    Likes Received:
    133
    Do a complete restore, there's a newer 5.0.1 that fixes this issue in 4S's, but you can only get it via restoring your phone if you're already on the older 5.0.1.
     
  5. Jmbaker429

    Jmbaker429 Evangelist
    Gold

    Joined:
    Jun 28, 2010
    Likes Received:
    146
    ah I forgot about that. I knew there was a second 5.0.1 but did t realize that it was to fix this problem. So if you were on the old 5.0.1 it wont show you that their is a new update to the new 5.0.1?
     
  6. Rafagon

    Rafagon Genius
    Gold

    Joined:
    Dec 7, 2011
    Likes Received:
    1,247
    It doesn't. It was a tweaked 5.0.1 with a new build number. You had to know about it and proactively go and get it.

    I found a post which described Europa's issue pretty much verbatim, and the user claims the new build fixed it. It's the second post here

    [See following post]

    I originally posted a link rather than a screenshot but then the link didn't work.

    Sent from my alphanumeric pager.
     
  7. Rafagon

    Rafagon Genius
    Gold

    Joined:
    Dec 7, 2011
    Likes Received:
    1,247
  8. Vonwachtstain

    Vonwachtstain Member
    Bronze

    Joined:
    Jan 2, 2011
    Likes Received:
    13
    I had the same problem yesterday. Full signal but it wouldn't collect calls and when it did they failed really fast. As for high pitched sound I have one EVERY time right after I get connected no matter if I call it somebody calls me. My iPhone 4 had the same problem.
     
  9. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,471
    It was shipped with 5.0.1 9A406 (the second 5.0.1 build). I'm not experiencing any No SIM or No Service issues. The problem is a failed call at five bars, then Searching for Service a few seconds later, then a return to five bars a few seconds after that.
     
  10. rom x

    rom x Zealot
    Gold

    Joined:
    Jan 18, 2011
    Likes Received:
    99
    i think it's a network issue cause i have sprint and i have never heard a loud, high-pitched screech when making or on a phone call.
     
  11. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,471
    I didn't hear it. The person I was talking to heard it right before the call dropped last night.

    I think I'll just have Apple ship me a replacement.
     
  12. Rafagon

    Rafagon Genius
    Gold

    Joined:
    Dec 7, 2011
    Likes Received:
    1,247
    And then the caller himself dropped. He reported his ear was in a cast, LOL.

    Funny, my 4S came with the same build as yours, and so far none of those issues. All these inconsistencies! Those Foxconn employees need to disinfect their hands better and wear more face masks before they put their hands on our devices!


    Sent from my alphanumeric pager.
     

Share This Page