First Generation iPhone and WiFi Issues with 3.0 and 3.0.1 software

camelwino

New Member
Sep 16, 2007
10
0
1
#1
I have a first generation iPhone and have been reluctant to install 3.0 or 3.0.1 because of issues concerning Wifi that I have read on various on-line forums. I guess I am hoping that maybe 3.1 will fix these problems. My Applecare coverage will expire in a few weeks. So, do I install 3.0.1 and risk WiFi failure or wait until 3.1 is available (probably after my Applecare coverage expires)? If I go ahead and install 3.0.1 now and Wifi fails, and the Apple Store is unable to fix it, what will they offer as a replacement? A 3G? Wifi may fail on it also. Any suggestions would be appreciated. Thanks.
 

camelwino

New Member
Sep 16, 2007
10
0
1
#2
WiFi and 3.0/3.0.1

Are there no suggestions out there? Or is the WiFi buzz just a hoax? A lot of people appear to be having problems.