Fix for No WiFi issues

Discussion in 'iPhone Jailbreak' started by justinxtreme, Nov 22, 2009.

  1. justinxtreme

    justinxtreme New Member

    Hello guys, I may be able to get the "No WiFi" issues people have been experiencing lately.

    Cause of "No WiFi" issues
    If your like me you probably weren't in the iPhone scene until like OS 2.0 or OS 3.0... Well for those who bought an iPhone back in 2007 when it came out for freaking $599 well you may know about this. Anyways back in 2007 unlocking tools started appearing and well a lot of them like ZiPhone corrupted the baseband sometimes and you had to reinstall it. Well that problem as come up again except instead of this problem coming up from a hack it comes from a official firmware release from Apple. Problem is iPhone 3G and 3GS users have a more secure bootloader except for the lucky ones who bought the iPhone 3G the first few months it came out (Until September 2008*. If you are ones of those lucky ones just read the * later on this post.

    Possible fixes
    Well you can reinstall or update the baseband. I'm going to refer to iPhone 3G's and 3GS with 5.09 and higher bootloaders on this part of the article. Anyways you can try using iRecovery and override the WiFi Mac Address settings so when the iPhone baseband checks for it, it will find it. I tried it but didn't work for me but you guys can still try it and also these steps confirm if your "No WiFi" problem is a software problem (most probably is a software problem) or hardware problem

    1.Setup iRecovery for use (You'll need Microsoft C++ Visual Redistributable)
    2.Put your iPhone into Recovery Mode (Hold Home Button before it boots up and keep holding it until it goes into Recovery Mode)
    3. Run iRecovery (navigate to where it's located using cd through Command Prompt then run it using the command "irecovery -s")
    4.Check whether or not it's a software or hardware problem and get the Mac Address of your WiFi hardware (Run the command in iRecovery "radio readnvram" and check if it has A Mac Address for your WiFi hardware if it does it's a software problem and write down that Mac Address if it doesn't or has x's or something then sorry but it's a hardware problem)
    5. Type in saveenv wifiaddr xx:xx:xx:xx:xx (Where xx:xx:xx:x:xx is is where you put your WiFi Mac address
    6. Type in printenv wifiaddr
    7. Type in fsboot
    8. Type in reset
    9. Exit out of iRecovery using /exit
    10 Close Command Prompt
    11. Check if it fixed it

    Another fix is through forcing a baseband install and well I don't know much about it yet. But you will need bbupdater and use iPhoneBrowser to place it into I think /bin but I'm not sure I'll update my information once I research it (It's 3AM so yeah). I'll research more about this and this also involves getting a baseband of the same version your using you can't downgrade your baseband through this if your thinking about that (Well you wouldn't be right now but later on when Apple does release a new baseband update and it blocks blacksn0w then yeah)

    A definite fix is if Apple releases a baseband update then you should update to it, it will fix it. As it updates the baseband meaning it will also install a newer version otherwise reinstalling. If your on 04.xx.xx baseband then update now to 05.11.07 (currently as of November 2009) and fix your WiFi problems


    * If you have a iPhone 3G you bought the first few months it came out then it probably has the 5.08 Bootloader (Bootloader versions can't be changed on the iPhone 3G and 3GS). You can use Fuzzyband to downgrade (meaning it will also reinstall) the baseband. I will post the Fuzzyband deb file for people to use. Jailbreak your iPhone (using a custom firmware not blackra1n since you don't have WiFi) and then use iPhoneBrowser to put the files on to /var/root/Cydia/AutoInstall. Then restart your iPhone and it will install Fuzzyband then afterwards use it to downgrade your baseband.
  2. justinxtreme

    justinxtreme New Member

    Oh by the way,
    You can't use Swifi I tried it. It won't work with the new iPhone 3Gs and 3GSs but if you have a iPhone 3G with 5.08 bootloader it might work on yours.

    How I made Swifi to work and launch
    -I downloaded Swifi off their website and put it into /bin using iPhoneBrowser
    -Install MobileTerminal through iPhoneBrowser
    -Install BootNueter using iPhoneBrowser
    -Run BootNueter and after like a minute quit it
    -Run Mobile terminal and get administrative privileges by typing su then my password (default password is alpine)
    -Then navigate to where Swifi is located (which is at /bin so I type in cd /bin)
    -Then type in Swifi
    -It will stop at the Musclenerd line and not go any further.

    Yeah so Swifi won't work with the new iPhoen 3Gs and iPhone 3GS
  3. Avatar

    Sponsored Advertisement

  4. From what I know, only bootloaders 5.8 and lower can be downgraded. This can be done with Fuzzyband from Cydia. Interesting article, though.
  5. justinxtreme

    justinxtreme New Member

    Thanks for the compliment... Does anyone know or specialize in the bbupdater program. I'm trying to figure out how to force install the baseband since the baseband installer doesn't reinstall basebands of the same version you'll need to force it... unless you have a 5.08 bootloader iPhone 3G which many don't have

    Also any other solutions people can contribute?
  6. justinxtreme

    justinxtreme New Member

    Anyone? Please

    Also is there a way that I can just send my iPhone to Apple instead of going to the Apple Store.... since my parents don't have time for that.
  7. justinxtreme

    justinxtreme New Member

    I'm almost complete with my research in forcing a baseband install with an iPhone 3G... as it turns out I might be able to mark the 05.11.07 baseband as a newer baseband (I won't tell you how yet I might be able to use this exploit or give it to geohot to downgrade basebands in the future)

    In my research it seems as if this No WiFi thing has occurred 2 years ago (2007-2008) when unlocking with ZiPhone and all (I'm new to the iPhone scene btw started August 2009). It would corrupt the baseband if not done properly or if it is rushed or something.... two years later in 2009 Apple releases a baseband update which corrupts some iPhone's baseband... why? because they rushed it...

    Fixes
    Trick bbupdater into thinking it's updating instead of reinstalling the same baseband I'm marking the 05.11.07 baseband (or whatever baseband) as a newer baseband (05.11.08 or something greater)

    There's no methods I could use to force install the same baseband as everytime I tried bbupdater would always reject it... so only way is to mark the baseband update as a newer version (it's not really newer but I'm just marking it so bbupdater will accept it)... which I'm currently working on

    I'm not done yet but once I'm done I'll release the fix
    It should be pretty helpful seeing that there's a 100-page thread on Apple's forums about this issue just that no one seems to be "advanced" or "technical" enough to actually research... I'm only 13....

    EXPLOIT!!!! YAY!!! THIS IS SO AWESOME I COULD USE IT FOR THE NEXT BASEBAND UPDATE TOO....
  8. Iphnwfsks

    Iphnwfsks New Member

    Wifi Sucks

    Hi,

    Just to be 13 you are very ahead on this field, I'm new and my Iphone 3G has the WIFI problems after updating to the latest version, I've been doing the "Reset Network Settings", total reset, install lates versions 3.1.2, but wi fi is not available, I went to the Apple store but the warranty expired and in order to replace it for a new one, I have to pay $200.00...This is a software issue and apple should provide a quick solution, also I noticed that once the wifi is disable the battery is discharging faster. Please let me know when you figure out other steps to fixed this problem. Thank you and good job. :eek:k:eek:k





  9. ZipZap

    ZipZap Member

    SO are you saying tha geohot rushed his JB and caused the problem? That would seem to jibe with the results.
  10. justinxtreme

    justinxtreme New Member

    @ ZipZap
    No, it's the other way around. Apple rushed the 3.1 software
  11. justinxtreme

    justinxtreme New Member

    George Hotz had nothing to do with the "No WiFi" problem. It is most likely occuring why? Because since blackra1n unlocks the iPhone when the OS probably reports to the baseband (Like always the baseband is always locked) and that false information (you do know the "unlock" Geohot and the iPhone Dev Team have been using are through making the OS think it's not locked it's not a hardware unlock and I'm not going to get into why they don't try using hardware unlock)it probably rearrises the problems baseband 5.11.07 has. But I'm not sure cause I haven't gotten into this stuff that much yet

    One recommendation: If you have baseband below 5.xx.xx I recommend to stay with that. There's no advantages of going to 5.xx.xx baseband. In fact 5.xx.xx is kind of buggy, Apple messed up somewhat.

    BUT REMEMBER THIS IS JUST A POV I'M 13

    Also about the exploit.... I tried a few times and it fails several times and only once sucessful for unlock. I think I need to find a way to inject it right...

    About the "hardware unlock": If your iPhone is genuinely hardware unlocked it will never be locked to networks.

    So then why won't the hackers make a hardware unlock solution?
    OK every iPhone has a unique ID for unlocking and it's stored right there on Apple's servers waiting...

    To hardware unlock your iPhone you will need that ID (it's a file I think).

    I'm not sure about this but hardware unlocking may require that you seperate the baseband chip from the Commboard chip (which a lot of people wouldn't be willing to do) ande connecting it to a computer directly to comminucate (This is a wierd step I don't know how to connect them.... haven't researched yet)

    Then after connection, you erase the current baseband ID and apply the unlock ID file to unlock it, it's like putting in a unlock code for a phone.

    Then put it back to the Commboard and put back your iPhone and boot up and done

    But the best way is unlocking with priviledges, Apple and some hackers (including geohot) have been able to somehow communicate with the baseband though Apple is really the only one who can fully communicate with it. Apple can simply just send and apply the ID automatically just by connecting your iPhone to your PC/Mac
  12. ZipZap

    ZipZap Member

    NO Problem with No Blackrain installed

    PROBLEMS when Blackrain installed

    Therefore.....Blackrain is causing problem. The fact that he has said he could fix for the right price..is all I need to hear to blame Blackrain.

    Now I do appreciate what Blackrain delivers to folks...but it is causing problems.

    Pwnage is a better choice if you can use it.
  13. merv0190

    merv0190 New Member

    baseband

    hey Justinxtreme

    I have a iPhone 2G

    I am putting some info here to see if you can help me.
    I was on 3.1.2 then I downgraded to 3.0 then I downgraded to 2.0 then to 1.1.4 then I downgraded my baseband using kiphone then I erased my baseband using kiphone then I restored to 1.1.4 with baseband 04.04.05_G then without jailbreaking I upgraded to 3.1.2 again so upgrading the firmware version and also the baseband to 04.05.04_G.I had WIFI for like 10 hours then it went back to the NO WIFI issue.

    So I do not believe it is a baseband problem anymore(I believe it..regarding that so many people said that they downgraded the firmware version but it didn't fixed the problem so it cannot be the firmwarte version that is being changed.But the baseband is not being changed while downgrading so I believe it was the baseband but right no I do not believe it any more..
    I did the irecovery thing and here is screenshot I got stuck at the radio thing because it didn't do anything when I put it.

    So any help would be appreciated.
  14. merv0190

    merv0190 New Member

  15. machete

    machete New Member

    wifi issue

    Ok, I've been following this thread and find it very interesting that someone is trying to tackle this issue since Apple seems to know about it and are ignoring it. As a matter of fact, they even removed all my posts regarding this issue that I put on one of the threads on their site. I'm not going to argue with their sysops since they have the right to monitor whatever gets posted on their own forums, but I told them that I'm going to spread the truth about this...

    THIS ISSUE IS DEFINITELY SOFTWARE RELATED!!!!

    I can't say it enough. As I posted on the apple forum previously, before they removed it, I have upgraded my 2G to every train of the version 2 software and then up to version 3 and above with the same issue - the phone gets very hot, battery only lasts about 4 hours or less and no wifi. As soon as I downgrade to version 1.1.4, still running the latest baseband, 04.05.04_G, the wifi works fine and the battery lasts for a couple of days without any issues. What's weird is that with the 2G iphone, the baseband hasn't changed since version 2, but as soon as I upgraded from version 1.1.4, I have had this issue. It's definitely something in the software that is causing this issue. And as the posts show, it has nothing to do with whether the phone has been jailbroken, unlocked or not, as some users that have never done that experience these same issues as well.

    As merv0190 points out in his postings, I get the same behavior when upgraded to version 3, using iRecovery. I can connect to the phone, however, none of the commands return any values, so I can't verify anything. I'm currently at version 1.1.4 without any issues and I'm going to stay there until someone else has any other options or input for something to try. Since we know that most likely they aren't going to upgrade the baseband for the 2G iphone, there has to be some sort of work around to force it to update that and trick it into installing a working copy, if the problem indeed lies with the baseband. It's very frustrating as I have a friend with a 2G phone that bought his about a week before I did back in '07 and used the same tools to jailbreak and unlock his phone and he doesn't have the same issues. I can't determine what the difference is or why some have this issue and others don't....

    -Machete
  16. ZipZap

    ZipZap Member

    You have a hacked phone...why would Apple want to address your issue. You're moving across OS versions and basebands, hacking all the way. As I understand it the baseband cannot be downgraded without a hack.

    I do agree that the WIFI issue is one that should be addressed...but it seems to only happen on hacked phones...so I doubt apple will really care.

    Finally, if you have a unit that overheats replace it.
  17. machete

    machete New Member

    wifi issue

    Understood that they wouldn't want to help me with a hacked phone but I never took it to an Apple store, imploring them for assistance. I simply added my experience and what I found in downgrading and upgrading on one of the threads they have on their site. Obviously, since I pointed out the most obvious, that it's a software issue, they didn't like that and ripped it off. That's fine - if they want to cover things up and delete evidence of a software bug, that's their prerogative. That's why I won't post on their site anymore ;). But that doesn't mean I'm going to keep quiet about what I've found out.

    And sorry, Mr. ZipZap, you're missing the point completely in that -

    1 - The broken wifi issue happens to some that have hacked their phones and some that have never hacked their phones. This issue isn't just affecting those that have hacked phones.

    2 - My phone only gets hot when this wifi issue is experienced (it does not overheat to where it would damage the unit), due to something in the software. It apparently can't activate something that makes the wifi chip work, which causes rapid battery consumption and excessive heating of the phone (most likely due to miscommunication with the wifi chip or constant, repeated attempts to active the wifi chip...who knows. If we did, I'm sure we'd have it fixed by now).

    Furthermore, since I have downgraded to version 1.1.4, I no longer have the issue - wifi works and the phone doesn't get hot, consuming the battery in 4 hours. Instead, I can use the phone for hours and have it on standby for a good couple days.....it is clearly an issue with the software and something between the baseband on certain models. What the correlation is still remains a mystery. I believe that justinxtreme is on to something in that it could be a corrupted baseband issue.

    -Machete
  18. merv0190

    merv0190 New Member

    Jailbreak

    Hello machete could you tell me with which software you jailbreaked your 1.1.4 firmware?

    Thank you
  19. machete

    machete New Member

    1.1.4 jailbreak

    Here are the instructions I had posted on the apple forum...it's probably why they ripped off all my posts. These are instructions to downgrade from version 3.1.2 to 1.1.4. I used pwnagetool 1.1.


    You will need the following tools to perform this:

    - Firmware 1.1.4 - http://appldnld.apple.com.edgesuite...0226.Sw39i/iPhone1,1_1.1.4_4A102_Restore.ipsw

    - iTunes 8 - http://www.oldapps.com/itunes.php?old_itunes=34

    - pwnagetool version 1.1 - http://www.iphone-hacks.com/iphone-downloads/file/99

    - Bootloaders 3.9 and 4.6 - http://www.rapidshare.com/files/104494661/bootloaders.rar

    Naturally, if the above links don't work, just google them and you'll find them.

    Now that you have the necessary tools, make sure you rip off your existing iTunes or install version 8 on another machine and work from that one. That's what I do so I don't screw with my iTunes library. To do all the downgrades and upgrades I've been doing, I have been working with 3 different machines, a Macbook, Powerbook and a Winblows box (yes, occasionally a windows machine does have some useful purpose other than a paperweight).

    The procedure I follow to downgrade is the following (it's flawless and works every time):

    First, let's create our custom, unlocked 1.1.4 via pwnagetool. From a Mac (this step I've only done from my Macs because I don't believe there is the correct pwnagetool for winblows for this step), download and start pwnagetool 1.1 and click on the Browse .ipsw to the location where you have the 1.1.4 firmware saved. Enable the following - Activate phone, Enable baseband update, Neuter bootloader, Unlock baseband, Auto delete BootNeuter.app. Click Ok then choose the booloader files you downloaded, then choose a location to save your pwned 1.1.4 firmware and save it. Once this has completed, quit pwnagetool.

    Make sure your computer has iTunes version 8 installed on it

    Put your phone in Recovery Mode and connect it, letting iTunes find it.

    Restore the original 1.1.4 firmware that you downloaded. You will receive a 1015 error or something to that effect when restoring. That's perfectly normal. Next, restore again. Yes, it's very important to do it again and you will receive the 1015 error after that again. Next, we need to pwn it.

    Fire up pwnagetool 1.1 again, and browse once more to the location where you downloaded the original 1.1.4 firmware. Next, all we're going to do is pwn it by clicking the iPwner button. This will run through the process and you will see all the commands and processes on the screen and after a reboot, you will get the pineapple logo and the phone will come up to a locked screen. You should still have your sim unlock since most likely it will still have the 04.05.04_G baseband which is already unlocked, but the phone won't be activated yet. Here's where you will restore with the modified 1.1.4 firmware that you just built earlier.

    Quit pwnagetool, put your phone in Recovery mode (you should see Steve jobs with his hands in the air, telling you "hi" or "surprise" when in recovery mode) and fire up iTunes. This time, restore the custom 1.1.4 firmware you created earlier and when it's done, you should have a fully unlocked, activated and downgraded iphone running 1.1.4 again. Too bad all the cool features they have added are no longer there, but hey, at least your battery will last enough to make more than a couple calls!


    -Machete
  20. bparkerson04

    bparkerson04 Member

    Just out of curiousity, if you experience this wifi issue after jailbreaking, can it be fixed by doing a restore to new phone? I am a little lost because of my unfamiliarity with this subject. I recently jailbroke my phone using blackra1n, and so far I have not had any issues with wifi.
  21. machete

    machete New Member

    1.1.4 jailbreak

    I have done a full restore and tried to use a friend's AT&T SIM in order to activate it without hacking it to see if the problem still occurred but he didn't want to mess up his activation using his SIM in my phone, so we never went through with it. So, ultimately, I haven't ruled out the fact that something with the jailbreaking could be causing this issue.

    And what's weird is that his phone is jailbroken and unlocked and he purchased it just 1 week before I did back in 2007. The only difference is that his had version 1.1.1 out of the box and mine had 1.1.2 with the latest baseband at that time. It took about 2 months before there was an unlock for it and that was using a piggyback SIM chip. The software unlock for the 1.1.2 software didn't come out for some time after that.

    But either way, he doesn't experience the same issues and is running 3.1.2 without any issues and he unlocked it and jailbroke it in the same manner that I did. So, yes some phones will experience this issue and others, like my friends and yours won't.


    -Machete

Share This Page