"Forget This Network" button not there

-bc-

New Member
Sep 9, 2007
4
0
0
#1
I have been trying to connect to my home wireless network. Its set up with a username of Diana with 128 Bit WEP encription. The network works fine with my Desktop and Laptop so I know that end is working. When I chose WiFi settings on my iPhone / I get Choose a Network/ and it lists my network "Diana". To the right I have 3 icons, a locked padalock, the signal icon, and the blue >. If I press the > icon (actually any of the 3) I get a screen with the following:

At top is a left facing arrow that reads Wi-Fi Networks, than Diana (my network name), nothing else.
Under that line is IP Address, under that is DHCP, BootP, and Static.

Under tht is a list of IP Address, then Subnet Mask... through Client ID. None of those variables have any data associated with them.

Under that list is HTTP Proxy, currently set to OFF. Nothing else is on that screen. If I set the HTTP Proxy to Manual I COULD (but have not as yet) enter server, port, Authentication (currently set to ON), username and Password).

That is it. I find no place to enter WEP encriptioin and can find no sign of a "Forget this Network" button. I've tried putting it in Airplane mode for a while and returning, no change.

I have Software version 1.02

Anyone have any ideas?
 

ps49556n

New Member
Silver
Jun 21, 2007
545
1
0
NYC
#2
The first step to resolve a problem like this is to completely reset and reconfigure the wifi network. Do no just reset the router, manually delete all the infor for the wifi network form a computer and re enter it. If you still have the problem, restore your iPhone. After that if it still persists, call Apple support.
 

-bc-

New Member
Sep 9, 2007
4
0
0
#3
Update,

Well I'm not sure I know why I would need to reconfigure my whole network as the wireless network works fine with everything except the iPhone. And its iPhone features that seem to be the problem.

What I have done, however, is to disable WEP security at the router. That lead to some interesting things. First, I was able to join the network w/o any issues. Also, the mysterious "forget this network" button appeared so I chose it and it behaved as expected, i.e., it forgot the network and provided me with a new option at the bottom, "renew lease" (which I did not do at this point).

I then put my phone in Airplane Mode, reenabled WEP on my router, turned off Airplane mode, and the phone returned to the state it had been in before, i.e., no provision to enter a WEP code, no ability to "forget this network" and unable to log in.
 

goblues38

Member
Bronze
Sep 7, 2007
49
0
6
#4
Update,

Well I'm not sure I know why I would need to reconfigure my whole network as the wireless network works fine with everything except the iPhone. And its iPhone features that seem to be the problem.
.

because the iPhone has stored some wrong information about your network, you have to redo the network. Simply adding a 1 lto you ssid ike "DIANA1" will be enought to get iTunes to see it as a NEW network, and allow you to reset up the credentials. Adding a simple extra digit to your ssid will minimize the work you will need to do to make other devices see the network.

make sense?
 

-bc-

New Member
Sep 9, 2007
4
0
0
#5
because the iPhone has stored some wrong information about your network, you have to redo the network. Simply adding a 1 lto you ssid ike "DIANA1" will be enought to get iTunes to see it as a NEW network, and allow you to reset up the credentials. Adding a simple extra digit to your ssid will minimize the work you will need to do to make other devices see the network.

make sense?
Yes, actually that does make sense now thank you. SOOOOO, this is what I did, I again went into the router and disabled WEP but left the SSID DIANA, then logged in with iPhone and chose forget this network.

I then went back to the router and changed the SSID to a completely different name, saved it W/O WEP, and logged in with iPhone; No problem.
I then reenabled WEP, and tried to log in again. This time it wanted a "password". Didn't ask for a WEP passphrase, or hex code, only "password", which is what it did initially with my other SSID. Rather then go down the same path I figured I'd back out and see if this makes snese.

Anyone have any thoughts? Is "password" synonomous with "passphrase"?
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#6
because the iPhone has stored some wrong information about your network, you have to redo the network. Simply adding a 1 lto you ssid ike "DIANA1" will be enought to get iTunes to see it as a NEW network, and allow you to reset up the credentials. Adding a simple extra digit to your ssid will minimize the work you will need to do to make other devices see the network.

make sense?
Not really. The problem is not with the router, so aside from changing WEP/WPA settings I wouldn't touch it--and I certainly wouldn't reconfigure the WLAN when there are other devices already working properly with it.

To the OP:
Are you sure you actually joined your WLAN? It sounds like you tapped the ">" next to your SSID, which doesn't join it. Forgive me for stating the obvious, but you tap the SSID name to join it. After it's joined you can use ">" to see "Forget this Network." If it's joined it will have a check mark next to it. If not you are not connected.

If you want to be sure clear out the settings on the iPhone go to Settings-->General-->Reset-->Reset Network Settings. This will clear out any joined WLANs.

Finally, I would recommend using WPA over WEP. But in either case the iPhone should ask for a password when joining a protected WLAN.


--
Mike
 

-bc-

New Member
Sep 9, 2007
4
0
0
#7
Not really. The problem is not with the router, so aside from changing WEP/WPA settings I wouldn't touch it--and I certainly wouldn't reconfigure the WLAN when there are other devices already working properly with it.

To the OP:
Are you sure you actually joined your WLAN? It sounds like you tapped the ">" next to your SSID, which doesn't join it. Forgive me for stating the obvious, but you tap the SSID name to join it. After it's joined you can use ">" to see "Forget this Network." If it's joined it will have a check mark next to it. If not you are not connected.

If you want to be sure clear out the settings on the iPhone go to Settings-->General-->Reset-->Reset Network Settings. This will clear out any joined WLANs.

Finally, I would recommend using WPA over WEP. But in either case the iPhone should ask for a password when joining a protected WLAN.


--
Mike
I'm never insulted when asked "obvious questions" I hate to tell you the number of service calls i've made just to plug back in a computer or change a fuse.

Anyway, in this case I did hit the SSID (and not the >) and it askes for a password. The only "Password" associated with this network is the WEP Passphrase which I've tried entering repeatedly w/o success. I have never been presented with a query for the WEP Hex code or Passphrase other then a request for "password". (Mind you I have ALSO tried hitting the > but I have hit the ssid too)

As for WPA, you are probably writhg. I really have no reason to stick with WEP anymore, there is only one other wireless device using the network and it is easy enough to change that. I think I'll just try changing one thing at a time though. My first step will be to try resetting the iPhone network settings.

Thank you for your help.

Bruce
 
Jan 5, 2014
1
0
1
#8
I have been trying to connect to my home wireless network. Its set up with a username of Diana with 128 Bit WEP encription. The network works fine with my Desktop and Laptop so I know that end is working. When I chose WiFi settings on my iPhone / I get Choose a Network/ and it lists my network "Diana". To the right I have 3 icons, a locked padalock, the signal icon, and the blue >. If I press the > icon (actually any of the 3) I get a screen with the following:

At top is a left facing arrow that reads Wi-Fi Networks, than Diana (my network name), nothing else.
Under that line is IP Address, under that is DHCP, BootP, and Static.

Under tht is a list of IP Address, then Subnet Mask... through Client ID. None of those variables have any data associated with them.

Under that list is HTTP Proxy, currently set to OFF. Nothing else is on that screen. If I set the HTTP Proxy to Manual I COULD (but have not as yet) enter server, port, Authentication (currently set to ON), username and Password).

That is it. I find no place to enter WEP encriptioin and can find no sign of a "Forget this Network" button. I've tried putting it in Airplane mode for a while and returning, no change.

I have Software version 1.02

Anyone have any ideas?
I have been trying to connect to my home wireless network. Its set up with a username of Diana with 128 Bit WEP encription. The network works fine with my Desktop and Laptop so I know that end is working. When I chose WiFi settings on my iPhone / I get Choose a Network/ and it lists my network "Diana". To the right I have 3 icons, a locked padalock, the signal icon, and the blue >. If I press the > icon (actually any of the 3) I get a screen with the following:

At top is a left facing arrow that reads Wi-Fi Networks, than Diana (my network name), nothing else.
Under that line is IP Address, under that is DHCP, BootP, and Static.

Under tht is a list of IP Address, then Subnet Mask... through Client ID. None of those variables have any data associated with them.

Under that list is HTTP Proxy, currently set to OFF. Nothing else is on that screen. If I set the HTTP Proxy to Manual I COULD (but have not as yet) enter server, port, Authentication (currently set to ON), username and Password).

That is it. I find no place to enter WEP encriptioin and can find no sign of a "Forget this Network" button. I've tried putting it in Airplane mode for a while and returning, no change.

I have Software version 1.02

Anyone have any ideas?
Go to Settings, turn on Airplane Mode. Turn off the Power button. Leave for a minute and turn on the Power button. Then turn off Airplane Mode and your previous Wifi setting should be restored. Option to 'Forget this network' is also available again.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,406
5,537
113
Utah
#9
Go to Settings, turn on Airplane Mode. Turn off the Power button. Leave for a minute and turn on the Power button. Then turn off Airplane Mode and your previous Wifi setting should be restored. Option to 'Forget this network' is also available again.
That post is more than six years old.