Found why some SB Themes Don't Show Up

bkushner

Member
Bronze
Jan 22, 2008
70
0
6
#1
Well I found the problem with installing themes that don't show up in Summerboard.

However, I'm no hacker or programmar and can't fix this other then to tell what's happening. Maybe someone else can
step up:

The new version of Summerboard with the 1.14 is putting the themes here:

/var/mobile/Library/SummerBoard/Themes


The installer is installing many of the old themes into:

/var/root/Library/SummerBoard/Themes


If you install an old theme, go into /var/mobile/Library/SummerBoard/Themes and move it to /var/root/Library/SummerBoard/Themes
you will have this. Hopefully someone will fix this.

Brian
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#2
I could put a fix on my Installer Source. It would just put a symlink to point to the correct location whenever installer tries to install to the old location.
 

seb481

New Member
Silver
Aug 3, 2007
774
1
0
San Diego
#3
I could put a fix on my Installer Source. It would just put a symlink to point to the correct location whenever installer tries to install to the old location.
Isn't it what BossTool does?
 

lman

New Member
Silver
Oct 18, 2007
632
0
0
#5
I could put a fix on my Installer Source. It would just put a symlink to point to the correct location whenever installer tries to install to the old location.
I was going to PM you to ask you if you could do this. This would really help me out seeing as i don't have a way to use a file manager right now. So if its not a problem i'd greatly appreciate it. Thanks! :laugh2:

I dunno if you could PM when you've done this? I want to get started with my themes as soon as possible.
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#6
I was going to PM you to ask you if you could do this. This would really help me out seeing as i don't have a way to use a file manager right now. So if its not a problem i'd greatly appreciate it. Thanks! :laugh2:

I dunno if you could PM when you've done this? I want to get started with my themes as soon as possible.
I'll put it up in a bit, I'm still helping out JJSquizz sort some things out. I just like totally remote administered his iPhone from Installer! w00t!

Anyway, yeah I'll put this fix up and make a post about it. This one is going to take me a bit of time thought, because I need to bug test moving the existing themes in the root folder to the themes folder in mobile.
 

lman

New Member
Silver
Oct 18, 2007
632
0
0
#7
Yeah i totally understand. I appreciate all you do...trust me haha. I'll be looking for that thread and if i can do some theme modding tonight great, but if not its not the end of the world.
 

bkushner

Member
Bronze
Jan 22, 2008
70
0
6
#8
Someone told me about this and it works.

Install Smb Themes Fix under Tweaks 1.1.3
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#9
Someone told me about this and it works.

Install Smb Themes Fix under Tweaks 1.1.3
Even better, less work for me!

The reason the some themes install to the old directory is because they're hard coded to install there.

The correct way to code the install is to use a ~ to represent the current user, so ~/Library/SummerBoard/Themes/

:p
 

lman

New Member
Silver
Oct 18, 2007
632
0
0
#10
works great, thanks both of you.