Free apps aren't working?

Aug 17, 2008
6
0
0
#1
I installed a couple of free apps on my 3g like wikipanion and hanoi but they don't work. It complete installs onto my phone but when I touch to load, it just closes back to the home screen. Any suggestions?
 

dturner

Zealot
Gold
Dec 15, 2007
5,725
12
38
Louisville, Ky.
#2
This seems to be a problem with the 3G especially. Do all downloading from your computer and not the phone.
As for your current ones, delete them from the phone and computer(if you have done a sync) and download them again from the computer and sync to the phone. They should now work.
Hopefully 2.1 will fix this issue that seems to be widespread in the 3G phone.
 

PapaST

Member
Bronze
Sep 10, 2007
458
6
18
#3
If I understand you correctly, you have it loaded but when you tap the icon to play it "sort of" comes up and then goes back to homescreen? I just turned my phone off then back on. Worked fine after that. I have about 5 pages of apps right now... some free some not. I find when I first load an app and it does that I just power cycle.
 
Aug 17, 2008
6
0
0
#4
thank you all so much for the help I'll let you know if it works
 
Sep 6, 2008
16
0
0
#5
This seems to be a problem with the 3G especially. Do all downloading from your computer and not the phone.
As for your current ones, delete them from the phone and computer(if you have done a sync) and download them again from the computer and sync to the phone. They should now work.
Hopefully 2.1 will fix this issue that seems to be widespread in the 3G phone.

I had the same problem and used this technique and now all of my apps are running fine again. Hope it works for you too!