Getting rid of "Flagged Mail"

iPutz

Zealot
Silver
Nov 20, 2012
962
184
43
72
US Midwest
#1
I am running the latest version of iOS7 on an iPhone 5 and am having a problem with the mail app. In the Mailboxes screen I have my e-mail in boxes and one item called "Flagged Mail" that I occasionally use to hold Mail I want to be sure to act on when I get to my PC. I deleted the one e-mail that I had in that mailbox but it still shows that I have 2 flagged e-mails. I usually keep all mailboxes clear including the trash as I keep all e-mails on my ISP's server until I download them onto my PC. I have deleted all e-mails on the phone and still cannot get rid of the "2" to the right of the Flagged Mail. Any ideas?
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,843
997
113
65
Florence, AL
#2
I am running the latest version of iOS7 on an iPhone 5 and am having a problem with the mail app. In the Mailboxes screen I have my e-mail in boxes and one item called "Flagged Mail" that I occasionally use to hold Mail I want to be sure to act on when I get to my PC. I deleted the one e-mail that I had in that mailbox but it still shows that I have 2 flagged e-mails. I usually keep all mailboxes clear including the trash as I keep all e-mails on my ISP's server until I download them onto my PC. I have deleted all e-mails on the phone and still cannot get rid of the "2" to the right of the Flagged Mail. Any ideas?
I Flagged an email, and it did the same way. So I deleted "Flagged" then added it back. Then the one email no longer showed.


Sent on iPhone 5 using iCafe app
 

iPutz

Zealot
Silver
Nov 20, 2012
962
184
43
72
US Midwest
#3
I tried that and restarted the phone before putting it back and the "2" was still there. Even tried a Hard Reset to no avail. It's not really an issue only an annoyance that has no real impact on my use of the phone, still irritating though. I did manage to get rid of it a couple months back, when I had the same issue but that involved deleting the e-mail address info from the phone, and doing the above before putting the address info back into the phone. That is not a solution I care to do every time this crops up. Maybe I'll submit it to Apple's feedback site and hope for the best. Thanks anyway, I appreciate the help.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,843
997
113
65
Florence, AL
#4
I tried that and restarted the phone before putting it back and the "2" was still there. Even tried a Hard Reset to no avail. It's not really an issue only an annoyance that has no real impact on my use of the phone, still irritating though. I did manage to get rid of it a couple months back, when I had the same issue but that involved deleting the e-mail address info from the phone, and doing the above before putting the address info back into the phone. That is not a solution I care to do every time this crops up. Maybe I'll submit it to Apple's feedback site and hope for the best. Thanks anyway, I appreciate the help.
Did you delete "Flagged", or just the email?


Sent on iPhone 5 using iCafe app
 

iPutz

Zealot
Silver
Nov 20, 2012
962
184
43
72
US Midwest
#5
Deleted the e-mail then the flagged mailbox then deleted the e-mail account that received the e-mail. Deleting the account info from the phone, restarting the phone and putting the account info back into Settings/Mail/Contacts/Calendars/Add Account is what finally straightened it out until now.
 
Last edited:

iPutz

Zealot
Silver
Nov 20, 2012
962
184
43
72
US Midwest
#6
I just found a much easier way to rid the "Flagged Mailbox" of its incorrect listing of the number of flagged e-mails. If the account that the flagged mails were received on is deactivated then re-activated the flagged e-mail number is corrected. I don't know if this will work when multiple accounts are involved but the method worked for my one account.

Ignore the above, the darn things just showed up again. No e-mails just the indication that there are 2 flagged e-mails.
 
Last edited: