Gevey 3G unlock on 2.1

Jul 15, 2008
16
0
0
#1
When i bought my older iPhone 2G Last year it came jailbroken with a gevey unlock sim on firmware 1.1.2. i never upgraded the firmware and i never used software unlock until i sold it a few months back. Now i bought the iPhone 3G 16gb white from my carrier. But im going to middle east in 2 weeks and i need my phone to work with the sim cards over there. So i ordered a 3g gevey sim unlock kit. I have tried to test it on my own career but i get no service. i heard that some jailbreaking software gives you the option to select "not an approved carrier" in jailbreaking process. i used quickpwn to jailbreak and i got no such option or prompt. my 2.1 iPhone is jailbroken but not unlocked. is this gonna work? did i do something wrong? my friend says his gevey 3g works.
 
Nov 14, 2008
6,844
414
83
27
Cairo, Egypt.
#2
My Gevey-3G works too. Make sure you attached the sim card to it in a correct way, and also make sure your sim card is new (a 3G one). I had the exact same problem with my old sim card, I have had it since 1998, it worked on all Nokia mobiles until a couple of weeks ago when I tried it on Gevey-3G and my iPhone 3G, and it didn't work. I figured (on my own) that I have to replace the sim card with a new 3G one, and now it's working just fine. So go get a sim card replacement, get the newest sim card possible (a 3G one preferably). Trust me on this, I guarantee you 100% that it will work.