GMail Downloading Hundreds of Archived Mail

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Aug 16, 2007
24
0
0
#1
This is so annoying. I know its been asked a lot but no one can give an answer in one post. I have set up Gmail on my iPhone but it receives mail that is already archived. Ive already disabled the recent option on the iPhone and enabled pop starting only from today. I also disabled pop and re-enabled it too. Nothing has worked, im overloading on email ive seen from months ago that i have already archives. What is the deal?
 

iBrad

New Member
Bronze
Jul 1, 2007
38
0
0
#2
hmm

i have Gmail as well... just let it load up all your email... (I have 6254 emails in my inbox.) And just click on every email recived on your first page of emails ON your iPhone. And just don't delete them. Just make the whole first page "read" it takes a little while. that way you wont see like 40 emails on your front screen.
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#3
I downloaded all of mine and deleted the old ones by hand... and also for my yahoo businesss mail account which had even more mail...

Long story short, it's done, i've only got current emails now, and my inbox doesn't read it's got 2k+ emails unread anymore. OCD here i come!
 

ps49556n

New Member
Silver
Jun 21, 2007
545
1
0
NYC
#4
This is so annoying. I know its been asked a lot but no one can give an answer in one post. I have set up Gmail on my iPhone but it receives mail that is already archived. Ive already disabled the recent option on the iPhone and enabled pop starting only from today. I also disabled pop and re-enabled it too. Nothing has worked, im overloading on email ive seen from months ago that i have already archives. What is the deal?


Go into advanced mail settings====>Turn off Use Recent Mode.


That will solve your problem
 

cman6453

New Member
Bronze
Jun 30, 2007
57
0
0
#7
Make sure under your gmail settings in your web browser under "Forwarding and POP" and select "Enable POP only for mail that arrives from now on".


Also make sure Use Recent Mode is turned off under iPhone settings.



Yup, that's the ticket. Basically turn off POP in your gmail account, save changes and then turn it back on. That will reset pop to download all emails from that moment on AND remember to turn off Use Recent Mode.