Gmail keeps loading old emails

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

TheDon

New Member
Jun 30, 2007
24
0
0
Socal
#1
I set it up on gmail to only send recent emails via pop but on my iPhone i keep getting old emails before the specified date. any help?
 

thinkart

New Member
Bronze
Jun 16, 2007
212
0
0
Mid-MO
#2
ME TOO! i wish there was a fix, but no one has come up with one that actually works for me. i assume this problem is occuring across the board for gmail users. at least, ive read over 20 posts (here and other sites) with the same complaint. im sure google (or Apple) will release an update to fix this.
i hate to say it, but never had this problem on BB. it only downloaded new unread emails. the iPhone downloads every email ive ever had always keeping my inbox FULL. its annoying, but at least all new emails still make it to me.
 

uptick

New Member
Jul 2, 2007
9
0
0
NY
#3
In my experience, by default, the mail feature will keep pulling down the 50 most recent messages from your gmail account inbox, whether those are new or old messages. So if you keep deleting messages off from iPhone, it will retrieve OLDER messages just to present you 50 constant messages on the iPhone.
Go to iPhone Settings -> Mail to change the number of messages to be shown.
Otherwise clean out your gmail inbox directly.
 

rcossy1023

New Member
Jul 1, 2007
22
0
0
#4
You can fix this by archiving your gmail inbox...You can archive the older messages in your inbox and keep the recent ones that you may need to access on your iPhone.

If you later need to access those messages you archived, goto your gmail and click "All mail" and thats where the messages have been hiding!:cool: