Gmail sends sent mail back to inbox

Jonny Pez

New Member
Jul 8, 2007
4
0
0
#1
for some reason a copy of every email i send from my iPhone is sent to me. I checked my iPhone settings and the "send CC to yourself" is turned off.

Does anyone know how I could fix this problem? I thought it may be a setting within my Gmail account, but i don't seem to have this issue when sending mail from my desktop or notebook computers.
 

tharmsen

New Member
Silver
Jul 5, 2007
873
0
0
#2
for some reason a copy of every email i send from my iPhone is sent to me. I checked my iPhone settings and the "send CC to yourself" is turned off.

Does anyone know how I could fix this problem? I thought it may be a setting within my Gmail account, but i don't seem to have this issue when sending mail from my desktop or notebook computers.
Mine does it too.
 

yoadrian

New Member
Jul 10, 2007
2
0
0
#5
Same issue w/ my Gmail. "CC" is turned off. Have added/deleted then added my Gmail account as timschizzle suggested- to no avail.

Any other ideas?
 

kwan

Member
Bronze
Jul 7, 2007
88
0
6
#6
Here's how I did it.
Go to the settings option on your "web" gmail page, then create filter. Create a filter to delete from: "type gmail user name"
what this does is when you send an email from gmail, it deletes the message that would normally go to your inbox in order to create a "conversation".
Unfortunately this disables the conversation style of organizing your email.
I believe it also doesn't save sent messages.
Its a good compromise for me. At least I don't get a new message from gmail 15 minutes after I send one.
 

timschizzle

New Member
Bronze
May 22, 2007
103
0
0
#7
do you still have it set to sync with your computer? i had to turn that off in iTunes for mine to work, because if it syncs, it overrides the set up that you did
 

kwan

Member
Bronze
Jul 7, 2007
88
0
6
#8
didn't even think of syncing gmail via iTunes. That would be a very rudimentary way of syncing email.
I'm thinking of migrating towards yahoo mail, since I have it pushed. And when I delete or read on the iPhone, it updates itself on the web as well.
I don't have to go back and do a clean up later, like I do with gmail.
 

Jonny Pez

New Member
Jul 8, 2007
4
0
0
#9
The Fix

Okay Guys, I figured it out!

All you need to do is turn off 'Recent Mode' within the mailbox settings on the iPhone.

I'm not sure what exactly 'Recent Mode' does, but definitely fixes this problem.
 

kwan

Member
Bronze
Jul 7, 2007
88
0
6
#10
The only thing that did was start downloading all my old emails.
What I'm doing now is:
1-Use Yahoo mail for push capabilities
2-forward all gmail email to yahoo email, and archive them at gmail automatically after forwarding. This way I don't have to go back and cleanup on my website gmail page.
3-Start emailing from my iPhone using yahoo. Completely removed gmail from iPhone.
 

Jonny Pez

New Member
Jul 8, 2007
4
0
0
#11
not bad

The only thing that did was start downloading all my old emails.
What I'm doing now is:
1-Use Yahoo mail for push capabilities
2-forward all gmail email to yahoo email, and archive them at gmail automatically after forwarding. This way I don't have to go back and cleanup on my website gmail page.
3-Start emailing from my iPhone using yahoo. Completely removed gmail from iPhone.
That's not a bad idea. That way you'll be able to combine the power of Push Mailing with mailboxes that don't have that capability!
 

brinky

New Member
Bronze
Jul 24, 2007
95
0
0
48
Atlanta, Ga
#12
didn't even think of syncing gmail via iTunes. That would be a very rudimentary way of syncing email.
I'm thinking of migrating towards yahoo mail, since I have it pushed. And when I delete or read on the iPhone, it updates itself on the web as well.
I don't have to go back and do a clean up later, like I do with gmail.
Good luck with that. Many folks, including myself have been having issue with yahoo actually pushing the email. It doesn't always work and email can get delayed several hours, even when you have it set to check every 15 mins.

Hope it works better for you then for me.
 

kwan

Member
Bronze
Jul 7, 2007
88
0
6
#13
I initially had some problems but since uninstalling all the email accounts and installing yahoo first, I no longer have any issues
 

brinky

New Member
Bronze
Jul 24, 2007
95
0
0
48
Atlanta, Ga
#14
I initially had some problems but since uninstalling all the email accounts and installing yahoo first, I no longer have any issues
Thanks, I will give that a shot and see what happens. Although I only setup Yahoo from the phone, iTunes syncs my Apple Mail accounts when I connect the phone. I will try turning that off and see.
 

iPhobos

New Member
Bronze
Jul 25, 2007
201
0
0
#16
anyone else try this?
I did this about five minutes ago and sent an email to test it and so far so good although I have been thinking about creating a new yahoo account since purchasing the phone. Being that my old yahoo account us complete spam it is probably about time to do so. That will make 3 gmail accounts and 2 yahoo accounts with a school and work email, yaouzers!
 

brinky

New Member
Bronze
Jul 24, 2007
95
0
0
48
Atlanta, Ga
#17
I initially had some problems but since uninstalling all the email accounts and installing yahoo first, I no longer have any issues

So far it seems to be working better. I only setup my Yahoo account and it seems to be pushing just fine. Another thing could have been to me being and idiot. I don't think push will work when using wi-fi since your phone has to be on edge in order for yahoo to notifiy the phone that there is a new message for it to download. My guess is that when on wi-fi it can find the phone to send a messge since EDGE is not how you are connected. Anyway that is just a theory but all seem well know.

Thanks!
 

dovebar27

New Member
Jul 28, 2007
12
0
0
#18
Just wanted to point out that this happens with Blackberrys too, at least...that whenever emails from my gmail addy were sent out with my Pearl, I would always get a copy of the email back.

And now that doesn't happen anymore because I have an iPhone. :p Point is, though--this isn't an iphone-only quirk, so this isn't really something to worry about.
 
Aug 13, 2007
4
0
0
#19
Prevent Sent Gmail Email Appearing in Your iPhone Mail Inbox

Prevent Sent Gmail Email Appearing in Your iPhone Mail Inbox To stop Gmail from pushing to your iPhone Mail Inbox a copy of each message you send from iPhone Mail:
  • Tap Settings on the iPhone's Home screen.
  • Go to Mail.
  • Now tap Accounts.
  • Choose your Gmail account.
  • Tap Advanced.
  • Make sure Off is selected under Use Recent Mode.
  • Tap Save.
The Price To Pay for Not Receiving Sent Mail

Note that the copy you get in your Inbox when you send from iPhone Mail is an unfortunate side effect of "recent" mode, which serves very useful a purpose.
Gmail's recent mode sends all connecting email programs or mobile devices the last 30 day's mail. With recent mode, you can access all your mail on all programs and devices (provided you check once every four weeks).
With recent mode turned off, you may not be able to access messages already downloaded to iPhone Mail if you connect to the same Gmail account with, say, your desktop email program.

*This worked for me, good luck*