Greenpois0n does't work for iphone 3g 4.2.1 ..?

Discussion in 'iPhone Jailbreak' started by fonzi, Feb 20, 2011.

  1. fonzi

    fonzi New Member

    I'm getting mixed info about jailbreaking an iphone 3g using greenpois0n rc6. Some say it works, but I keep getting the "Try Again" button after putting the iphone into DFU mode.

    Could somebody clarify this for me. thanks
  2. besweeet

    besweeet Member

    greenpois0n is very iffy (if you know what I mean). But that's Chronic-Dev Team for ya! It's best to just use PwnageTool to create your own pre-jailbroken IPSW that you can restore to with iTunes. If you aren't on Mac OS X, then use sn0wbreeze.
  3. Avatar

    Sponsored Advertisement

  4. Watcher

    Watcher Zealot

    Are you sure the phone is in DFU mode and not Recovery mode? DFU should give you the black screen but you should still be able to tell it's on. Also make sure when you connect your phone, iTunes doesn't come up. It shouldn't be active at all.
  5. fonzi

    fonzi New Member

    I tried to put the phone into DFU but I don't get the 'black' screen. the phone is completely off. I've tried holding both sleep and home button for 10 secs, and then releasing the sleep button.

    I'm stumped on how to set my phone into DFU mode.
    Also, to turn the phone on, I need to hold the sleep and home button for 10 secs.

    It's a 3g with iOS 4.2.1
  6. besweeet

    besweeet Member

    Sounds like you're already in DFU mode...
  7. fonzi

    fonzi New Member

    If im in DFU mode, why would the GreenPoison program have me click "try again" and repeat the process and not detect the phone is in DFU mode?
  8. besweeet

    besweeet Member

    greenpois0n isn't a reliable jailbreak tool... PwnageTool and sn0wbreeze are.
  9. offroadhunter

    offroadhunter Member

    I literally just finished j/b my 3G before I put it up for sale... I tried using GP but had no luck... there's some sort of issue where gp won't recognize the phone is in dfu mode.. I went to pwnage and it worked perfectly.. I'd also suggest giving pwnage a try.
  10. Watcher

    Watcher Zealot

    Hmmm... I guess it depends on a lot of factors... computer OS version as well as updates installed, etc. ... who knows. I just know it would always say "Try again" for me until I realized I wasn't really in DFU mode. Once I got it there, it went as smooth as butter.

Share This Page