HAD 3.0 went back to 2.2.1 and problem

Krystian_E46

New Member
Bronze
Dec 2, 2008
44
0
0
Chi-Town, IL
www.e46fanatics.com
#1
Hey guys i need help i had 2.2.1 with my tmobile sim, yesterday i played around and installed 3.0 everything was working fine except i can go without using my tmobile # so i went back to 2.2.1 and now my sim unlock doesn't work.

Any Ideas ?
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#2
2.2.1 cannot be software unlocked, you will have to use a hardware unlock like a turbosim. According to your sig, you had 2.2 which could be unlocked with yellowsnw.
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#4
It most likely won't work with the updates baseband, this is just a guess.
 

iphun

Zealot
Gold
Mar 16, 2009
1,967
0
36
PA
#6
is there anyway i can downgrade the baseband
No there is absolutely no known way to downgrade the baseband. There are ways to get 2.2.1 on a higher baseband, but those instructions are long and complicated.
 

iphun

Zealot
Gold
Mar 16, 2009
1,967
0
36
PA
#9
ok i even downgraded to 2.2 and still nothing
3.0 has a higher baseband, so NO os lower than 3.0 will work. Even every beta version gets a baseband upgrade to for example, once on beta 5 you cannot go back to beta 4, let alone any 2.x or 1.x . Sorry but unless you try to restore through iTunes, get some 13xx error, then use quickpwn to jailbreak the phone, you will not be able to fully restore through iTunes. After you get it restored to a jailbroken state you can then restore through iTunes to the stock version of 2.2.1. For some people that works and for some it's a bust, but I guess worth a try.