Headphone Problems (Music randomly starts/stops)

drumthrasher109

New Member
Bronze
Jan 9, 2009
471
0
0
drumsplace.co.cc
#1
This has been bugging me ever since I got my iPhone.

The second I plug in (non-Apple headphones) my headphones, the iPod opens and it plays the first song I have on my iPhone.

Most of the time it will randomly start pausing the music and begin to play it.

Also, when I'm watching videos, it will spontaneously pause the video.

ALSO, when I'm playing a game with my headphones plugged in, it will turn off the games music and start playing music from my iPod.

This is pissing me off. Nobody from Apple has been able to tell me what is happening.

I kind of think the headphone jack is made weird... I've tried several pairs of headphones and the same thing happens. If I use the white headset that comes with the phone, it works fine (go figure...).
 

drumthrasher109

New Member
Bronze
Jan 9, 2009
471
0
0
drumsplace.co.cc
#2
Well today I've done a few things. First, I updated to a newer version of sbsettings toggles. Next, I removed bossprefs.

SO FAR, my headphones are working perfect. I feel so happy right now :).
 

drumthrasher109

New Member
Bronze
Jan 9, 2009
471
0
0
drumsplace.co.cc
#3
Well, maybe not. I restored it back to factory crap and it still happens. Hopefully the AT&T will just hand me a new one.
 

iPhoneMonster

New Member
Bronze
Jan 18, 2009
461
0
0
#4
Well, maybe not. I restored it back to factory crap and it still happens. Hopefully the AT&T will just hand me a new one.
Don't go to AT&T, go to an Apple Store. I had to get my iPhone replaced and went to Optus (Australia's Network) to get a replacement they sent me to Apple. And my closest Apple store is 6 and a half plane journey away. So I called them up.
 

drumthrasher109

New Member
Bronze
Jan 9, 2009
471
0
0
drumsplace.co.cc
#5
Yeah. We called up Apple and they are supposed to be calling us back today so they can ship the box so I can send my iPhone to them. I hope it doesn't take forever for my new one to show up...
 

iPhoneMonster

New Member
Bronze
Jan 18, 2009
461
0
0
#6
It took about 2 weeks for mine to get shipped, so I told them it was not acceptable and they gave me a free $50 gift card.