HELP GCal is not syncing to iPhone Calendar

JayTrek

New Member
Aug 24, 2011
2
0
1
#1
My phone has stopped getting OTA updates to my GCal. Anyone else experienced this problem? What do I need to do to correct?
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#2
Just so I understand correctly, you are setup with the "Push" for Gmail settings through an Exchange setup?
Is your calendar the only thing that you get pushed to you, or do you get mail and contacts too? If so, are they working?
Generally, if you are using google's exchange setup for push services, and it stops working, its on Google's side.
Here is a way to test:
On your phone, go into Settings and then Mail, Contacts, and Calendars and turn off the account.
On your PC, log into your calendar and make a new event for tomorrow. Verify it's in there and log out.
Back on the phone, turn the service back on. Check to see if the new event shows. It should come up within a minute (you can look for the little rotating icon up next to your carrier symbol to see if it's even trying to pull down the data)
If it fails, then you have to look at what could be different. Changing a password on the PC will definitely affect it, since they share the same account login info. Also, if the server info has changed, that will also cause problems. You SHOULD get an error letting you know whats wrong, but sometimes that doesn't happen.

BTW, when I say PC, I mean online.
 

JayTrek

New Member
Aug 24, 2011
2
0
1
#3
Hawk, I have been digging and stumbled on the fact that if I change my work appointments to the regular calendar (in other words...the native calendar with my gmail account) they sync. However, other calendars...like one I created to keep work stuff separate from other things, another I created to keep up with my son's baseball schedule, and one my blog partner and I use to plan blog entries...do not.

So is there a way to get these additional calendars to sync?
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#4
Well, I use the Google Calendar Sync to sync Outlook to Google calendars. I have it setup to sync twice a day automatically (it can be setup to sync every minute if you wanted).
This might be a better option for you, although I am setup differently than you are. My calendar on my phone does not sync to anything but iTunes when I connect. iTunes updates my Outlook and the the Google calendar sync updates to my Google calendar. It syncs in both directions, so that if I make an update to my Google calendar away from home, it will get synced to Outlook and eventually on my phone.
Give it a shot. It's easy to install and configure.
 

James4455

New Member
Feb 20, 2009
10
0
1
West Texas
#6
I am trying to do this as well, I would like to change to Google for my Calendars and probably for contacts also. When I go to the link posted above I am only able to select one Google calendar. There are three calendars that are 'Not Available For Syncing' these are calendars such as US Holidays, Dallas Cowboys, etc. How do I get this information to go to my iPhone. Also, I have current information in my iPhone that I would like to have in Google Calendar.
 

Vcoronel127

Member
Bronze
Aug 30, 2011
119
8
18
#7
I am trying to do this as well, I would like to change to Google for my Calendars and probably for contacts also. When I go to the link posted above I am only able to select one Google calendar. There are three calendars that are 'Not Available For Syncing' these are calendars such as US Holidays, Dallas Cowboys, etc. How do I get this information to go to my iPhone. Also, I have current information in my iPhone that I would like to have in Google Calendar.

I'm sorry but I don't know how to sync those that aren't available for syncing. As far as the information you have in your iPhone, you have to set the iPhone default calendar to google calendar. You can do this by going into our settings>mail,contacts,calendar>set default calendar to google personal calendar.

This way all events you enter from now on in your iPhone will also reflect on your gcal.

Past events you have entered in your phone will not show up in your gcal because your default settings was on your iPhone calendar, not gcal. You need to individually change them in order to see them in google calendar. Hope it helps and good luck


U.S Army
Sent from my iPhone 4
 

James4455

New Member
Feb 20, 2009
10
0
1
West Texas
#8
[You can do this by going into our settings>mail,contacts,calendar>set default calendar to google personal calendar
Thanks, I've tried that and no joy. I suppose I will just forget about Google and stay with the iOS that at least is working. I would hate to loose some valuable data or brick a phone.