Help, I can't send MMS on my iPhone 4

Discussion in 'iPhone 4' started by Mthoroughbred, Aug 21, 2012.

  1. Mthoroughbred

    Mthoroughbred Contributor
    Silver

    Joined:
    Dec 16, 2008
    Likes Received:
    95
    Hope someone can help me I have had my iPhone 4 on AT&T since release and never had a problem like the one I am having now. This weekend I tried to send a couple of pics to someone and i realized that they didn't go through. All i kept getting was the (!) next to the picture. I sent a pic to my girlfriend same thing and she's on my plan (she has a Nokia Lumia 900). I went and restored the phone..... nothing. Did a network reset..... nothing. I also made sure that my mms was turned under settings>messages>mms on. It just stopped working over night. I'm hoping someone here can help. I'm on firmware 5.1.1.
     
  2. Bennyboy

    Bennyboy Genius
    Platinum

    Joined:
    Jul 21, 2010
    Likes Received:
    1,757
    I don't have a solution, I would suggest a restore as new if you are brave enough, but as far as 5.1.1 goes, it's the most disappointing firmware ever from Apple. I've been on it for a month and I hate it. And it's not the phone, I just had a replacement yesterday and even before I restored from backup it was giving me all kinds of problems.

    Try a hard reset, restore your network settings with mms turned off then turn it back on again. Good luck.

    ps: all my problems are network related, 3G and wifi.
     
  3. psylichon

    psylichon Genius
    Moderator

    Joined:
    Oct 31, 2007
    Likes Received:
    751
    I'd check in with AT&T before you go through the hassle of restoring as new. Could be something on their end.
     
  4. Mthoroughbred

    Mthoroughbred Contributor
    Silver

    Joined:
    Dec 16, 2008
    Likes Received:
    95
    Thx guys for trying to help. I'm gonna take the sim card out and place in my friend's phone and see what happens. If it does it on my friend's phone then it's something wrong with the network if it doesn't then I guess it's my phone. If all else fail I'll call AT&T see what they can do.
     
  5. Mthoroughbred

    Mthoroughbred Contributor
    Silver

    Joined:
    Dec 16, 2008
    Likes Received:
    95
    I placed my girlfriend's sim card in my phone and I could send pictures through MMS with no problems. Then i inserted my sim card in her phone and no luck couldn't send pictures calling AT&T today. I just find it weird that we are both on the same plan and this is happening to just me.
     
  6. psylichon

    psylichon Genius
    Moderator

    Joined:
    Oct 31, 2007
    Likes Received:
    751
    You should have seen how bad it was when MMS first came to the iPhone. Real touch and go. It's not surprising that AT&T still doesn't have its act together on MMS with the iPhone.
     
  7. Mthoroughbred

    Mthoroughbred Contributor
    Silver

    Joined:
    Dec 16, 2008
    Likes Received:
    95
    I've had every iPhone except the 4s and I never had a problem like this before
     
  8. Mthoroughbred

    Mthoroughbred Contributor
    Silver

    Joined:
    Dec 16, 2008
    Likes Received:
    95
    Problem solved! Called AT&T and the system for some weird reason had turned on media content control which was blocking my MMS. Glad that was fixed. Not to give them a plug but they were very helpful.
     
  9. Xtreme LED

    Xtreme LED New Member

    Joined:
    Aug 15, 2011
    Likes Received:
    1
    ATT is always helpful. Its the service itself that blows
     

Share This Page