help iPhone gets stuck loading..

Nov 24, 2007
319
0
0
#1
I am having this same problem over & over. PLEASE HELP !

"i install a app and it just stays cloaking after i exit from installer, stays loading (aka cloaking) for 5 mins..so i turn it off/on it stays in the Apple screen still loading.. this has happen twice" 4 times now! i got it working yesterday by deleting this
"To fix it, you need SSH running and then must browse to:

/usr/bin/

and delete the screenshot folder there, (/usr/bin/screenshot)

After that, restart your phone and you should be back to normal."

this is really pissing me off, i'm just about done installing what i want & this BS every effin time.... was all happy thought the whole problem was because of screenshots... i guess it still could be but i think i deleted what i suppose too, right? please help !
i deleted the screenshot folder & screenshots and it worked. i installed "Labyrinth" then i install another app "level" and it doesn't work again(stuck loading) deleted the app both apps still don't work.. i don't think it's a problem with thoses apps.. like i said i deleted screenshot folder and it worked again,, i dunno :(:(:(

To stop the loading & loading & loading, SSH in & delete the app u installed (TO FIX LOADING PROBLEM),then once u can use installer again uninstall it... but still i can't install any apps at all, has anyone else had this problem?
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#2
Hiya Mr.Fingerz,

I have a question to ask, are you familiar with using MobileFinder or an FTP client like WinSCP or CyberDuck?

The reason I ask is because you should check what the permissions are on your /var/Applicaitons are, as well as who the owner is.

If it says Owner: root, then thats your problem, because it should be owned by mobile. Another issue may be the permissions, they may be 644 when they should be 755.

I'm going to assume there are two possibilities here.

1) Your applications folder is now owned by a different user, or has had its permisisons changed.

2) Installer lost access to /var/mobile/Library/ or /var/root/Library/

Those are the two spots apps tend to hit when installed. The .app file goes into the Applications directory, and Installer logs the app in it's LocalPackages.plist. When the App installed runs the first time, it tries to set a preference file in /var/mobile/Library/Preferences, or /var/root/Library/Preferences


----

If you've got nothing to lose, you may want to try this (taken from this site):

General Fix - It’s a Must
Please apply this fix first. In general, applications tend to save their data into two folders:

/var/root/Library
/var/root/Library/Preferences
To reduce the possible issues, please make these two folders world-writable:

chmod 777 /var/root/Library
chmod 777 /var/root/Library/Preferences
If the above folders do not exist, create them.

UPDATE: Sometimes your mobile folder may have wrong permissions, to be sure your mobile account has no such problems, do this:

chown -R mobile:mobile /var/mobile
This will save you from those weird problems (e.g. ‘MobileSafari doesn’t save cookies‘).
 
Nov 24, 2007
319
0
0
#3
Yes, I've used WinSCP & know how to change permissions, but i have no idea about the owner or how to change it.. my the permission is 0775 on /var/Applicaitons folder.. Should i change it to 0755? How do i find out who the owner is ?

THANKS FOR YOUR HELP
 
Nov 24, 2007
319
0
0
#5
Ok i found the owner, can't be leave i missed that.."To find the owner in WinSCP, just right click the file and goto properties, its right above permissions" anyways the owner of /var/Applicaitons is "root" but i can't find out how to change it.. i've been getting help from X999X in private msgs.. i thought i go back to the post incase anyone else is has the same problem... ok i found "open terminal" & were to type commands, but im kinda confused to what commands to use...
x999x said: chown -R mobile /var/mobile/Library
but shouldn't i be using a command like this : chown -R mobile /var/Applicaitons

i'm not saying x999x is giving me the wrong info , i'm just kinda lost because i thought i needed to change the owner of /var/Applicaitons not var/mobile/Library or do i change both? could someone explain this to me... please & thx you