Help! jailbroken 4s won't launch Safari!

Discussion in 'iPhone Jailbreak' started by Serianni, Jan 21, 2012.

  1. Serianni

    Serianni New Member

    Joined:
    Jan 21, 2012
    Likes Received:
    0
    OK, so I jailbroke my iPhone 4s and was installing some tweaks. I installed adblock and Safari would not launch anymore. Basically what it would do is I would click on the Safari and it would go to open up and launch and then it would quit and be at the home screen. I uninstalled any and all Safari tweaks that I installed through Cydia and it still will not open! I force quit Safari, no dice. I rebooted it several times and no dice. I tried even reseting all the network connections via Settings>General>Reset>Reset Network Settings, and it is STILL not wanting to launch. Every other app including Cydia is working fine, even my Skyfire browser is fine. So wth is going on?!?! I just tried rebooting it into Safe Mode and Safari works ok in Safe Mode... Idk what would be the culprit
     
  2. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    4,460
    Moved to iPhone Jailbreak.
     
  3. RPMSTL

    RPMSTL Member
    Bronze

    Joined:
    Jun 22, 2009
    Likes Received:
    3
    It is one of the tweaks or cydia apps installed.

    I had the same issue after installing Safari Download Manager - uninstalled it and all good.

    Start uninstalling one thing at a time and you will find the issue.
     
  4. ricks2gtouch

    ricks2gtouch Zealot
    Silver

    Joined:
    Feb 20, 2009
    Likes Received:
    161
    Had the same problem. Uninstalled Safari Download Manager and everything is fine now. As far as I can tell anyway!
     

Share This Page