Help me revirginize

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#1
So as some of you know, my V1 died on me this last October. I watched as the signal slowly disappeared and then none of my communications worked. When i tried to restore, I get error 1101 (or 1011...I'm dyslexic)
Well i find out that I am not the only one with this problem. In fact as far as problems go, this one is kind of common- or at least becoming common. I found post after post and thread after thread about people that have this exact problem- all communications stopped and there is no IMEI number. The bad news is that the "fixes" are not the same for everyone, and I am still researching it. It seems that you can get the comm board replaced as a last resort, but I have a feeling that I will get this restored without having to go down that road.

So the reason for my post is that I need to revirginize the phone to try and fix the baseband. Since the phone has no communications past the USB cable, does anyone know how to do this on a Windows XP system?
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#2
Well it seems that no one knows how to do this. I have been working on this all day today, and I have a little bit of light at the end of the tunnel, but I'm not there yet.

I found this post by Letusgo2Hell on Hackintosh, dated 10/25/07
Before starting:
Be sure you have the same problem as I had. I had "IMEI unknown" and Not "IMEI 0049...."
I had a new iPhone with 1.1.1 crashed after first try to activate with touchfree


Result

My iPhone was bricked, but it's working again. In some other Threads are some info's how you can unlock
your iPhone also with the terminal.
If you want to unlock it also, be sure to copy the needed Apps before
updating to FW 1.1.1. BC iBrickr is not working with this FW.


My iPhone

- Bricked 1.1.1


Sympthom's

- IMEI: Unknown
- ICCID: Unknown
- Repair needed
- No Audio
- No WiFi


What I have done, to get this status

- Jailbreak
- touchfree breakdown while using
- use touchfree alpha and also breakdown


Possible Rootcause

- Mobile-Firmware corrupt


What did I use to fix it
All needed things here (w/o FW 1.0.2 -> get with iTunes):

- Pacay
- APPTappInstaller.exe
- iBrickr_0.91
- BSD Subsystem (with iBrickr)
- UIctl (with iBrickr)
- Mobile Terminal VT100 (with iBrickr)
- ieraser
- bbupdater
- secpack
- ICE03.14.08_G.eep
- ICE03.14.08.fls



What I have done to fix this status

0) If your iPhone does not have FW 1.0.2 -> flash it to FW 1.0.2 (Yellow triangle on your iPhone)

0.1) Remove your SIM!

0.2) Only if your Phone is locked use PACAY to activate it

0.3) If you have FW 1.0.2 and Yellow triangle on your iPhone goto Step 1.)

0.4) If you have 1.0.2 but not yellow triangel (launch iTunes 7.5 first, then connect your iPhone) press ON/OFF-Button and Home Button. After 10 sec.
release ON/OFF-Button. After 15 sec. release Home-Button. Connect to iTunes. Click away all massages.
Your iphone-Disply should be black. If your Display is not Black goto 0.4) again

0.5) Close iTunes and all itunes-processes

1.) Run AppTappInstaller.exe
1.1) Running will be failed first time. close AppTappInstaller
1.2) Connect to iTunes. If Error-Message apperars close iTunes and all processes again.
1.3) Run AppTappInstaller again. If success goto 2.) else to 1.)

2.) Start "(CLICK HERE) activate.bat" (from downloaded PACAY folder)
2.1) Follow all instructions and also the reboot
2.2) Now you have an activated 1.0.2 iPhone goto 3.). if not start with 0.) again

3.) Start iBrickr and select Applications and follow ALL the instructions to install Apps
3.1) Install the following Apps: BSD Subsystem, UIctl, Mobile Terminal VT100
3.2) Be sure the Apps are installs. After that you should see the Terminal- and UIctl-Icon
3.3) Install with iBrickr-Files-Upload-Fuction the following files in "/usr/bin/"
ieraser, bbupdater, secpack, eep-file and fls-file -> goto 4.)

4.) Tap the Terminal-App on the iPhone and input the following commands
cd /usr/bin
chmod +x *.*

4.1) Press home-Button and start Uctl (Do only the steps here descriped!)
4.2) Tap on com.apple.CommCenter -> tap "unload -w"
4.3) Tap on com.apple.mobile.lockdown -> tap on "stop"
4.4) Press Home-button and start Terminal again
4.5) Type following commands
cd /usr/bin
./ieraser (-> iPhone does something, read the results)
cd /usr/bin
./bbupdater -f *.fls -e *.eep -> firmware is flashed
4.6) If you want to unlocking with apps and Terminal, do it know. Info's in other Threads!

5.) If everything was quitted with O.K. (Read the results!) press ON/OFF-Button and Home-Button.
After 10 sec. release ON/OFF-Button. After 15sec release Home-Button
5.1) Connect to iTunes. Hold Shift-Key down and press on restore -> flash FW 1.1.1 to your iPhone

Finished! :

Things not included in this is that you have to uninstall all that is Apple (not Safari or Quicktime) and install iTunes 7.5 First, before anything else.
Then you downgrade to 1.0.2, use iBrickr to kick it back out and then follow the instructions.

I have not completed this yet. Please don't think that this works until I report back on how it went.
If all goes well, I should be posting that my phone is fixed. If not, well, doesn't mean it wont work for you.
I can say that right now, I have gotten downgraded to 1.0.2, and it cannot activate because there is no IMEI or ICCID listed. I will complete the rest hopefully tomorrow.
 
Last edited by a moderator:

Picazzo

Zealot
Gold
Jan 21, 2008
2,808
15
38
Copenhagen, Denmark
#3
Hi Hawk!

You're saying that your iPhone has no communication except the USB...is that correct? When you are virginize the iPhone to 1.0.2 and the baseband I'll guess you need the WiFi connection to get stuff from Installer!?

Maybe this file/guide will help you out: Guide to virginize
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#4
Thanks man, but with only USB connection, that method will not work for me. The method I posted above is very similar, but uses iBrickr to install some of the key components needed to pull this off.
I have unknown IMEI and ICCID, and no edge, Wifi, or BT. It's like the card has shut down. Since I am not the only person that has had this problem, I might be able to fix it. I might not, as it could be a hardware error and I watched the cell signal disappear to nothing, and then I tried to do a hard reset, which is where the FUBAR came into play. I am one step above FUBAR, with SNAFU, and the rest of the time it's been strictly BOHICA everytime I tried to restore.
 

Ipuddtang

New Member
Jan 8, 2009
6
0
0
#6
^ That was corny as the crap I took this morning.