HELP! Original iPhone icons are gone!

nxb807

New Member
Sep 30, 2009
12
0
0
#1
HELP! I have a jailbroken/unlocked iPhone 3G, and I have a serious problem. I downloaded the NES app from Cydia yesterday. The app wasn't working, so I went into Cydia to remove the app, and now ALL of my original iPhone apps/icons are gone - Phone, Calendar, Safari, Settings, iPod, App Store, Contacts, Weather, Camera, You Tube, Photos...EVERYTHING! I tried syncing the phone again, hoping this would work, but the original features did not come back. When you call my phone it still rings, and when you perform searches in Spotlight, all the emails, address contacts still come up...but the applications itself are not found.

Someone else told me that the icons may be hidden and advised that I install SBSettings via Cydia. Trouble is, the Cydia and Icy apps are also gone.


Can anyone tell me how to fix this? I'm panicking over here.
 

nxb807

New Member
Sep 30, 2009
12
0
0
#2
i'm reading other forums about missing icons. some suggest to download a program called iPhonebrowser. others talk about getting apt-search. i can keep up with some technical stuff, but this mess is going way over my head. does any of this stuff make sense to anyone?

i'm trying to avoid restoring my settings and am hoping there are indeed other solutions.
 

nxb807

New Member
Sep 30, 2009
12
0
0
#3
your idea certainly seems to be the easiest way to resolve this matter. would you have any idea why this happened in the first place? do you think there's a possibility that the phone is permanently damaged?
 

nxb807

New Member
Sep 30, 2009
12
0
0
#4
the settings icon is gone too. ALL of the original icons (text, camera, photos, calendar, calculator, safari, phone, email, iPod, app store, you tube, stocks, weather), and the jailbreak apps for 3.0 (cydia & icy)...do not appear.
 

nxb807

New Member
Sep 30, 2009
12
0
0
#5
when i type any of those icon names in spotlight, they are not found.
 

nxb807

New Member
Sep 30, 2009
12
0
0
#6
you mean to actually turn off the phone and restart? if so, that was the very first thing i did. right after i uninstalled that damn NES app, i noticed that all my original apps were "whited" out; they showed up but with no icon image. i powered off the phone, and when it turned back on, all the "whited" out apps were gone.

i then plugged up my phone to sync with iTunes. it went through all the motions, but none of the icons came back.

i then restarted the phone again....still nothing. that's when i hit panic mode and started searching in forums to get some answers.

and now...here we are...still in panic mode...totally freaking out and trying not to worry.
 

nxb807

New Member
Sep 30, 2009
12
0
0
#8
this is where i read the alternative solutions this: http://thebigboss.org/2008/10/30/tip-missing-or-hidden-icons/

it says:
If you cannot install anything because Cydia is hidden, you can use apt-get install quickgold from the SSH prompt. In the most drastic case where you also do not have SSH, you can use iPhone browser and delete the file located at /var/mobile/Library/Preferences/com.apple.SpringBoard.plist. Then reboot.

i don't know what any of this means or how to get "apt-get". does this make sense to you?
 

nxb807

New Member
Sep 30, 2009
12
0
0
#9
i sincerely appreciate your prompt replies. i'll be sure to post the solution...once i figure out what that is
 

nxb807

New Member
Sep 30, 2009
12
0
0
#10
still searching for answers, so if anyone else can help, please let me know how i can fix this.
 

dturner

Zealot
Gold
Dec 15, 2007
5,725
12
38
Louisville, Ky.
#11
I think doing the restore is going to be your easiest solution. My guess is that some app you obtained from the jailbreak may have caused this, but who knows. JB'ing can sometimes cause weird things to happen.
 

nxb807

New Member
Sep 30, 2009
12
0
0
#12
can anyone answer this for me? i found some info on another forum that advised me to download a program called iPhonebrower, delete the file located at /var/mobile/Library/Preferences/com.apple.SpringBoard.plist, then reboot. I've this a number of times now but my home icons are still missing. And after i reboot the phone, i receive a message telling how to rearrange the icons, etc…but they are nowhere to be found.

i’ve tried this step 3 times now, and every time i reconnect the phone to iPhonebrowser, the “.com.apple.springboard.plist” is still there. is this why it’s not working? why is it still there, and why won't it go away? what else should i do?