Help regarding repair needed message

nanooreg

New Member
Sep 26, 2007
24
0
0
#1
Hello. i was hoping to maybe get some help on this. i was trying to upgrade my friends iPhone from 1.1.1 to 1.1.2. i did mine flawlessly. when i did his however, i must have messed it up somehow. i got an error message (i don't remember which one). i tried restoring to 1.1.1 (didn't work), i then tried to restore to 1.0.2 (unsuccessfuly) and then i received the error 1011 message. then on my friends (mine now i guess) iPhone, a message appeared saying (repair needed. unable to make or receive calls. and then also something about Apple support). does anybody have a solution for this so i can get his iPhone back in order?

thanks!
 

GolfNut

New Member
Bronze
Oct 15, 2007
83
0
0
#2
During the JB process, you'll get an error after you restore 1.1.1. It's normal. Some Tutorials say to restore it twice and proceed anyway.

If you want to simply get the phone working at this point, try putting the phone in restore mode and restoring 1.1.3. It worked for me and gave me a phone until I had more time to devote to Jailbreaking. I had to do this many times over the past week before finally getting the JB process to work.