Help with Cydia

Jul 23, 2008
27
0
0
Atlanta, Ga
#1
Okay, so, new to iPhone world. I bought a new 1st gen 8gig unlocked with 2.0.

I have the Cydia icon on my screen with a red 6 showing 6 new things or whatever. Then I pull it up and it says, "4 essential upgrades. One or more essential packages are currently out of date. If these upgrades are not performed you are likely to encounter errors." Should I upgrade or no?! Will this lock my phone? What are the updates for? Thanks in advance!
 

lman

New Member
Silver
Oct 18, 2007
632
0
0
#2
I'd wait for another opinion, but since these are updates through cydia they are probably for the the program to function properly. I had a jailbroken 1.1.4 and there were updates for installer periodically, so this seems similar to that. but lets see what someone else says
 

Evilzone

New Member
Jul 23, 2008
25
0
0
#5
I had that aswell, I upgraded and its fine.
 

iTrey.Bates

New Member
Bronze
Jul 9, 2008
106
0
0
Texas
#6
you are supposed to upgrade buddy...nothing bad will come of it...promise
 

VSpec

New Member
Dec 13, 2007
14
0
0
#7
I keep getting errors when trying to upgrade the essential items that Cydia brings up. After that I can't download anything else. Can anyone help? The error I'm getting is:

Source Error
failed in buffer_write(fd) (6, ret=-1)
 
Jul 15, 2008
17
0
0
#8
I keep getting errors when trying to upgrade the essential items that Cydia brings up. After that I can't download anything else. Can anyone help? The error I'm getting is:

Source Error
failed in buffer_write(fd) (6, ret=-1)
If you have many upgrades, you can try doing 1 at a time instead of UPGRADING ALL. This will make the process longer but you can also reboot after each install to make sure that everything reloads properly.
 

iPimp

New Member
Bronze
Nov 12, 2007
60
0
0
#9
i updated, nothing happens, first it updates only 4 then you open cydia and it updates 2

Same thing here,unlocked my 16gb 1st gen and did the exact same thing 4 then 2.


It's all good...:cool: