Help with iOS7

Discussion in 'iOS 7' started by Ross Taylor, Jul 26, 2013.

  1. Ross Taylor

    Ross Taylor New Member

    Joined:
    Jul 26, 2013
    Likes Received:
    1
    I got iOS7 on my iPhone 5 and it worked a treat! During this time i made backups to my iMac. Unfortunately, the other day it stopped working on my iPhone and told me it was not allowed and stopped. I had to restore it so it now runs ios6.14. I need ios7 back so i can get back my files from the backups but whenever i try to reinstall it, the way i did the first time ,it says " The Device is not eligible for the requested build" I don't know what to do and I really need those files and your help! Thanks
     
  2. EverythingApple

    EverythingApple Evangelist
    Gold

    Joined:
    Jul 28, 2010
    Likes Received:
    217
    How did you get iOS 7? What Beta version do you have? I think they're up to Beta 4. That might be your culprit. But, I'm not a developer, so I can't answer it completely. I'm just answering on what I've read.
     
  3. Ross Taylor

    Ross Taylor New Member

    Joined:
    Jul 26, 2013
    Likes Received:
    1
    i did have beta 3 and thats when it cut off. My friend gave me the ios7 file but i don't have a udid
     
  4. Ross Taylor

    Ross Taylor New Member

    Joined:
    Jul 26, 2013
    Likes Received:
    1
    Do you think its worth getting a UDID? Does anyone know where I can get one?
     
  5. chris

    chris Administrator
    Administrator

    Joined:
    Jun 10, 2006
    Likes Received:
    1,777
    This free app will recognize and email you the UDID of your iPhone.
     
  6. Ross Taylor

    Ross Taylor New Member

    Joined:
    Jul 26, 2013
    Likes Received:
    1
    I know what my UDID is, I was wondering if I should register it? would that help?
     
  7. acosmichippo

    acosmichippo Genius
    Platinum

    Joined:
    Sep 10, 2007
    Likes Received:
    1,089
    That would do it, but unfortunately the UDID registering process has been down since Apple's developer site was breached. They are working on bringing parts of the site back up one at a time. No telling when the UDID registering will be back up.

    So your only option to get your phone working right now is to restore back to 6.1.4. When the dev portal is back fully, then you can have a dev register your UDID and reinstall iOS7.
     
    #7 acosmichippo, Jul 26, 2013
    Last edited: Jul 26, 2013
  8. Ross Taylor

    Ross Taylor New Member

    Joined:
    Jul 26, 2013
    Likes Received:
    1
    Should I buy it through Apple or do you know a trustworthy place where you can register your UIDI for less. Thanks
     
  9. acosmichippo

    acosmichippo Genius
    Platinum

    Joined:
    Sep 10, 2007
    Likes Received:
    1,089
    hold on, I'll send a PM.
     
  10. Ross Taylor

    Ross Taylor New Member

    Joined:
    Jul 26, 2013
    Likes Received:
    1
    Thanks that would be great! I'll send you my UDID
     
  11. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,523
    The solution has already been posted by acosmichippo, but I just wanted to post the reason this happened. When iOS beta 1 first came out anyone could install it without having their UDID registered. They could also do OTA updates from there on. However, a full install of iOS 7 beta 3 from iTunes doesn't work without being registered, which is what you tried to do after downgrading to 6.1.4.
     
    • Informative Informative x 1
    • List
  12. IllusionEntity

    IllusionEntity Evangelist
    Gold

    Joined:
    Jun 3, 2010
    Likes Received:
    162
    I have been registered again yesterday as I got a replacement iPhone 5. I installed beta 3 through iTunes with no problem at all. I believe that the UDID registration part of the dev portal is back up. I bought a registration from ebay.
     
  13. Ross Taylor

    Ross Taylor New Member

    Joined:
    Jul 26, 2013
    Likes Received:
    1
    I should have a UDID now but it's still not working and I am trying to update to beta 1. I get the same message that the Device is not eligible for the requested build.
     
  14. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,523
    You'll have to get your UDID registered if you want to run 7.0.
     
  15. IllusionEntity

    IllusionEntity Evangelist
    Gold

    Joined:
    Jun 3, 2010
    Likes Received:
    162
    ... Beta 1 expired ages ago. You need to download beta 3..
     

Share This Page