Help with T-Mobile SIM card failure


New Member
Sep 11, 2007
I have a unlocked 8GB that i did following and everything that i have followed says that it is unlocked.
AT+CLCK="PN",2 and it says 0
Which means it's unlocked. But when i try my buddy's TMOBILE card it loads in gets a signal but the screen goes black, the dock still works, programs, calls, etc. But if i restart the iPhone it says i need to reconnect to iTunes and reactivate? what am i missing?


New Member
Oct 3, 2009
k im sorry, but im new on the site cant figure out how to post my own question. I am having a similar problem.... i recently moved to Santiago, Chile. I brought my unlocked iPhone down, threw in a "movistar" chip and have had no problems until the past couple weeks. EVERYTIME my phone shuts down, turns off, runs out of battery, and I end up having to "turn it back on" it goes through all these issues and wont accept the sim card. After a few days it has gotten back to working but why? Last night I updated my phone, ofcourse it reseted it, and rebooted, thereforee again saying "locked simcard" then I unlock it, and it says simfailure. WTF? Am I doing something wrong? Is there something I can do to fix this? Is it possible that the simcard it worn out and the phone is having trouble reading it? or is it just a problem with the phone? I know its fully unlocked, when I was in argentina I bought a pay by the minute chip and it worked fine.... This is the first time ive had a problem....

thank you so much for your responses.

sincerest gratitudes.