Home button flaky? Jailbroken? Check this out...

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#1
So like a lot of people, my home button can be rather unresponsive at times. I've all but ruled out a hardware issue, though. I'm pretty convinced it's a jailbreak issue.

I've been uninstalling and disabling my various tweaks to try and get to the bottom of the flakiness. My home button is fine after a respring or reboot but slowly gets more and more unresponsive until I basically can't use it at all. And I think I've narrowed it down to Activator. Now, Activator is one of the main reasons I jailbreak, so I don't like the idea of ditching it. But today I tried disabling its mobile substrate in SBSettings' "more" section. I thought this would disable it entirely but it seems to still work properly. And the best thing is that my home button has not lost responsiveness all day long without a single respring or reboot.

Now I've only tried this for a day, but I'd like some verification if anyone else is experiencing this symptom. Also, I'd like to know why disabling the Activator mobile substrate doesn't actually disable it! I'm not complaining if it works... just curious.
 

emhcee

Member
Bronze
Apr 4, 2008
246
12
18
#2
Interesting find... I've had that same flakiness as well with the home button, but had just chalked it up to the button getting mechanically worn out. Worth giving it a shot and see what happens.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#3
Still working like a charm. This was never a problem before updating from 4.3.3 to 5.0.1. It's been an everyday aggravation since. I really think this tweak, for whatever reason, has solved it for me. Just wish I knew what was really going on.
 

chazm

Contributor
Silver
May 1, 2008
729
40
28
#5
God I hope my 4S doesn't get this problem. All 3 of my iPhone 4's had this problem. So far, I'm ok. But I believe it's 100% hardware
 

chazm

Contributor
Silver
May 1, 2008
729
40
28
#9
IMO it's the iPhone 4. All 3 of my iPhone 4's had the home button problem. My GF's 4 has happened one 2 different phones and my roommate has the same problem. Now that I've had the 4S for over 4 months I haven't had a hiccup once.
 

djwindsor

Contributor
Silver
Jul 7, 2009
755
44
28
Neponsit, NY
#12
I agree and concur with the OP. I too had the same issue and narrowed it down to activator. I deactivated in MS and actually tried to delete it but when you try to delete it, quite a few other files I need will be deleted. I then compromised and turned off all the gestures since doing that essentially makes the app useless and non intrusive. I got a much better app which behaves perfectly. The one I got is zephyr and I use it with a swipe up gesture to emulate the home button. It works very well.
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
48
ATL
#13
Thanks. I'm going to try this out. I will say that my home button isn't as much a problem as the music app, which tends to crash a LOT recently. But it's crashing when I hit the home button to unlock if the screen went to sleep. I hit home, start to slide to unlock, and the whole thing freezes and then reboots to safe mode. Happens almost every time I use the music app now. If my crashes suddenly go away, then there is something really wrong with activator and its home button integration.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#19
haven't updated to 5.1 yet. So I guess that makes me 5.0.1? Yeah, I think that's it. It's been flaky for a while now though.
Yep, 5.0.1. You could try a restore to factory settings. If that doesn't work, it's almost certainly a hardware-related problem. There isn't much to lose in testing it since you can backup right before you restore and then apply the backup after testing it. IMO, the home button on the iPhone 4 tends to wear out sooner than it did on the older iPhones. I doesn't affect all of them, but it isn't uncommon and Apple will replace them for free if it's under warranty. They sometimes replace them for free even if they are out of warranty.
 

Bakuto

New Member
Jun 26, 2012
1
0
1
#20
So like a lot of people, my home button can be rather unresponsive at times. I've all but ruled out a hardware issue, though. I'm pretty convinced it's a jailbreak issue.

I've been uninstalling and disabling my various tweaks to try and get to the bottom of the flakiness. My home button is fine after a respring or reboot but slowly gets more and more unresponsive until I basically can't use it at all. And I think I've narrowed it down to Activator. Now, Activator is one of the main reasons I jailbreak, so I don't like the idea of ditching it. But today I tried disabling its mobile substrate in SBSettings' "more" section. I thought this would disable it entirely but it seems to still work properly. And the best thing is that my home button has not lost responsiveness all day long without a single respring or reboot.

Now I've only tried this for a day, but I'd like some verification if anyone else is experiencing this symptom. Also, I'd like to know why disabling the Activator mobile substrate doesn't actually disable it! I'm not complaining if it works... just curious.

Thanks a lot! My button worked so sporadically I wanted to throw the phone at times... Disabling Activator in mobile substrate worked for me... Also only happened after upgrading to v5.1. Thanks again!