Home WiFi not connecting

rbaron

Member
Bronze
Jan 18, 2007
69
0
6
#1
I am sitting at home typing this on a MacBook Pro connected to my Airport Extreme router. Surfin' away to where ever I want.

My iPhone on the other hand is using the "E" AT&T network.
If I go into settings it shows my home network. When I tap on it it opens a new window.

DHCP: 169.254 etc
Sub Mask: 255.255 etc
Router: blank
DNS: blank

So what do I need to do to get it connected to my home network?
When I click settings then WiFi under "Chose a Network" my network has a "check mark" next to it but according to the top of the screen it is surfing using the "E" network.

Can someone help?

Thanks in advance...
 

rbaron

Member
Bronze
Jan 18, 2007
69
0
6
#2
Never mind.... I got my iPhone to connect to my network.
 

AlexL99

New Member
Sep 8, 2007
1
0
0
#3
I have spent hours trying to get my new iPhone at home. I can connect to an open network, so it's not the iPhone.

I have a linksys router. I have the correct key. I have tried changing DNS server, static IP , and a million other things that I have found on this forum and others.

Is there anyone who can point me to something that might help.

Thanks in advance
A
 
Sep 6, 2007
6
0
0
#4
Not enought information!

Please describe: router model and settings (DHCP server or not, encryption: no, WEP, WPA, MAC filter: enable, disable and so on). iPhone settings too.
Error message?
 
Oct 24, 2007
1
0
0
#5
i had the same problem with mine...

you know when you scan for wireless routers and it comes up with yours...don't click it and enter the wep..

you have to manually type in the router name and then select the security type ...

i hope this helps!




I have spent hours trying to get my new iPhone at home. I can connect to an open network, so it's not the iPhone.

I have a linksys router. I have the correct key. I have tried changing DNS server, static IP , and a million other things that I have found on this forum and others.

Is there anyone who can point me to something that might help.

Thanks in advance
A
 
G

Gadgetgirlz

Guest
#6
I think I figured this out!

WiFi password problem solved.

I posted it on my blog, here is the Link

I hope this works for you :)
 

scandalex

Member
Silver
Sep 16, 2007
771
0
16
#7
WiFi password problem solved.

I posted it on my blog, here is the Link
LINK REMOVED.
I hope this works for you :)
So in order to know what may be so helpful, it requires visiting your blog to read? Guess I'm trying to rationalize it in my mind why you just couldnt post it here.

You got a hit counter on your blog or something....?
 

wusiswug

New Member
Feb 19, 2009
2
0
0
#8
When I first got my Touch, I was able to connect to the internet at home...all my settings were in place. Recently I haven't been able to connect and I noticed that all my settings are gone. How do I retrieve those settings? I always thought the Touch would automatically connect if there is a wifi in range. I'm able to connect everywhere else.

Thanks in advance.
 

Emerica

New Member
Bronze
Feb 5, 2009
82
0
0
#9
Have you searched for the connection in range?

Is your modem and everything on and internet working?
 

wusiswug

New Member
Feb 19, 2009
2
0
0
#10
Yes, I can see my network and it is connected (with a check), however the IP address fields are all blank.

Yes, modem and wifi working fine on my notebook but not on my Touch.

Thanks.
 

teineg

New Member
Feb 19, 2009
1
0
0
#11
Os there a way that I can access any locked wi fi ports on my ipod touch 2nd generation
 
Mar 2, 2010
5
0
0
RI
#12
1) Go to your Mac computer>Airport Utilities>Access>click the "+" button on lower right of screen>type in your phone's Wi-Fi Address>click Update
2) To find your phone's Wi-Fi Address go to your iPhone>Settings>General>About>scroll down to "Wi-Fi Address"

This solved the problem for both my 2G and 3GS phones. I now can use a password to access the network, and both my phones and my Macbook all connect no problem.
 

uly

Member
Bronze
Nov 7, 2009
39
0
6
#13
I've been having problem with wi-fi connections for a while since updating to iOS 4.0.1 (jailbroken).

Specifically, what happens is that I can connect to the wi-fi network as usual, and the wifi icon shows up in the status bar just fine. But when I actually use Safari to open a page, I will get a "no internet connection" error.

At this point, if I check the DHCP details for the wifi network, I usually see that there is no IP addresses for router or DNS server, so I suspect this may be a DHCP error, but I can't be sure.

The problem can usually be fixed by doing a hard reboot (NOT a respring), but sometimes the problem will persist even after a few reboots.

Lastly, this problem happens rarely on my home wi-fi, but almost everytime on public wi-fi networks.

Any idea how I can fix this problem?
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#15
Almost sounds like the router is not set for dhcp.
 

uly

Member
Bronze
Nov 7, 2009
39
0
6
#16
Yes, I've tried resetting the network settings.

I'm tempted to think that it's a router error, too, but the fact is that this problem happens only with my iPhone. Other devices can connect to the network just fine, and the same problem happens to this iPhone on several networks.

Alternatively, what happens sometimes is that I would be connected to the WiFi network, and the DHCP settings are showing up fine, but the WiFi icon won't appear in the status bar. When I fire up Safari, I get "Safari cannot open the page because it is not connected to the internet". If open SBSetting, I see that Wi-Fi is indeed off. But if I turn on Wi-Fi from SBSetting, then close SBS, then open SBS again, Wi-Fi will again be turned off. Basically, I cannot turn on Wi-Fi.

EDIT:
Even as WiFi appears turned off in SBS, I can still see my WiFi IP address at the bottom.
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#17
I have a weird problem at my girlfriends condo. If I connect before she does on her laptop, my phone knocks her off constantly. It seems that they were fighting for the same IP address. My solution was to statically set the IP address to something at the top end of the routers address range.
Example. If her laptop is 192.168.1.10, the I set my IP as static to 192.168.1.120. So far there hasn't been a problem since.
And it's ONLY with the iPhone, my laptop doesn't interfere with hers at all.
 

uly

Member
Bronze
Nov 7, 2009
39
0
6
#18
I have a weird problem at my girlfriends condo. If I connect before she does on her laptop, my phone knocks her off constantly. It seems that they were fighting for the same IP address. My solution was to statically set the IP address to something at the top end of the routers address range.
Example. If her laptop is 192.168.1.10, the I set my IP as static to 192.168.1.120. So far there hasn't been a problem since.
And it's ONLY with the iPhone, my laptop doesn't interfere with hers at all.
Oh yeah, that's happened in one of my friend's place as well. Not sure if this applies to other cases, though.

On my home network, there are 2 laptops plus this iPhone. I have set the WiFi router to always give a specific IP for each of these devices, so IP conflict shouldn't be a problem.
 

Mthoroughbred

Zealot
Silver
Dec 16, 2008
747
102
43
#19
Yes, I've tried resetting the network settings.

I'm tempted to think that it's a router error, too, but the fact is that this problem happens only with my iPhone. Other devices can connect to the network just fine, and the same problem happens to this iPhone on several networks.

Alternatively, what happens sometimes is that I would be connected to the WiFi network, and the DHCP settings are showing up fine, but the WiFi icon won't appear in the status bar. When I fire up Safari, I get "Safari cannot open the page because it is not connected to the internet". If open SBSetting, I see that Wi-Fi is indeed off. But if I turn on Wi-Fi from SBSetting, then close SBS, then open SBS again, Wi-Fi will again be turned off. Basically, I cannot turn on Wi-Fi.

EDIT:
Even as WiFi appears turned off in SBS, I can still see my WiFi IP address at the bottom.
Try resetting the router thats happen to me before and that happens to do the trick.
 

uly

Member
Bronze
Nov 7, 2009
39
0
6
#20
Try resetting the router thats happen to me before and that happens to do the trick.
Well, the only router I can reset is my own home router, and this is where I have the least problem. I can't really go around resetting people's routers, much less public hotspots.