How do I get Email app to properly put in correct From address?

SmartAlx

Zealot
Gold
Jun 7, 2007
1,087
8
38
What the heck?

I have a professional gmail account forwarding to my main non-professional personal gmail account. *It's so much more convenient to not have to check two accounts. *But I often need to reply to the emails, but I CAN NOT have my return address be my smartalx account name. *Completely unprofessional! *The desktop version of gmail has a setting that automatically keeps the From address correct. *I assumed that it worked the same way on the iPhone, but nope!

Sonofa...

Now I'm sending emails to profesional clients with my snarky smartalx gmail account name! I can't have that! *I know I can set the from address manually but I can't be expected to remember to do that every single time I reply to a client. *I send too many and too fast. Why doesn't the iPhone email app work the same way as gmail does? I know it's Apple and not gmail but COME ON! I know I'm not the only person who has to deal with this issue.

Any thoughts on this issue?
 

SmartAlx

Zealot
Gold
Jun 7, 2007
1,087
8
38
Aww cmon. There is no way I'm the only person in the world who has to deal with this.

Anyone?
 

iNinja

Zealot
Gold
Aug 8, 2008
3,986
20
38
UK
I don't relate to your problem, and I don't encounter it because I use one email address.

However, you can have a way around it by setting up 2 email accounts on the iPhone. 1 using the gmail set up and 1 using microsoft exchange. That way you can check you work and personal email s easily and not reply from your other account. Not the neatest solution but it will work.
 

Jack06

Member
Bronze
Jan 6, 2009
122
0
16
I think 4.0 has something relating to this, two or more email addresses in the same mailbox. Even has the option to see each mailbox differently, and probably to send emails from each mailbox separately.
 

Eninety2

Member
Silver
Jul 22, 2008
568
9
18
What the heck?

I have a professional gmail account forwarding to my main non-professional personal gmail account. *It's so much more convenient to not have to check two accounts. *But I often need to reply to the emails, but I CAN NOT have my return address be my smartalx account name. *Completely unprofessional! *The desktop version of gmail has a setting that automatically keeps the From address correct. *I assumed that it worked the same way on the iPhone, but nope!

Sonofa...

Now I'm sending emails to profesional clients with my snarky smartalx gmail account name! I can't have that! *I know I can set the from address manually but I can't be expected to remember to do that every single time I reply to a client. *I send too many and too fast. Why doesn't the iPhone email app work the same way as gmail does? I know it's Apple and not gmail but COME ON! I know I'm not the only person who has to deal with this issue.

Any thoughts on this issue?

I can relate, I went through this last year. There is a workaround but it's really a trade off.

You have to input your settings for your gmail account manually, as in you can't select gmail from the list. You need to get the incoming and outgoing servers from googles help page. When you are punching all of your info in, when you get to the field that asks what your email address is you put in both the email that you are registering and the one that you have forwarded. When you compose an email and you hit the from tab it will give you your other "professional" email.

Now the trade off. It can only be done as an imap account, there is no support for this through exchange.


I think 4.0 has something relating to this, two or more email addresses in the same mailbox. Even has the option to see each mailbox differently, and probably to send emails from each mailbox separately.
Unfortunately, that doesn't solve the OP problem. In order for him to use the universal inbox he would have to register the email in question into the iPhone.
 

SmartAlx

Zealot
Gold
Jun 7, 2007
1,087
8
38
You all aren't paying attention. I DO have two email accounts set up on my iPhone. In fact I have 3. That is the whole point. The app STILL doesn't automatically put in the correct "from" address, even though it's available. It wouldn't even be available if I didn't have both accounts linked to the phone.
 

jmp316

Evangelist
Gold
Jul 10, 2008
1,048
141
63
This is odd. I have 2 gmail accounts setup in the mail.app on my iPhone, and similar to you, 1 for work and 1 for personal. I have never had any problems with anything the OP has stated...

Maybe delete the accounts and start over...
 

SmartAlx

Zealot
Gold
Jun 7, 2007
1,087
8
38
And by the way, as a gmail user who uses gmail the way google intends, I am unimpressed with Apple's new multiple inbox feature in 4.0. I don't need that. I already have 5 gmail accounts forwarded to my main 6th Gmail account and I rarely have the need to logout and switch to one of those 5 separate accounts. I've had it set up that way for 3 or 4 years and it works perfectly... not so much on my iPhone. Hence the OP.

What I need is for the "All Mail" label to work properly. For Gmail, All Mail is the same thing as a lot of people's inbox, the main repository for new mail. So I need it to be the "default" "folder" when the iPhone's mail app opens up, and for it to be placed correctly at the top of the list of "folders", for when I need to switch to drafts or other labels... er... folders. I'll be whining about that in another thread pretty soon.
 

SmartAlx

Zealot
Gold
Jun 7, 2007
1,087
8
38
Eninety2, I already do that. That's what I'm complaining about. I have to change the address MANUALLY. It's one more thing I have to check every time I send an email, and it's not a habit to check it because gmail does it automatically, but the iPhone's email app doesn't.
 

KrakaJap

Zealot
Gold
Jul 7, 2009
1,620
25
48
43
IL
SmartAlx said:
You all aren't paying attention. I DO have two email accounts set up on my iPhone. In fact I have 3. That is the whole point. The app STILL doesn't automatically put in the correct "from" address, even though it's available. It wouldn't even be available if I didn't have both accounts linked to the phone.
Are you setting your default email address correctly in the general Mail settings? In order to use the proper mail account as "from" you have to begin the email reply or composition from one of the folders in that account. For example, select the inbox of your "professional" account and compose a new email. If you don't have your professional account set up by itself on your phone I don't know if there is a way to do this. I've never input 2 email addresses in a single account before so I have no idea if that actually works. But from my understanding, if you have mail forwarded to another account that is set up on your phone then replies will only be sent from the forwarding account and not the forwarded account.


Sent from my iPhone using iCafe app
 

SmartAlx

Zealot
Gold
Jun 7, 2007
1,087
8
38
jmp, do you have your professional email forwarding to your personal email account? I do. I ONLY use my personal account. All the professional account is used for is the email address itself. I never have to ever log into that account. Ever.

Here's how it works.

Someone emails blah@gmail and my blah account forwards it to zing@gmail. I never need to open my blah account this way. I find it iny zing account. When I need to reply to the blah email I can't have zing@gmail in the from field. And Google understands this. But Apple doesn't. Gmail automatically makes the from address blah@gmail, even though I'm reading and composing the emails in zing@gmail. But for the iPhone, you have to change the address manually.

The ONLY reason I have 3 accounts set up on my iPhone at all is to get the email addresses in my 'from' dropdown list.

Gmail, in a browser, automatically sends replies with the correct from email address. The iPhone doesn't.
 

SmartAlx

Zealot
Gold
Jun 7, 2007
1,087
8
38
KrakaJap

Yes, I know how it works. It shouldn't work that way though. In gmail I don't have to manually change the from address.

But from my understanding, if you have mail forwarded to another account that is set up on your phone then replies will only be sent from the forwarding account and not the forwarded account.
That's PRECISELY the way I wish it worked... mail being sent from the forwardING account instead of the forwardED account. Too bad it's really the opposite.
 

KrakaJap

Zealot
Gold
Jul 7, 2009
1,620
25
48
43
IL
jmp, do you have your professional email forwarding to your personal email account? I do. I ONLY use my personal account. All the professional account is used for is the email address itself. I never have to ever log into that account. Ever.

Here's how it works.

Someone emails blah@gmail and my blah account forwards it to zing@gmail. I never need to open my blah account this way. I find it iny zing account. When I need to reply to the blah email I can't have zing@gmail in the from field. And Google understands this. But Apple doesn't. Gmail automatically makes the from address blah@gmail, even though I'm reading and composing the emails in zing@gmail. But for the iPhone, you have to change the address manually.

The ONLY reason I have 3 accounts set up on my iPhone at all is to get the email addresses in my 'from' dropdown list.

Gmail, in a browser, automatically sends replies with the correct from email address. The iPhone doesn't.
This works in gmail because you are using a gmail system for both accounts. This will not work the same on the iPhone since they are not maintaining your gmail accounts. If it did perform the same way, then if anyone else forwarded an email to your account and you replied, it would be sent from the original email account listed in the forward. Definitely not safe. The only way I could see this working is if you provided your forwarding account information that could be validated before sending (which if I understand you correctly, you have). But again... this is not Apple's email system and it does not work this way. I tried eninety2's solution and I suppose it works... it just seems to be a pain to have to remove the email address you're not going to be replying from each time.

If you are going to be replying to professional emails from your iPhone then you must have your professional account set up on your iPhone and only reply to emails listed there and not the forwarded ones on your main account.

Yes, I know how it works. It shouldn't work that way though. In gmail I don't have to manually change the from address.
I understand what you're trying to do and agree that it would make it easier for those with multiple gmail accounts in which one is acting as the master account. But unfortunately there is no way to effectively do this on the iPhone.
 

SmartAlx

Zealot
Gold
Jun 7, 2007
1,087
8
38
KrakaJap

This works in gmail because you are using a gmail system for both accounts.
Actually, it works in gmail because Google has designed it to work properly. If the professional account was hotmail, or msn, or mybusinesss.com, gmail would still input the correct 'from' address.

Apple understands the need for it, and that's why they developed the universal inbox. But (in typical Apple fashion) the implimentation will be too short sighted and incomplete. Filtering is essential for someone with a lot of businesss email and the inbox isn't the appropriate place for new mail when you know its source and purpose. If you can filter an incoming email and keep your email account organized, you should. The inbox is only for mail that can't get sorted.

This will not work the same on the iPhone since they are not maintaining your gmail accounts. If it did perform the same way, then if anyone else forwarded an email to your account and you replied, it would be sent from the original email account listed in the forward. Definitely not safe.
Well, gmail doesn't actually "forward" the email, the way you do when you press the Forward button, inserting FW: on the subject line. It sends email in a POP or IMAP sort of way. The iPhone works the same way, so really there shouldn't be any difference. I think the iPhone is just pulling the from address from the wrong header. There is more than one "to" address in an email head.
If you are going to be replying to professional emails from your iPhone then you must have your professional account set up on your iPhone and only reply to emails listed there and not the forwarded ones on your main account.
No, I have it set up right. I still don't ever ever have to open up my professional account on my iPhone, although I do have to have it set up, but JUST to get the email address into the from dropdown. I can most certainly still email from my master personal account. The professional email address *is* available in the dropdown. I just have to be diligent about making sure the from address is correct.
 

SmartAlx

Zealot
Gold
Jun 7, 2007
1,087
8
38
Oh, I actually do have to open up my professional account from time to time on my iPhone. Another complaint. When I first compose an email and I think ahead to change the from field, then save the email for later, the iPhone removes the email from my active account and places it into my professional account. So when I go to drafts, it's not there. This presents two problems: the obvious... having to switch accounts constantly. What a chore. But the main issue is this means that when I change the from field, I'm actually changing ACCOUNTS! This is ABSOLUTELY incorrect. When I send an email from an account, I expect it to go to the SENT folder in THAT account. The iPhone voilates that.
 

KrakaJap

Zealot
Gold
Jul 7, 2009
1,620
25
48
43
IL
Well like Jack said... this "might" be corrected with OS4.


Sent from my iPhone using iCafe app
 

jmp316

Evangelist
Gold
Jul 10, 2008
1,048
141
63
Alx,

I have 2 accounts on the phone. I guess I misunderstood your post/question. I've never tried to forward my work to my personal. As someone else stated, I would wait a week or so until OS 4.0 comes out and play with it then...

Sorry I couldn't be more of a help...

J
:)
 

Eninety2

Member
Silver
Jul 22, 2008
568
9
18
I believe if you turn off all the smtp servers in your settings except the one you want to handle your outgoing mail you will get what I think you are after. Try sending an email to yourself and see what it says. Don't pay attention to what the sending address says when composing the email, just send it.