How do I remove autofill email addresses?

Bill K

New Member
Oct 10, 2009
4
0
1
#21
For jailbroken phones only. Install Autofill Eraser from Cydia for free. Pick the email address you want to remove from an alphabetical list. Neat and easy.

How could Apple not acknowledge and fix this annoying problem. This is why Apple needs the JB hackers- to make the iPhone more user-friendly.
 

UtopkY

New Member
Dec 3, 2013
1
0
1
#22
Anyone with a solution which does not involve thrid-party apps?
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,849
1,001
113
66
Florence, AL
#23
Mine doesn't auto fill that way. It just shows a list of addresses I've emailed. I have to tap on an address for it to fill. So if there's one on the list I don't want, I just don't tap it.


Sent using iCafe app
 

RoofMonkey

Genius
Gold
Jun 21, 2010
8,895
2,059
113
Florida
#24
Anyone with a solution which does not involve thrid-party apps?
From your iPhone start typing the name of the person you would like to email.
When you see the old email address click the arrow to the right of that old email and click "Delete from Recents"
This feature came out with iOS 6.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#25
From your iPhone start typing the name of the person you would like to email.
When you see the old email address click the arrow to the right of that old email and click "Delete from Recents"
This feature came out with iOS 6.
In the email app? I tested it and I don't see an arrow to the right.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,849
1,001
113
66
Florence, AL
#26
Some emails have a circled i to the right. Not all do. Junk stuff and some legit. Tap the circled i, and it gives you the option to delete. My example is some junk bogus stuff. But a few legit emails had it too. It may be non contacts have the circled i.
ImageUploadedByiCafe Forums1386105678.312505.jpg

ImageUploadedByiCafe Forums1386105698.525891.jpg



Sent using iCafe app
 
Last edited:

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#27
That doesn't work for me in most cases...even if it's a contact I haven't written to for years. I type in the letter "m" and a bunch of emails come up - none of which have an info button (or an arrow). When I type in the letter "r" about 15 emails come up - two of which have an info button and the option to remove from recents.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,849
1,001
113
66
Florence, AL
#28
That doesn't work for me in most cases...even if it's a contact I haven't written to for years. I type in the letter "m" and a bunch of emails come up - none of which have an info button (or an arrow). When I type in the letter "r" about 15 emails come up - two of which have an info button and the option to remove from recents.
It may be based on time. I can't tell. I have a lot of those. Doesn't seem to have a rhyme or reason.


Sent using iCafe app
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,849
1,001
113
66
Florence, AL
#29
That doesn't work for me in most cases...even if it's a contact I haven't written to for years. I type in the letter "m" and a bunch of emails come up - none of which have an info button (or an arrow). When I type in the letter "r" about 15 emails come up - two of which have an info button and the option to remove from recents.
It is old outdated email, as long as it's not a contact. Looked it up.


Sent using iCafe app
 

RoofMonkey

Genius
Gold
Jun 21, 2010
8,895
2,059
113
Florida
#30
Guess it changed from an arrow to the circled i.
I just tried it and had a few that I could remove from recents.
 
Jul 13, 2011
116
5
18
#31
The case is similar with autofill contact entries. When you click on the "i" symbol, I don't always have the "Remove from recents" link. I don't have a clue why.

Here's an example of how to remove the iPhone contacts suggestion entries but as mentioned the "Remove from recents" link is not always there:

 
Last edited:

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#32
The case is similar with autofill contact entries. When you click on the "I" symbol, I don't always have the "Remove from recents" link. I don't have a clue why.
@Ledsteplin pointed out a few days ago that the option for removing from recents will not appear if they are an existing contact.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,849
1,001
113
66
Florence, AL
#33
@Ledsteplin pointed out a few days ago that the option for removing from recents will not appear if they are an existing contact.
Right. And I assume that to remove a contact email from recents, you'd first have to delete the contact. Or maybe just the contacts email address listed in that contacts info.


Sent using iCafe app