How to block caller id on iPhone 5 iOS 7.1.1?

MrMike6by9

Evangelist
Gold
Nov 16, 2008
1,482
120
63
69
Maryland, USA
#2
It's likely a country or carrier issue. I turned off mine (USA/ATT) and called my landline. It shows as "private" on that phone. Personally, we configure our landline to block all "caller ID hidden" calls.
YMMV