How to easily jailbreak 1.1.3 with the FULL jailbreak (Windows/Mac)

Imahottguy

New Member
Jun 11, 2007
28
0
0
Lansing, MI
www.freemod.net
Gaw, I h8 it when people quote a long media rich post...

Anyways, I did the jailbreak/unlock on my OOTB 1.1.2 phone that was freshly restored to 1.1.3. I guess that I did a no-no? I had it restore my iPhone from the last backup ( all the settings and such ) and then did the JB/Unlock. I was able to fix Mail and the google locator, however I experience this last issue: It seems at random, but Mobile Safari will default back to having three open tabs (from before the restore and JB/Unlock). This doesn't change when I delete the cache, history and cookies. It also keeps all my cookies and history from before I restored. I really don't want to have to go through this again, I'm thnking that there is some sort of permissions issue, so I've checked several places using mobile finder, with no luck. Anyone have any ideas? Thanks everyone.
 

Hawk

Genius
Gold
Aug 2, 2007
6,683
241
83
50
ATL
Thisis probably a very dumb question, but after clearing the cache and history, did you close the 2 extra browser windows?
I would do that and reboot.
 

mcaram16

Member
Silver
Jul 26, 2007
715
0
16
Long Island, NY
Error Received, now what?

When i click Jailbreak and Verbose boot (debug) then click start i get the following error in the Progress log:

This application has requested the Runtime to terminate it in an unusual way. Please contact the applications's support team.

Has any received this error, if so, now what?
 

chaunce

New Member
Oct 22, 2007
23
0
0
Pics/Notes not saved

Been through the process a number of times. I experienced the mail and youtube issues, but resolved them by not checking the activation box in the GUI Mac version of ziPhone. I thought I was set until I tried to take a picture. Got the blank box. When I go to the pics application, the blank box disappears. Additionally, my notes are no longer saving. An existing note will accept an update, but I can't save new notes.

In messing around, I see in my finder applications folder that the mobile slide show.app shows a question mark next to it, but does launch when I click it within finder. I've deleted the com.apple.mobielslideshow.plist with no impact (same with mobilenotes). I attempted to delete my 100Apple folder with my pics in it, but I can't.

I'll obviously try a restore and rejailbreak, but I'm pretty sure that something in my backup/restore file is corrupted, so I'm thinking I may need to set up as a new iPhone (which isn't the end of the world).

Before I went through the trouble though, I wondered if anybody had any suggestions.

I got greedy - I had a jailbroken 1.1.3 set up as I liked with everything working (albeit with root user permissions), except for movie rentals and google maps (without the workaround). Now, that stuff works, but the camera and my notes app don't.

Thanks!
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
Been through the process a number of times. I experienced the mail and youtube issues, but resolved them by not checking the activation box in the GUI Mac version of ziPhone. I thought I was set until I tried to take a picture. Got the blank box. When I go to the pics application, the blank box disappears. Additionally, my notes are no longer saving. An existing note will accept an update, but I can't save new notes.

In messing around, I see in my finder applications folder that the mobile slide show.app shows a question mark next to it, but does launch when I click it within finder. I've deleted the com.apple.mobielslideshow.plist with no impact (same with mobilenotes). I attempted to delete my 100Apple folder with my pics in it, but I can't.

I'll obviously try a restore and rejailbreak, but I'm pretty sure that something in my backup/restore file is corrupted, so I'm thinking I may need to set up as a new iPhone (which isn't the end of the world).

Before I went through the trouble though, I wondered if anybody had any suggestions.

I got greedy - I had a jailbroken 1.1.3 set up as I liked with everything working (albeit with root user permissions), except for movie rentals and google maps (without the workaround). Now, that stuff works, but the camera and my notes app don't.

Thanks!
Not sure what the problem is with Notes, but check the permissions/ownership on /var/mobile/Library/Notes/notes.db

Mine is owned by mobile (group wheel) and the permissions are 0644.


As for camera roll photos I had an issue where I used Screenshot before restoring my settings. So /var/mobile/Media/DCIM/100APPLE/ was created. Then after restoring my settings I noticed new photos were going into /var/root/Media/DCIM/101APPLE/. I cleared out both folders, then deleted the folders themselves (via SSH). When I took a photo /var/root/Media/DCIM/100APPLE/ was recreated and all seems fine now.

BTW: This has happened to me in the past--as far back as 1.0.2 (but in /var/root, obviously).




--
Mike
 

patrickj

Genius
Gold
Sep 2, 2007
6,221
407
83
Austin, Tx
ipadinsight.com
As for camera roll photos I had an issue where I used Screenshot before restoring my settings. So /var/mobile/Media/DCIM/100APPLE/ was created. Then after restoring my settings I noticed new photos were going into /var/root/Media/DCIM/101APPLE/. I cleared out both folders, then deleted the folders themselves (via SSH). When I took a photo /var/root/Media/DCIM/100APPLE/ was recreated and all seems fine now.

BTW: This has happened to me in the past--as far back as 1.0.2 (but in /var/root, obviously).

--
Mike

I just noticed I had the same issue after reading these last couple posts - with new photos not showing up in Camera Roll that is. And I had also used the Screenshot app before taking any camera snaps.

Fix you suggest worked for me, with a slight variation - in that I found I did not have the second folder under the /var/root/Media ... path. Only had the first one (I guess created by Screenshot) - so removed its content, then the folder itself, and now all is glorious and happy in Camera-land ...
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
I just noticed I had the same issue after reading these last couple posts - with new photos not showing up in Camera Roll that is. And I had also used the Screenshot app before taking any camera snaps.

Fix you suggest worked for me, with a slight variation - in that I found I did not have the second folder under the /var/root/Media ... path. Only had the first one (I guess created by Screenshot) - so removed its content, then the folder itself, and now all is glorious and happy in Camera-land ...
What's funny is if I use Erica's snap2album it will create /var/root/Media/DCIM/100APPLE/ and place its shots there. Not a big issue as I usually grab the PNG from the /tmp anyway--or just use snap.

This doesn't affect the camera app, or anything else, as far as I can tell. Well, aside from the fact that the screenshot photos in /var/root don't show up in the camera roll, naturally.



--
Mike
 

thepunisher1991

New Member
Bronze
Jul 30, 2007
72
0
0
A simple how-to (Windows):

Update (02/11/2007 6:01 PM MST): Mac stuff removed from guide.
Update
(02/13/2007 9:51 AM MST): GUI version is out, much easier!
Update (02/13/2007 12:45 AM MST): ZiPhone 2.0 now out! Guide updated.

  • 1.) Perform a full restore to 1.1.3 via iTunes. You want to be on freshly restored 1.1.3. Don't bother syncing to iTunes, you can do that later. You can accept to restore from your previous backup now, or wait till your finished jailbreaking 1.1.3.
  • 2.) Download ZiPhone2.0.zip (download updated 2/13/2007 12:44 PM MST) and extract its contents into a folder on your computer. Under Windows I recommend creating the folder c:\ZiPhone and extracting the contents there.
  • 3.) Open "My Computer" and navigate to c:\ZiPhone, or wherever you extracted the contents of ZiPhone.zip. Double-click into the ZiPhone folder and then double-click ziPhoneGUI.exe
  • 4.) At the main ZiPhone GUI screen check-off Jailbreak and Verbose boot. Be sure not to forget to check Verbose boot! Click start.
  • 5.) That's it! You will have Installer on your springboard. Enjoy. Close ZiPhone GUI. (The actual jailbreak process takes less than 3 minutes!)
Success! By FAR this was way easier than the previous jailbreak methods.

--
Mike

what would be the method i would have to use if i am going from a 1.1.2 jailbroken iPhone trying to update to 1.1.3 with jailbreak :)
 
Last edited by a moderator:

chaunce

New Member
Oct 22, 2007
23
0
0
Not sure what the problem is with Notes, but check the permissions/ownership on /var/mobile/Library/Notes/notes.db

Mine is owned by mobile (group wheel) and the permissions are 0644.


As for camera roll photos I had an issue where I used Screenshot before restoring my settings. So /var/mobile/Media/DCIM/100APPLE/ was created. Then after restoring my settings I noticed new photos were going into /var/root/Media/DCIM/101APPLE/. I cleared out both folders, then deleted the folders themselves (via SSH). When I took a photo /var/root/Media/DCIM/100APPLE/ was recreated and all seems fine now.

BTW: This has happened to me in the past--as far back as 1.0.2 (but in /var/root, obviously).




--
Mike

Mike,

Thanks for that. My notes.db is owned by root with group: wheel. Permissions are set to 438. I don't have a ton of notes - I could probably just delete? If not, is it easy to change the permissions/owner?

As for the camera, I'll give that a try. I don't recall ever using screenshot, but I have used camerapro. I wonder if that caused the behavior.

Yeah, I unfortunately, like you, like to have the latest. I debated whether to push my luck, but I wanted to use rentals. I commute, so it was appealing. Anyway, thanks for the help. Much appreciated.

Chris
 

callisto9

Member
Bronze
Feb 12, 2008
403
1
16
IOWA
well, i bricked my phone. i had problems syncing my calendar after the Zibri jailbreak, so i installed the fix from iClarified and it bricked my phone. i was able to restore back to a clean 1.1.3, but i still can't sync my outlook calendar with my iPhone. :(
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
Mike,

Thanks for that. My notes.db is owned by root with group: wheel. Permissions are set to 438. I don't have a ton of notes - I could probably just delete? If not, is it easy to change the permissions/owner?

As for the camera, I'll give that a try. I don't recall ever using screenshot, but I have used camerapro. I wonder if that caused the behavior.

Yeah, I unfortunately, like you, like to have the latest. I debated whether to push my luck, but I wanted to use rentals. I commute, so it was appealing. Anyway, thanks for the help. Much appreciated.
You can change permissions via command line (you can use SSH). Use this:
chown mobile:wheel /var/mobile/Library/Notes/notes.db
chmod 0644 /var/mobile/Library/Notes/notes.db


And risk-taker that I am I set my Notes.db to root/wheel and sure enough I couldn't save notes. ;) (After going back to mobile/wheel it was OK again.)


--
Mike
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
what would be the method i would have to use if i am going from a 1.1.2 jailbroken iPhone trying to update to 1.1.3 with jailbreak :)
Yikes, no need to quote that entire post! With its size and image content it makes it a chore to read the forum, especially on an iPhone.

First update to 1.1.3. Then follow this guide, starting from the beginning (a full restore to a clean 1.13).


--
Mike
 

amiroo79

New Member
Bronze
Nov 3, 2007
217
0
0
Southern California
Mike,

Your step 4 seems confusing:

"4.) At the main ZiPhone GUI screen check-off Jailbreak and Verbose boot. Be sure not to forget to check Verbose boot! Click start."


You say to check off verbose boot in the first sentence and then say to check it in the second sentence. Which is it?

Also, any clue what the BL3.9 option on there is for? Because I have a 1.1.2 with BL3.9 as my phone came with 1.1.1 OTB.
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
Mike,

Your step 4 seems confusing:

"4.) At the main ZiPhone GUI screen check-off Jailbreak and Verbose boot. Be sure not to forget to check Verbose boot! Click start."


You say to check off verbose boot in the first sentence and then say to check it in the second sentence. Which is it?
Check-off, as in check the box (i.e., like checking off to-do list items).

EDIT: Verbose is not needed anymore with ZiPhone 2.1!



Also, any clue what the BL3.9 option on there is for? Because I have a 1.1.2 with BL3.9 as my phone came with 1.1.1 OTB.
If your phone works you don't need that. Don't even try it! It's a repair tool.


--
Mike
 

iphoneluverr

New Member
Aug 28, 2007
348
0
0
um tinman.. where is the file? the rapidshare one says its been deleted by the uploader, the only reason im doing this is because my friend is leaving out of state for awhile and he really wants this