How To Enable 3D Maps on Older iOS 6 Devices

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
700
113
#1
iOS 6's 3D Maps for some reason aren't compatible with the iPhone 3Gs, iPhone 4 and iPod Touch 4th Gen.

The iPhone Dev-Team released a bespoke version of Redsn0w; 0.9.13dev1 - This enables the user/jailbreaker to use SSH on their device. Redsn0w can be downloaded here for Mac and here for Windows.

Once you've jailbroken iOS 6 you will need to download the debian file (.deb) and install it onto your device via SSH. Navigate here (this is the main site) or download the .deb directly here (dropbox link).

Launch a Terminal type app on your device or simply use the Terminal interface through SSH (should be built into your client). Type the following: apt-get update

...next you will need to type: apt-get install mobilesubstrate

Using your SSH still, copy and paste/drag and drop your newly downloaded .deb file to /var/mobile

and type the following to complete:

cd /var/mobile

dpkg -i com.alpden.3denabler_1.0_iPhoneos-arm.deb

You should now reboot your device and enjoy 3D Map goodness.


 

fijiman

Contributor
Silver
Feb 13, 2011
832
64
28
UK
#4
The jailbreak is primarily for jailbreak devs.... had a quick look around ios6 file structure...still looks the same-ish...good for people who like to theme.... Can't wait for full release of IOS6.0 plus Untethered jailbreak....
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
700
113
#5
The jailbreak is primarily for jailbreak devs.... had a quick look around ios6 file structure...still looks the same-ish...good for people who like to theme.... Can't wait for full release of IOS6.0 plus Untethered jailbreak....
Hopefully we won't have to wait as long this time.