How to get sound working in NES.app in under 5 min

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

wildonrio

New Member
Gold
Jul 4, 2007
2,002
6
0
Provo, UT
#1
This small guide assumes you already have Installer.app on your iPhone. If not, read here and make special note of the asterisk.

1. Run Installer.app and download Erica Utilities, MobileTerminal, and BSD Subsystem. (If you don't see these things on the list, make sure you've downloaded Community Sources first.)
2. Go to MobileTerminal and type...
cd /usr/local/bin
Push return, and then type...
./sound no
And push return again. This turns off all other sounds on your phone.
3. Go play your game with sound :)
4. Make SURE that after you're done playing, you go back into MobileTerminal and type cd /usr/local/bin and then ./sound yes to get your normal phone sounds back on.

If you don't hear sound, make sure you've plugged in your headphones (this was the only sound I was able to get to play) and switched the sound source to headphones in your preferences.

By the way, the sound is not as great as you think. It's quiet and rather choppy sometimes :(. You can fix the choppiness a little by increasing the frame rate.
 
Last edited by a moderator:

domi

New Member
Bronze
Aug 13, 2007
84
0
0
Texas
#2
This small guide assumes you already have Installer.app on your iPhone. If not, read here and make special note of the asterisk.

1. Run Installer.app and download Erica Utilities, MobileTerminal, and BSD Subsystem. (If you don't see these things on the list, make sure you've downloaded Community Sources first.)
2. Go to MobileTerminal and type...
cd /usr/local/bin
Push return, and then type...
./sound no
And push return again. This turns off all other sounds on your phone.
3. Go play your game with sound :)
4. Make SURE that after you're done playing, you go back into MobileTerminal and type cd /use/local/bin and then ./sound yes to get your normal phone sounds back on.

If you don't hear sound, make sure you've plugged in your headphones - this was the only sound I was able to get to play.

By the way, the sound is not as great as you think. It's quiet and rather choppy sometimes :(. You can fix the choppiness a little by increasing the frame rate.
thanks for the useful post. you might want to edit step four though. it says cd /use/local/bin instead of cd /usr/local/bin
 
Last edited by a moderator:

Vpeach

Member
Bronze
Jun 30, 2007
74
0
6
#4
I tried this about 4 times and I can't get it to work. I did with and without the headphones.

Anybody else having difficulty?
 

Vpeach

Member
Bronze
Jun 30, 2007
74
0
6
#7
When you typed the ./sound no command in Terminal, what did it say to you?

it says Unloading audio daemon


when i play the game should i adjust the sound setting to headphones?
I ended up doing that and now I'm getting audio. It's choppy...just like you mentioned above..but it's a start!

Thanks so much!
 

elkay

New Member
Aug 29, 2007
28
0
0
Torrington, CT
#8
When I run MobileTerminal, I do not have a local folder in my /bin. Anyone else have this problem, or care to shed some light on where I'm going wrong here? Running firmware 1.0.2 and using the latest and greatest MobileTerminal.

EDIT:

Found out the problem. Didn't realize those additional commands were part of Erica's Utilities and BinKit. Installed those and now it's working as it should.