I lost my iPhone speaker sound

andyar85

New Member
May 24, 2008
3
0
0
#1
Just got my new iPhone with a 1.1.4 firmware version. I unlocked, jailbraked and activated it with ZiPhone 3.0, and everything was OK. started to enter my contacts manually, and at some point(I don't recall very well the exact moment) I realized that when I pressed the buttons I have no more sound coming out from my phone speaker. I'm very nervous because is brand new, so I tried some stuff that I Googled:
- the plug/unplug fast and slow out of the phone's jack
- the reset all settings
- clean the jack, even if the phone is new and no clog is there
- restore to it's factory settings(a full restore) and unlock again

I can still use it to make phone calls, I can talk and hear through my earphone, and everything is OK if I plug in the the headphone(buttons sounds and everything). But when I take out the headphones there is still no sound and I have to rely on my tiny vibrator to notify me when someone calls.

Have I done something wrong in the unlock process? the ZiPhone is one click do everything...so....

I tried listening very close to the phone's speaker and there is an attempt to play the sound(I hear the sound but very very low). so the speaker is still working but there is "not enough" signal to play since I hear a dimm sound.

Is there some link between the firmware, unlock program, iTunes version? should I try with a downgrade? or maybe a diferent unlocker or version of ziPhone?

I'm pretty worried that I even searched for new jack assembly for the iPhone, and found at about 25$, but since is a new phone I don't know if this is a hardware issue.

I've been reading there is the chance that the phone is trapped in headphone mode, but I can't seem to locate the sensor in the jack to see if there is something blocking it. If anyone knows some technical details on this please share. Is it just a contact that acts like a sensing sensor? Maybe if so there is a chance of a bad contact or something. It would help to have a jack schematic.....

Someone suggested to pwnage it(I'm on windows so winpwn)to solve the speaker issue, but I don't know how this should work? I'd be appreciative if someone tels me how to pwn it. should I restore back to 1.1.4 with iTunes and then pwn? Does it affect the unlocking or through winpwn I can Unlock, Activate and Jailbrake?

If anyone has any idea please let me know how to solve this issue.
 

MaverickC17

New Member
Bronze
Dec 29, 2007
178
0
0
#2
Sound

I had this happen to me also. Reseting All Settings fixed it.

Settings>General>Reset>Reset All Settings
 

andyar85

New Member
May 24, 2008
3
0
0
#3
Nope that doesn't work. Tried it already.
My speaker isn't dead since when I listen very close I can hear the sounds, but very low.

will winpwn do something as I was suggested?
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#4
Restore a few times in a row, and see if you get sound. If so, rejailbreak. If not, take it to Apple. It could be a hardware defect.

- John
 

andyar85

New Member
May 24, 2008
3
0
0
#5
restore multiple times ?
steps?
- put it in restore mode
- restore from iTunes
- check sound
- put it again in restore mode etc? how may times should I try? and only after the sound comes back(if it does...) rejailbreak?
 

Flyingstar

Member
Bronze
Jul 29, 2007
343
0
16
So. Cal
#6
this happened to me. I tried restore to no effect. took it back to Apple and they gave me a new phone no questions asked (bad earphone jack)
 
May 24, 2008
3
0
0
#7
Hi, I have firmware 1.1.4, and use ziPhone to unlock my phone, but I can't install the BSD subsystem is always in the reinstall folder together with the installer and the SSH....What can I do?